Kirjoittaja Aihe: Leap 15.3:ssa jatkuvia päivitysristiriitoja  (Luettu 3518 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 831
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Leap 15.3:ssa jatkuvia päivitysristiriitoja
« : 09.06.2021 - klo:12:02 »
Leap 15.3 vaikuttaa toistaiseksi paljon epävakaammalta kuin aikaisemmat versiot, mahdollisesti taustalla tehtyjen suurten muutosten takia. Erilaisia päivitysristiriitoja on ollut jatkuvasti.

Kansainväliselläkin openSUSE-foorumilla ehdittiin jo ihmetellä sitä, jossa readline-doc-paketti oli ristiriidassa paikkauksen kanssa, ja korjaukseksi siihen YaST ehdotti suurin piirtein koko järjestelmän poistamista. Itse yritin ratkoa asiaa YaSTissa, missä tuli sivu toisensa jälkeen ehdotuksia, joiden jälkeen aina piti painaa ”OK, yritä uudelleen”. Lopputuloksena sain sddm:n ja valtaosan Plasmaa poistumaan koneelta. Asensin koko järjestelmän uudelleen.

Tänään on sitten patch:SUSE-2020-3792-1.noarch ristiriidassa 'gzip.x86_64-paketin kanssa (ja kyllä, siinä on yksi ').

Ymmärtääkseni ratkaisu on toistaiseksi se, että ajaa komentorivillä zypper ref; zypper up, joka tekee kaikki mahdolliset päivitykset yrittämättä ratkoa ristiriitoja. Ohjelmapäivityssovelma vain pysähtyy ensimmäiseen virheeseen, ja jos lähtee YaSTissa ratkomaan ongelmaa, päätyy vain syöksykierteeseen, jonka tuloksena on toimimaton järjestelmä.
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed, CentOS Stream 9; kannettava 1: openSUSE Tumbleweed; kannettava 2: openSUSE Leap 15.4; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 831
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #1 : 10.06.2021 - klo:15:14 »
Asiasta on kansainvälisen openSUSE-foorumin, redditin yms. avustuksella selvinnyt, että ongelmia aiheuttaa zypper patch -komento, jollaista en tiennyt olevan olemassakaan ja jota en ainakaan koskaan ole käsin ajanut. Plasman ohjelmapäivityssovelma kuitenkin käyttää sitä.

Yksi suositus oli poistaa ohjelmapäivityssovelma kokonaan käytöstä Plasman ilmoitusalueen asetuksista ja ajaa ainoastaan käsin zypper up. Tilanne voi jatkua tällaisena vielä hyvän tovin.

Itse tekisi mieli suositella, että kaikki 15.3:een päivittämistä aprikoivat jättäisivät toistaiseksi sen tekemättä.
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed, CentOS Stream 9; kannettava 1: openSUSE Tumbleweed; kannettava 2: openSUSE Leap 15.4; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2720
  • Sukupuoli: Mies
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #2 : 12.06.2021 - klo:16:51 »
On kyllä ikävä bugi kun niin suora vaikutus loppukäyttäjälle.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1261
  • Sukupuoli: Nainen
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #3 : 13.06.2021 - klo:21:03 »
Ikävä juttu tuo päivitysongelma  :(
Mutta hyvä, että asiasta tuli tietoa, meinasin nimittäin päivittää äidin koneen  :)
Pöytäkone NUC Intel NUC8i7BEH, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
 Väinö-minibulli :D

Poissa Samuel

  • Jäsen
  • Viestejä: 357
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #4 : 19.09.2021 - klo:16:34 »
Tervehdys

Onko tilanne parantunut, nyt 19.9.21. Uskaltaakohan aloittaa koneiden päivittämisen opensuse leap 15.3 versioon?

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 831
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #5 : 19.09.2021 - klo:16:50 »
Tilanne on parantunut, mutta ainakin vielä viime viikolla iski erikoinen päivitysristiriita, jossa jotain YaSTin osia piti sallia poistettavan, jotta asennus saattoi mennä läpi. Mitään näkyvää seurausta siitä ei ollut YaSTin käyttöön.
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed, CentOS Stream 9; kannettava 1: openSUSE Tumbleweed; kannettava 2: openSUSE Leap 15.4; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

Poissa Samuel

  • Jäsen
  • Viestejä: 357
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #6 : 19.09.2021 - klo:17:31 »
Kiitos Oskar

Ehkä sitä vois yhteen koneeseen kokeilla :)

Poissa png

  • Jäsen
  • Viestejä: 329
  • Sukupuoli: Mies
Vs: Leap 15.3:ssa jatkuvia päivitysristiriitoja
« Vastaus #7 : 19.09.2021 - klo:17:38 »
Minulla on yhdessä Lenovo läppärissä ollut jo jonkin aikaa uusi 15.3. Leap, eikä päivitysten kanssa ole ollut suurempaa ongelmaa. Tämä on siis puhdas uusi asennus. 8)
Kukaan ei voi tehdä kaikkea, mutta jokainen
voi tehdä jotakin; ja jos jokainen tekee jotakin,
tulee kaikki tehdyksi.