Kirjoittaja Aihe: Optinen lähtö ja Suse 10.2  (Luettu 14272 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #20 : 11.01.2007 - klo:19:26 »
Johan nyt on kumma, muistitko tehdä sen alsa:n uudelleen käynnistyksen?
/usr/sbin/rcalsasound restart

jos vielä katsot alsamixeriä niin onhan varmasti IEC958 kohta aktiivinen ja äänet ei ole 0:ssa


Meikäläiseltä meinaa loppuu kohta konstit... ;(

tossa muutama kuva:






Mitenkäs näiden kanssa kävi?

Kokeile myös seuraavaa:
(huomaa myös välilyönti 0,2 /usr välissä)
aplay -D plughw:0,2 /usr/share/sounds/alsa/test.wav


PS. kokeile myös tämä ton välilyönnin kanssa
aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav


ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #21 : 11.01.2007 - klo:19:29 »
pingviini:~ # aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument


Kokeile myös seuraavaa:
(huomaa myös välilyönti 0,2 /usr välissä)
aplay -D plughw:0,2 /usr/share/sounds/alsa/test.wav


PS. kokeile myös tämä ton välilyönnin kanssa
aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav

pingviini:~ # aplay -D plughw:0,2 /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
pingviini:~ # aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin

Niin  ja tosiaan ei kuulunu ääntä. Olen resetoinu vahvarin, kaapelit kiinni( optinen(digi) ja rca(analog) ). Analoginen rca kiinni tape in liitännöissä ja musa kuuluu, Optinen asennossa ei kuulu mitään. Hiukan on hämärää.
« Viimeksi muokattu: 11.01.2007 - klo:19:33 kirjoittanut ronaldo09 »

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #22 : 11.01.2007 - klo:20:08 »
no kyllähän nyt temppuilee. Katson vielä huomenna jos keksisin jotain.
Koita vielä googlettaa kyseessä kuiten niin yleinen juttu, että ihmettelen jos jollain muulla ei ole vastaavia ongelmia ollut.

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #23 : 11.01.2007 - klo:20:15 »
ok
kiitos kun viitsit nähdä vaivaa. Aika ongelma kyl on

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #24 : 12.01.2007 - klo:08:54 »
Kokeile vielä seuraavaa näin toisella keskustelu palstalla, että jollain ei ollut kuulunut tolla aplay testillä mitään, mutta seuraavalla muutoksella Amarokkiin sai sieltä äänet kuulumaan.

Settings --> Configure Amarok --> Engine
Output plugin = alsa (oletuksena autodetect)
Speaker Arrangement= Pass Through

jos sinulla on mplayer asennettuna testaa myös sillä
mplayer /usr/share/sounds/alsa/test.wav -ao alsa:device=hw=0,2

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #25 : 12.01.2007 - klo:12:27 »
EI Helv#**i. Ei toimi. voisko Msi:n emos olla jotain linuxii vastaan. Ei vaan pelitä. Ääni kuulu hyvin taas Tape asennossa(analog) mut ku vaihdoin optical in niin hiljasta oli kun muuntajatehtaalla. Pian lentää kone ikkunasta!! :)

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #26 : 12.01.2007 - klo:12:45 »
niin ja ääni toistu tolla mplayerin komennolla analogisesti. Pystyskö ton laitteisto haun suorittamaan uudestaan. Että suse hakis automaattisesti asetukset ja laitteiston emolle.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #27 : 12.01.2007 - klo:13:01 »
EI Helv#**i. Ei toimi. voisko Msi:n emos olla jotain linuxii vastaan. Ei vaan pelitä. Ääni kuulu hyvin taas Tape asennossa(analog) mut ku vaihdoin optical in niin hiljasta oli kun muuntajatehtaalla. Pian lentää kone ikkunasta!! :)


No en lähtisi vielä konetta hajottamaan :)
Itse olen joskus taistellut erinäisten laitteiden kanssa ja joskus on ollut hyötyä bootata kone knoppix dvd:llä sekun tuntuu tunnistavan/konffaavan melkohyvin erinäisiä laitteita. Itselläni esim ei meinannut lähtee digitv kortti SuSEssa toimii ei sitten millään, mutta kun katsoin knoppixista millä kernelimoduulilla / konfeilla se siinä toimi niin sain toimimaan myös susessa.

Eli jos mahdollista kokeile erinäisillä live cd/dvd:llä jos se vaikka toimisi jossain muussa distrossa oletuksena ja kopio sitten sieltä nuo asetukset.

Valitettavasti en osaa oikein enempää auttaa. Jos nyt haluat vielä varmistaa että äänet menee alsalle niin tee seuraava komento.

strace -fe open aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
tarkista että sieltä löytyy rivit....

open("/dev/snd/controlC0", O_RDONLY)
open("/dev/snd/controlC0", O_RDWR)


ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #28 : 12.01.2007 - klo:13:22 »
Ei löytyny noita rivejä mitä mainitsit.

pingviini:~ # strace -fe open aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/usr/lib64/libasound.so.2", O_RDONLY) = 3
open("/lib64/libm.so.6", O_RDONLY)      = 3
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/lib64/libc.so.6", O_RDONLY)      = 3
syscall_273(0x2aff4f021ed0, 0x18, 0x7fff5c926158, 0x2aff4e1814a0, 0x2aff4f021e30, 0xff342d312d315e42, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3) = 0
open("/usr/lib/locale/locale-archive", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/usr/lib/locale/fi_FI.UTF-8/LC_CTYPE", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/locale/fi_FI.utf8/LC_CTYPE", O_RDONLY) = 3
open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
open("/usr/share/alsa/alsa.conf", O_RDONLY) = 3
open("/etc/asound.conf", O_RDONLY)      = 3
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument
Process 9439 detached
pingviini:~ #

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #29 : 12.01.2007 - klo:14:22 »
Ei löytyny noita rivejä mitä mainitsit.

pingviini:~ # strace -fe open aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/usr/lib64/libasound.so.2", O_RDONLY) = 3
open("/lib64/libm.so.6", O_RDONLY)      = 3
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/lib64/libc.so.6", O_RDONLY)      = 3
syscall_273(0x2aff4f021ed0, 0x18, 0x7fff5c926158, 0x2aff4e1814a0, 0x2aff4f021e30, 0xff342d312d315e42, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3, 0x3) = 0
open("/usr/lib/locale/locale-archive", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/usr/lib/locale/fi_FI.UTF-8/LC_CTYPE", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/locale/fi_FI.utf8/LC_CTYPE", O_RDONLY) = 3
open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
open("/usr/share/alsa/alsa.conf", O_RDONLY) = 3
open("/etc/asound.conf", O_RDONLY)      = 3
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument
Process 9439 detached
pingviini:~ #


tosta puuttuu taas se välilyönti
pingviini:~ # strace -fe open aplay -D hw:0,2/usr/share/sounds/alsa/test.wav

kokeiles uudestaan:
strace -fe open aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav


ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #30 : 12.01.2007 - klo:14:32 »
Tollanen tuli. ei ääntä optisesta..

pingviini:~ # strace -fe open aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav
open("/etc/ld.so.cache", O_RDONLY)      = 3
open("/usr/lib64/libasound.so.2", O_RDONLY) = 3
open("/lib64/libm.so.6", O_RDONLY)      = 3
open("/lib64/libdl.so.2", O_RDONLY)     = 3
open("/lib64/libpthread.so.0", O_RDONLY) = 3
open("/lib64/libc.so.6", O_RDONLY)      = 3
syscall_273(0x2ab0508daed0, 0x18, 0x7fff5b06e1b0, 0x2ab04fa3a4a0, 0x2ab0508dae30, 0xff342d312d315e42, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4, 0x4) = 0
open("/usr/lib/locale/locale-archive", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/share/locale/locale.alias", O_RDONLY) = 3
open("/usr/lib/locale/fi_FI.UTF-8/LC_CTYPE", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/locale/fi_FI.utf8/LC_CTYPE", O_RDONLY) = 3
open("/usr/lib64/gconv/gconv-modules.cache", O_RDONLY) = 3
open("/usr/share/alsa/alsa.conf", O_RDONLY) = 3
open("/etc/asound.conf", O_RDONLY)      = 3
open("/dev/snd/controlC0", O_RDONLY)    = 3
open("/dev/snd/controlC0", O_RDWR)      = 3
open("/dev/snd/pcmC0D2p", O_RDWR|O_NONBLOCK) = 4
open("/usr/share/sounds/alsa/test.wav", O_RDONLY) = 3
Playing WAVE '/usr/share/sounds/alsa/test.wav' : Signed 16 bit Little Endian, Rate 44100 Hz, Stereo
Warning: rate is not accurate (requested = 44100Hz, got = 48000Hz)
         please, try the plug plugin
Process 5148 detached
pingviini:~ #

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #31 : 12.01.2007 - klo:15:35 »
No kyllä tosta näkee, että se käy lukemassa /etc/asound.conf tiedoston ja oikeaan laitteeseen kamaa tungetaan ("/dev/snd/controlC0").

En kyllä ymmärrä. Voihan se olla, että tossa asound.conf filussa on jotain pielessä mutta en todellakaan ole mikään guru näissä asioissa  :(

kokeile nyt vielä sitä alkuperäistä asound.conf tiedostoa, mehän tehtiin muutoksia siihen.
Jos se ei auta niin kokeile vielä sitä knoppixia ja aja siellä noita samoja testi komentoja jos sattus siellä toimii niin kopio asound.conf tiedosto sieltä sitten talteen.
« Viimeksi muokattu: 12.01.2007 - klo:15:36 kirjoittanut harmie »

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #32 : 12.01.2007 - klo:18:20 »
niin alunperinhän mulla ei edes ollu sitä asound.conf tiedostoo siellä etc kansiossa. Aika hankala homma on kyl. Kokeilen sitä knoppista viel.