Kirjoittaja Aihe: Optinen lähtö ja Suse 10.2  (Luettu 14253 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

ronaldo09

  • Vieras
Optinen lähtö ja Suse 10.2
« : 09.01.2007 - klo:20:00 »
Ääni ei kuulu optisena suse 10.2:sta? Googlettelin ja löytykin ohjeita ( http://kotoistaminen.novell.fi/?sivu=optinen ), mutta 3päivää vanhana linux käyttäjänä tieto/taito ei riitä millään. Eli ilmeisesti pitää kääntää jotain confsys kansioon. löysin kaikki kansiot ja käännös ohjelmat mutta se käännös ei ilm. Ollu oikeen tai sit kansiotkin oli vääriä. Jos joku on saman rumban vetäny läpi niin neuvoja vois pistää.
Ja tosiaan pitäis saada siihen myös se amroK käännös siihen perään.
Kiitos etukäteen.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #1 : 11.01.2007 - klo:10:54 »
no aloitetaanpas alusta.

mikäli sinulla jo nyt siis on tiedosto /etc/asound.conf tee siitä varmuus kopio seuraavasti
sinun pitää olla root tai sitten käyttää sudoa

cp - p /etc/asound.conf /etc/asound.conf.backup

tämän jälkeen poista alkuperäinen tiedosto
rm /etc/asound.conf

seuraavaksi kopioi tuolta löytämästäsi artikkelista toi valmis conf filu. valitse vaikka hiiren oikealla painikkeella että tallenna tiedosto jonnekkin esim. kotihakemistoon.
http://kotoistaminen.novell.fi/data/asound.conf

siirrä sitten tiedosto tonne etc:n alle.
mv /home/<käyttäjä>/asound.conf /etc/

varmista että kaikilla on lukuoikeus tiedostoon ja että sen omistaa root.
chown root:root /etc/asound.conf
chmod 444 /etc/asound.conf

tämän jälkeen käynnistä alsa uudelleen.
/usr/sbin/rcalsasound restart

testaa sitten http://kotoistaminen.novell.fi/?sivu=optinen sivujen mukaisesti että äänet toimii, jos näin on niin lisää vielä se amarok conf tonne /etc/asound.conf tiedoston loppuun. Voit käyttää mitä teksti editoria, muista avata se roottina että voit tallentaa sen.
Jos taas äänet ei toimi älä jatka vielä eteenpäin vaan laita tänne mahdolliset error messut.


tämän jälkeen käynnistä alsa uudelleen.
/usr/sbin/rcalsasound restart

Sitten vielä muutokset Amarok:iin...
"Talleta tiedosto ja käynnistä ALSA uudelleen. amaroKissa täytyy vielä vaihtaa seuraavat asetukset:
-> settings -> configure amarok -> engine -> kohtaan output plugin "esdsink", ja napsauta "apply"."

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #2 : 11.01.2007 - klo:16:30 »
Ei kuulu mutta ei tullu kyllä virheitäkään.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #3 : 11.01.2007 - klo:17:17 »
Ei kuulu mutta ei tullu kyllä virheitäkään.

onhan sinulla kaikki äänisäädöt päälle ettei joku ole mykistetty / säädöt minimissä.
avaa komentoriviltä alsamixer ja tarkista. Tarkista myös YaST:lla menemällä kohtaan Hardware --> Sound
Tee tääältä volume testi kohdasta Other --> volume --> test


ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #4 : 11.01.2007 - klo:17:25 »
kaikki päällä ja volumea löytyy mutta ei ääntä.

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #5 : 11.01.2007 - klo:17:48 »
Kuinkas Kmixissa, onko PCM tapissa päällä ja tapissa.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #6 : 11.01.2007 - klo:17:50 »
kaikki päällä ja volumea löytyy mutta ei ääntä.


Mitä tulostaa seuraavat komennot
aplay -l
ja
cat /proc/asound/devices

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #7 : 11.01.2007 - klo:18:00 »
aplay -I:

**** List of PLAYBACK Hardware Devices ****
card 0: CK804 [NVidia CK804], device 0: Intel ICH [NVidia CK804]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: CK804 [NVidia CK804], device 2: Intel ICH - IEC958 [NVidia CK804 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0


JA cat /proc/asound/devices:

2:        : timer
  3: [ 0- 2]: digital audio playback
  4: [ 0- 1]: digital audio capture
  5: [ 0- 0]: digital audio playback
  6: [ 0- 0]: digital audio capture
  7: [ 0]   : control
  8:        : sequencer



ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #8 : 11.01.2007 - klo:18:01 »
Kuinkas Kmixissa, onko PCM tapissa päällä ja tapissa.

Niin ja tapissa oli myös PCM.

Onko sitten jotain muita asetuksia mistä pitää valita jotain?? Kuten esim. winukassa oli että sai valita toki se oli msi:n oma ääni ohjelmisto mut sieltä piti esim valita digital tai analog tai molemmat.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #9 : 11.01.2007 - klo:18:09 »
mitä tapahtuu jos yrität soittaa jotain wav/mp3 tiedostoa seuraavalla komennolla

aplay -D hw:0,2 <polku tiedostoon>

esim.
aplay -D hw:0,2 file.wav

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #10 : 11.01.2007 - klo:18:12 »
mitä tapahtuu jos yrität soittaa jotain wav/mp3 tiedostoa seuraavalla komennolla

aplay -D hw:0,2 <polku tiedostoon>

esim.
aplay -D hw:0,2 file.wav


pingviini:~ # aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #11 : 11.01.2007 - klo:18:14 »
kokeile myös muuttaa /etc/asound.conf tiedostoa seuraavasti
Lisää tiedoston alkuun allaolev aj akommentoi aikaisempi default pois lisäämällä kyseisten rivien alkuun #-merkki
pcm.!default {
        type hw
        card 0
        device 2
}

tämän jälkeen käynnistä vielä alsa uusiksi (pitää olla root)
/usr/sbin/rcalsasound restart

Kokeile seuraavaksi samat ääni testit kuin aikaisemmin.

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #12 : 11.01.2007 - klo:18:43 »
kokeile myös muuttaa /etc/asound.conf tiedostoa seuraavasti
Lisää tiedoston alkuun allaolev aj akommentoi aikaisempi default pois lisäämällä kyseisten rivien alkuun #-merkki
pcm.!default {
        type hw
        card 0
        device 2
}

tämän jälkeen käynnistä vielä alsa uusiksi (pitää olla root)
/usr/sbin/rcalsasound restart

Kokeile seuraavaksi samat ääni testit kuin aikaisemmin.


Sori en oikeen tajunnu tota mitä ja mihin pitää pistää.
Tossa on se tämän hetkinen asoun.conf tiedosto:

_____________________________________________________

# /etc/asound.conf
#

pcm.!default {
type plug
slave.pcm "digital-hw"
}

pcm.analog {
type plug
slave.pcm "analog-hw"
}

ctl.analog {
type hw
card 0
}

pcm.mixed-analog {
type plug
slave.pcm "dmix-analog"
}

ctl.mixed-analog {
type hw
card 0
}

pcm.digital {
type plug
slave.pcm "digital-hw"
}
ctl.digital {
type hw
card 0
}

pcm.mixed-digital {
type plug
slave.pcm "dmix-digital"
}

ctl.mixed-digital {
type hw
card 0
}

pcm.analog-hw {
type hw
card 0
# The default value for device is 0, so no need to specify
}

ctl.analog-hw {
type hw
card 0
}

pcm.digital-hw {
type hw
card 0
device 2
}ctl.digital-hw {
type hw
card 0
}

pcm.dmix-analog {
type dmix
ipc_key 1234
slave {
pcm "analog-hw"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.dmix-analog {
type hw
card 0
}

pcm.dmix-digital {
type dmix
ipc_key 1235
slave {
pcm "digital-hw"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.dmix-digital {
type hw
card 0
}
_________________________________________________________

Pystyisiks fixaa sen valmiiksi tohon?

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #13 : 11.01.2007 - klo:18:48 »
# /etc/asound.conf
#
pcm.!default {
        type hw
        card 0
        device 2
}
#pcm.!default {
#type plug
#slave.pcm "digital-hw"
#}

pcm.analog {
type plug
slave.pcm "analog-hw"
}

ctl.analog {
type hw
card 0
}

pcm.mixed-analog {
type plug
slave.pcm "dmix-analog"
}

ctl.mixed-analog {
type hw
card 0
}

pcm.digital {
type plug
slave.pcm "digital-hw"
}
ctl.digital {
type hw
card 0
}

pcm.mixed-digital {
type plug
slave.pcm "dmix-digital"
}

ctl.mixed-digital {
type hw
card 0
}

pcm.analog-hw {
type hw
card 0
# The default value for device is 0, so no need to specify
}

ctl.analog-hw {
type hw
card 0
}

pcm.digital-hw {
type hw
card 0
device 2
}ctl.digital-hw {
type hw
card 0
}

pcm.dmix-analog {
type dmix
ipc_key 1234
slave {
pcm "analog-hw"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.dmix-analog {
type hw
card 0
}

pcm.dmix-digital {
type dmix
ipc_key 1235
slave {
pcm "digital-hw"
period_time 0
period_size 1024
buffer_size 32768
rate 48000
}
}

ctl.dmix-digital {
type hw
card 0
}

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #14 : 11.01.2007 - klo:18:57 »
pingviini:~ # aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #15 : 11.01.2007 - klo:19:03 »
Johan nyt on kumma, muistitko tehdä sen alsa:n uudelleen käynnistyksen?
/usr/sbin/rcalsasound restart

jos vielä katsot alsamixeriä niin onhan varmasti IEC958 kohta aktiivinen ja äänet ei ole 0:ssa


Meikäläiseltä meinaa loppuu kohta konstit... ;(

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #16 : 11.01.2007 - klo:19:05 »
laitappa vielä tulostus komennosta

aplay -L

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2719
  • Sukupuoli: Mies
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #17 : 11.01.2007 - klo:19:13 »
pingviini:~ # aplay -D hw:0,2/usr/share/sounds/alsa/test.wav
ALSA lib conf.c:3858:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3952:(snd_config_expand) Parse arguments error: Invalid argument
ALSA lib pcm.c:2143:(snd_pcm_open_noupdate) Unknown PCM hw:0,2/usr/share/sounds/alsa/test.wav
aplay: main:550: audio open error: Invalid argument


Kokeile myös seuraavaa:
(huomaa myös välilyönti 0,2 /usr välissä)
aplay -D plughw:0,2 /usr/share/sounds/alsa/test.wav


PS. kokeile myös tämä ton välilyönnin kanssa
aplay -D hw:0,2 /usr/share/sounds/alsa/test.wav
« Viimeksi muokattu: 11.01.2007 - klo:19:17 kirjoittanut harmie »

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #18 : 11.01.2007 - klo:19:19 »
laitappa vielä tulostus komennosta

aplay -L

PCM list:
hw {
        @args.0 CARD
        @args.1 DEV
        @args.2 SUBDEV
        @args.CARD {
                type string
                default {
                        @func getenv
                        vars {
                                0 ALSA_PCM_CARD
                                1 ALSA_CARD
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.card'
                        }
                }
        }
        @args.DEV {
                type integer
                default {
                        @func igetenv
                        vars {
                                0 ALSA_PCM_DEVICE
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.device'
                        }
                }
        }
        @args.SUBDEV {
                type integer
                default {
                        @func refer
                        name 'defaults.pcm.subdevice'
                }
        }
        type hw
        card $CARD
        device $DEV
        subdevice $SUBDEV
}
plughw {
        @args.0 CARD
        @args.1 DEV
        @args.2 SUBDEV
        @args.CARD {
                type string
                default {
                        @func getenv
                        vars {
                                0 ALSA_PCM_CARD
                                1 ALSA_CARD
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.card'
                        }
                }
        }
        @args.DEV {
                type integer
                default {
                        @func igetenv
                        vars {
                                0 ALSA_PCM_DEVICE
                        }
                        default {
                                @func refer
                                name 'defaults.pcm.device'
                        }
                }
        }
        @args.SUBDEV {
                type integer
                default {
                        @func refer
                        name 'defaults.pcm.subdevice'
                }
        }
        type plug
        slave.pcm {
                type hw
                card $CARD
                device $DEV
                subdevice $SUBDEV
        }
}
plug {
        @args.0 SLAVE
        @args.SLAVE {
                type string
        }
        type plug
        slave.pcm $SLAVE
}
shm {
        @args.0 SOCKET
        @args.1 PCM
        @args.SOCKET {
                type string
        }
        @args.PCM {
                type string
        }
        type shm
        server $SOCKET
        pcm $PCM
}
tee {
        @args.0 SLAVE
        @args.1 FILE
        @args.2 FORMAT
        @args.SLAVE {
                type string
        }
        @args.FILE {
                type string
        }
        @args.FORMAT {
                type string
                default raw
        }
        type file
        slave.pcm $SLAVE
        file $FILE
        format $FORMAT
}
file {
        @args.0 FILE
        @args.1 FORMAT
        @args.FILE {
                type string
        }
        @args.FORMAT {
                type string
                default raw
        }
        type file
        slave.pcm null
        file $FILE
        format $FORMAT
}
null {
        type null
}
cards 'cards.pcm'
front 'cards.pcm.front'
rear 'cards.pcm.rear'
center_lfe 'cards.pcm.center_lfe'
side 'cards.pcm.side'
surround40 'cards.pcm.surround40'
surround41 'cards.pcm.surround41'
surround50 'cards.pcm.surround50'
surround51 'cards.pcm.surround51'
surround71 'cards.pcm.surround71'
iec958 'cards.pcm.iec958'
spdif 'cards.pcm.iec958'
modem 'cards.pcm.modem'
phoneline 'cards.pcm.phoneline'
dmix 'cards.pcm.dmix'
dsnoop 'cards.pcm.dsnoop'
default {
        type hw
        card 0
        device 2
}
analog {
        type plug
        slave.pcm analog-hw
}
mixed-analog {
        type plug
        slave.pcm dmix-analog
}
digital {
        type plug
        slave.pcm digital-hw
}
mixed-digital {
        type plug
        slave.pcm dmix-digital
}
analog-hw {
        type hw
        card 0
}
digital-hw {
        type hw
        card 0
        device 2
}
dmix-analog {
        type dmix
        ipc_key 1234
        slave {
                pcm analog-hw
                period_time 0
                period_size 1024
                buffer_size 32768
                rate 48000
        }
}
dmix-digital {
        type dmix
        ipc_key 1235
        slave {
                pcm digital-hw
                period_time 0
                period_size 1024
                buffer_size 32768
                rate 48000
        }
}
pingviini:~ #

ronaldo09

  • Vieras
Vs: Optinen lähtö ja Suse 10.2
« Vastaus #19 : 11.01.2007 - klo:19:22 »
Johan nyt on kumma, muistitko tehdä sen alsa:n uudelleen käynnistyksen?
/usr/sbin/rcalsasound restart

jos vielä katsot alsamixeriä niin onhan varmasti IEC958 kohta aktiivinen ja äänet ei ole 0:ssa


Meikäläiseltä meinaa loppuu kohta konstit... ;(

tossa muutama kuva: