Kirjoittaja Aihe: Firefox 3.0.5 muistialueen ylitys.  (Luettu 8545 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

tupe

  • Vieras
Firefox 3.0.5 muistialueen ylitys.
« : 10.01.2009 - klo:16:23 »
Voiko mitenkään korjata Firefoxin kaatumatautia?
Koodia: [Valitse]
/usr/bin/firefox: line 123:  5665 Muistialueen ylitys     $MOZ_PROGRAM "$@"Käytössä openSUSE 11.0 ja KDE 3.5.9.

guest158

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #1 : 10.01.2009 - klo:18:13 »
mun FF:llä kun ei oo vast. kaatumatautia ilmennyt, niin millaisessa koneessa sitä ajat? ja miten paljon konettasi muuten kuormitat samanaikaisesti?
Ootko säädellyt välimuistin määriä? Ja onko levylläsi tilaa touhuta? Keskusmuistin määräkin voinee (?) vaikuttaa astian riittävyyteen...
niin ja mikä FF:n versio on menossa eli käytössä?
KDE on tosta 3.5.9-versiosta päivittynyt jo ajat sitten .10-versioksi, mutt en tiedä onko sillä vaikutusta 'taudin kuvaan'

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #2 : 10.01.2009 - klo:20:26 »
Lainaus
mun FF:llä kun ei oo vast. kaatumatautia ilmennyt, niin millaisessa koneessa sitä ajat? ja miten paljon konettasi muuten kuormitat samanaikaisesti?
Ootko säädellyt välimuistin määriä? Ja onko levylläsi tilaa touhuta? Keskusmuistin määräkin voinee (?) vaikuttaa astian riittävyyteen...
niin ja mikä FF:n versio on menossa eli käytössä?

Prosessori (CPU): Intel(R) Celeron(R) CPU 2.80GHz.Muistin määrä (RAM):  1 010,4 Mt
Vapaa muisti:  349,6 Mt (+ 391,9 Mt välimuisti)
Vapaa swap:  957,0 Mt  En ole säädellyt välimuistia. Levyllä on runsaasti tilaa.
Firefoxi on 3.0.5-0.1 updates lähteestä.  Käytössä lisäksi 1-Click weather ja 
Adblock Plus 1.0.


guest158

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #3 : 10.01.2009 - klo:20:56 »
usean KDE-päivityksen lisäksi FF on nykyään 3.0.5-2.5
Myös Suseen on tullut useitakin päivityksiä, jotka myös ovat voineet vaikuttaa juuri muistin ylivuoto-ongelmiin noiden FF:n päivitysten lisäksi.
Oot kuiteski ilmeisesti aktiivisesti ylläpitänyt ohjelmistosi, vaikka FF onkin jäänyt pari päivitystä paitsi?

guest141

  • Vieras

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #5 : 10.01.2009 - klo:21:58 »
usean KDE-päivityksen lisäksi FF on nykyään 3.0.5-2.5
Myös Suseen on tullut useitakin päivityksiä, jotka myös ovat voineet vaikuttaa juuri muistin ylivuoto-ongelmiin noiden FF:n päivitysten lisäksi.
Oot kuiteski ilmeisesti aktiivisesti ylläpitänyt ohjelmistosi, vaikka FF onkin jäänyt pari päivitystä paitsi?


Eipä ole paketinhallinnassa uudempaa versiota saatavilla. Päivitykset mitä on tullut on asennettu ja tuo on uusin.

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #6 : 10.01.2009 - klo:22:01 »

guest141

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #7 : 10.01.2009 - klo:22:12 »
Onko sinulla kyseessä 32 vai 64 bit asennettu suse?

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #8 : 10.01.2009 - klo:22:31 »
Onko sinulla kyseessä 32 vai 64 bit asennettu suse?
32 bittinen on kyseessä.
 

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4540
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #9 : 10.01.2009 - klo:22:46 »
Poista .mozilla-hakemisto

Koodia: [Valitse]
mv .mozilla .mozilla_old
ja käynnistä firefox uudestaan. Auttaako?
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #10 : 10.01.2009 - klo:22:57 »
Poista .mozilla-hakemisto
ja käynnistä firefox uudestaan. Auttaako?

Olen tuota kokeillut, mutta ei ole auttanut.

guest158

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #11 : 11.01.2009 - klo:00:29 »
usean KDE-päivityksen lisäksi FF on nykyään 3.0.5-2.5
Myös Suseen on tullut useitakin päivityksiä, jotka myös ovat voineet vaikuttaa juuri muistin ylivuoto-ongelmiin noiden FF:n päivitysten lisäksi.
Oot kuiteski ilmeisesti aktiivisesti ylläpitänyt ohjelmistosi, vaikka FF onkin jäänyt pari päivitystä paitsi?


Eipä ole paketinhallinnassa uudempaa versiota saatavilla. Päivitykset mitä on tullut on asennettu ja tuo on uusin.

Anteeksi, jos olen töykeä, mutt jos mä kerron jonkun muun paketin olevan se uusin, niin se myös on. Mun tapani ei ole valehdella.

Jos kuitenkin epäilet sanojani, niin klikkaa linkistä:
http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/i586/

Siinä on sinulle uudempi/uusin FF ja se asentuu pakettihallinnasta, Yastista, kunhat laitat lähteeksi:
http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #12 : 11.01.2009 - klo:09:44 »
Lainaus
Anteeksi, jos olen töykeä, mutt jos mä kerron jonkun muun paketin olevan se uusin, niin se myös on. Mun tapani ei ole valehdella.

Jos kuitenkin epäilet sanojani, niin klikkaa linkistä:
http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/i586/

Siinä on sinulle uudempi/uusin FF ja se asentuu pakettihallinnasta, Yastista, kunhat laitat lähteeksi:
http://download.opensuse.org/repositories/mozilla/openSUSE_11.1/

En epäillyt sanojasi, miksi olisin?  Kerroin vain oman tilanteeni.  Minullahan on siis openSUSE 11.0, joten nuo lähteet eivät sovi minulle. Lisäsin nyt kuitenkin yhteisölähteistä Mozillan lähteen ja sieltä sain Firefoxista uudemman version, eli 3.0.5-2.3.
Lainaus
http://download.opensuse.org/repositories/mozilla/openSUSE_11.0/i586/
Toivotaan, että tuo auttaa kaatumisiin. Kiitoksia avustanne!


Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #13 : 11.01.2009 - klo:17:29 »
Emäntä tuli reissusta ja paljastu täälläkin Firefoxin kaatumatauti Vaahtoa ei suupielestä tullut, eikä päätä hakannut lattiaan. No nurin oli tuskastuttavan monta kertaa päivän aikana. Ite en oo tästä ollut tietonen, kun Operalla surffailen.

11.1 ja KDE 4.1.3 on käytössä ja seuraavanlainen ilmotus muistialueen ylityksestä tulee.

Koodia: [Valitse]
/usr/bin/firefox: line 126:  9926 Muistialueen ylitys     $MOZ_PROGRAM "$@"

Tais kesällä viimeks kaatuilla vastaavanlaisesta syystä, mutta meni ajan kanssa ohi. pitänee kokeilla keinot joita tässä säikeessä ehdoteltu.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #14 : 11.01.2009 - klo:17:47 »
Mulla ff kaatuu säännöllisesti kerran päivässä, joskus jopa kaksi kertaa.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #15 : 11.01.2009 - klo:18:21 »
Eipä tuo Firefoxin versio 3.0.5-2.3 versio ainakaan täysin korjannut ongelmaa, koska kaatuilu on jatkunut senkin jälkeen, eikä nyt ole mitään lisäosiakaan asennettu. Tosin vasta pari kertaa kaatunut.  Aloitin myös tyhjältä pöydältä poistamalla .mozilla kansion.

Sen sijaan FF:in asennus toi tullessaan uuden ongelman. Updater ilmoittaa uusista päivityksistä, jotka ovat 2 kpl mozilla-xulrunner securite päivityksiä. Päivitykset vaan eivät jostain syystä suostu asentumaan, vaan updater ilmoittaa aina hetken päästä uudestaan samoista päivityksistä.
Löytyisköhän tähän ratkaisua, vai heitänkö edellisen version Firefoxista takaisin? 

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4540
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #16 : 11.01.2009 - klo:18:36 »
Komenna komentoriviltä

Koodia: [Valitse]
zypper up
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

tupe

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #17 : 11.01.2009 - klo:18:53 »
Komenna komentoriviltä

Koodia: [Valitse]
zypper up
Koodia: [Valitse]
# zypper up
Luetaan asennettuja paketteja...
Asennetaan seuraava UUSI korjauspäivitys:
mozilla-xulrunner181
Operaation suorittamisen jälkeen järjestelmä vie tilaa saman verran, kuin nyt.
Jatketaanko? [KYLLÄ/ei]: k
Olinkin jo tuota päivitystä kokeillut, mutta ei vaikutusta.
 

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #18 : 11.01.2009 - klo:19:36 »
Sen sijaan FF:in asennus toi tullessaan uuden ongelman. Updater ilmoittaa uusista päivityksistä, jotka ovat 2 kpl mozilla-xulrunner securite päivityksiä. Päivitykset vaan eivät jostain syystä suostu asentumaan, vaan updater ilmoittaa aina hetken päästä uudestaan samoista päivityksistä.
Löytyisköhän tähän ratkaisua, vai heitänkö edellisen version Firefoxista takaisin? 

Miulla on toi updater herjannut samaa kilkettä lähes siitä alkaen kun päivitin 11.1 versioon. Ei oo zypperi herjaa poistanut. Tosin en oo seurannut onko se asentunut vai ei. Zypperillä ei kyllä oo mitään herjoja vääntänyt. Miulla menny usko koko updateriin ko se kiukutteli jo 11 versiossa ja muutaman päivän toimi päivityksen jälkeen.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

guest158

  • Vieras
Vs: Firefox 3.0.5 muistialueen ylitys.
« Vastaus #19 : 11.01.2009 - klo:21:07 »
en tiedä, onko koko zypper enää oikein käytössäkään... mulla on ollu jo jonkun aikaa Packagekit valittuna zypperin sijaan, eikä oo herjoja näkynyt, mut päivitykset kyll toimii. Tää siis 11.1:ssä

Jostain nimittäin muistelen lukeneeni, ett tollanen muutos olis tehty tai silloin olis ollu tekeillä.
Koska se silloin oli? en muista, mutt olisko ollu mennä myöhäissyksystä tai alkutalvesta?
Olivat muutkin saaneet zypperistä tarpeekseen.
Onneks Yast skulaa