Kirjoittaja Aihe: Toimiiko jollakin Google-earth Tumbleweedissä?  (Luettu 455 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1184
  • Sukupuoli: Nainen
Toimiiko jollakin Google-earth Tumbleweedissä?
« : 16.03.2021 - klo:15:28 »
Minulle tulee kuvassa oleva herja, enkä ole löytänyt sopivaa mesa-libGLU.rpm:ää asennettavaksi.
Tuota yritän tunkea koneeseen: google-earth-pro-stable-current.x86_64.rpm, joka on toki joskus toiminutkin.

muoks: korjattu pari kirj.virhettä otsikossa  ;D
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2681
  • Sukupuoli: Mies
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #1 : 16.03.2021 - klo:17:21 »
Varmaan pari vaihtoehtoa
Tämän mukaan voisit valita vaihtoehdon 2
https://www.reddit.com/r/openSUSE/comments/dgqvmo/opensuse_151_dependencies/

Tai sitten asentta tämän
https://build.opensuse.org/package/show/home:Sauerland/mesa-libGLU

Tai sitten jotain muuta  :)

Poissa RaijaR

  • Jäsen
  • Viestejä: 1184
  • Sukupuoli: Nainen
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #2 : 16.03.2021 - klo:21:02 »
Asensin tällä ohjeella(https://build.opensuse.org/package/show/home:Sauerland/mesa-libGLU)
Koodia: [Valitse]
zypper addrepo https://download.opensuse.org/repositories/home:Sauerland/openSUSE_Leap_15.2/home:Sauerland.repo
zypper refresh
zypper install mesa-libGLU

Asennus em. asennus onnistui ja myös GE asennus onnistui, mutta GE ei käynnisty
Koodia: [Valitse]
localhost:~ # google-earth-pro
/opt/google/earth/pro/googleearth-bin: error while loading shared libraries: libGLU.so.1: cannot open shared object file: No such file or directory
localhost:~ # locate libGLU.so.1
/usr/lib/libGLU.so.1
/usr/lib/libGLU.so.1.3.1
localhost:~ #
Pitäisköhän minun yrittää kopioida tuo libGLU.so jonnekin? Jos, niin minne?

Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa png

  • Jäsen
  • Viestejä: 280
  • Sukupuoli: Mies
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #3 : 16.03.2021 - klo:21:53 »
Minä luulen, että täytyy ajaa komento
Koodia: [Valitse]
ldconfigmutta mitä vipuja tarvitset, en osaa sanoa.
Kukaan ei voi tehdä kaikkea, mutta jokainen
voi tehdä jotakin; ja jos jokainen tekee jotakin,
tulee kaikki tehdyksi.

Poissa mrl586

  • Jäsen
  • Viestejä: 162
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #4 : 14.05.2021 - klo:10:41 »
Toimii, ks. tämä ohje.
Riippuvuus mesa-libGLU täyttyy sopivalla dummy-paketilla, jonka voit asentaa kätevästi yhden klikkauksen taktiikalla. Lisäksi kannattaa asentaa paketit libopenssl1_0_0 tai libopenssl1_0_0-32bit, jotta Google Earthin käynnistys onnistuisi.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1184
  • Sukupuoli: Nainen
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #5 : 14.05.2021 - klo:21:23 »
Ei nyt oikein selvinnyt, että mitä pitäisi tehdä ja mistä sen 1-click ohjelman löytää. Ja kumman kirjasto-ohjelman valitsen.
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa mrl586

  • Jäsen
  • Viestejä: 162
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #6 : 16.05.2021 - klo:18:30 »
Tämä paketti sinun tulisi asentaa. OpenSSL 1.0.0 -kirjastosta tarvitset sellaisen version, jolla Google Earth toimii, joten voit vaikka asentaa molemmat, jos et ole varma, kumpaa Google Earth niistä tarvitsee. Jos kyseessä 64-bittinen versio Google Earthista, se käyttänee todennäköisesti 64-bittisiä kirjastoja.
« Viimeksi muokattu: 16.05.2021 - klo:18:49 kirjoittanut mrl586 »

Poissa RaijaR

  • Jäsen
  • Viestejä: 1184
  • Sukupuoli: Nainen
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #7 : 17.05.2021 - klo:10:29 »
Ei toimi minulla. En tiedä miksi  :)

Koodia: [Valitse]
raija@localhost:~> /opt/google/earth/pro/google-earth-pro %f
/opt/google/earth/pro/google-earth-pro: rivi 21: 9732 Muistialueen ylitys     (luotiin core-tiedosto)"$(dirname "$(readlink -f "$0")")/googleearth-bin" "$@"
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa mrl586

  • Jäsen
  • Viestejä: 162
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #8 : 17.05.2021 - klo:21:48 »
Oletko jo tehnyt tämän vaiheen ohjeesta? Kyseessä on OpenSusen paketoinnin kanssa ristiriidassa oleva kirjasto, joka tulisi poistaa ja sen sijaan asentaa vastaava kirjasto (libopenssl1_0_0) pakettienhallinnan kautta.
Lainaus
"FWIW, somebody in the german forum mentioned simply moving away /opt/google/earth/pro/libcrypto.so.1.0.0 worked for them and got google earth to start normally, maybe you want to try that.".

Poissa RaijaR

  • Jäsen
  • Viestejä: 1184
  • Sukupuoli: Nainen
Vs: Toimiiko jollakin Google-earth Tumbleweedissä?
« Vastaus #9 : 18.05.2021 - klo:21:45 »
Toimiiko GE sinulla näillä ohjeilla tehtynä?
Jos toimii sinulla, niin anna ohjeet muodossa esim.

rm /opt/google/earth/pro/libcrypto.so.1.0.0 ???
zypper in ?

En ymmärrä/löydä ohjetta, jos pitää lukea useita keskusteluja asiasta.


Jälkikirjoitus.

Näin sain GE:n käynnistymään

Koodia: [Valitse]
rm /opt/google/earth/pro/libcrypto.so.1.0.0
zypper in libopenssl1_0_0



« Viimeksi muokattu: 18.05.2021 - klo:21:54 kirjoittanut RaijaR »
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed, jossa nippu distroja QEMU/KVM:ssä
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D