Kirjoittaja Aihe: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)  (Luettu 84438 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa peran

  • Käännösryhmä
  • *
  • Viestejä: 421
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #80 : 01.01.2018 - klo:17:38 »
Sorry, ymmärrysvirhe miulta. Luulin että komento tekee vaan txt tiedoston hausta. Aikasemmin on tullu tavaraa niinpaljon, että alkupää on hävinny. Ei näköjään tarvinnu sudoakaan.

Kyllä ihan oikein ymmärsit eli tekee txt-tiedoston hausta, mutta virheilmoitukset jää pois hausta.

Saisihan ton hienomminkin tehtyä (virheet suunnattua null:iin), mutta ei muista, eikä jaksa googlettaa, niin toi on kätevä tapa poistaa virhevirta halutusta virrasta.

Sudoa en tuossa tapauksessa käyttäisi, koska sitä ei tarvita.

[OffTopic]
Edit - Jaksoin kuitenkin googlatakin... ;)
Koodia: [Valitse]
find / -name "rtl-sdr.rules" 2>/dev/null
[/OffTopic]
« Viimeksi muokattu: 01.01.2018 - klo:17:49 kirjoittanut peran »

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #81 : 01.01.2018 - klo:18:22 »
Sorry, ymmärrysvirhe miulta. Luulin että komento tekee vaan txt tiedoston hausta. Aikasemmin on tullu tavaraa niinpaljon, että alkupää on hävinny. Ei näköjään tarvinnu sudoakaan.
Koodia: [Valitse]
pi@Fldigi:~ $ cat tulos.txt
/home/pi/rtl-sdr/rtl-sdr.rules
/etc/udev/rules.d/rtl-sdr.rules
pi@Fldigi:~ $

Eli sinulla on se tiedosto tuolla /home/pi/rtl-sdr/rtl-sdr.rules

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #82 : 01.01.2018 - klo:18:51 »
Eli sinulla on se tiedosto tuolla /home/pi/rtl-sdr/rtl-sdr.rules

Juu, ja oon koittanu sitä kertoa usiamman viestin ajan.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #83 : 01.01.2018 - klo:21:03 »
niin eli se sun kopionti pitää tehdä sieltä

eli jos olet hakemistossa /home/pi/rtl-sdr/build voit kopioida
Koodia: [Valitse]
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

mutta jos olet jossain muualla niin
Koodia: [Valitse]
sudo cp /home/pi/rtl-sdr/rtl-sdr.rules  /etc/udev/rules.d/

mutta kuten jo todettu tuo tuskin on se sinun ongelmasi ja ainakaan itse en voi oikein paremmin auttaa kun ei ole ko laitteita enkä niistä mitään tietäisi vaikka olisikin :)

Poissa raimo

  • Jäsen
  • Viestejä: 218
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #84 : 02.01.2018 - klo:12:28 »
En nyt jaksa lukea koko pitkää ketjua, mutta huvikseni virittelin Kiinalaisesta DVB tikusta radiovastaanottimen.
Ainoa asia mikä esti sen toiminnan oli että jos "DVB-osuus" on kernelissä blacklistimättä niin radio ei toimi.
Tuollaiseen käsitykseen tulin, ja koneena oli Raspi 3, käyttiksenä Raspbian ja ohjelmana muistaakseni qsdr tms.

Nimim. aina pitäisi tehdä muistiinpanot.

Ubuntufoorumin jäsen nm on tietäjä joka tietää miten homma hoidetaan.
Esim: https://forum.ubuntu-fi.org/index.php?topic=47459.0;topicseen

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #85 : 02.01.2018 - klo:13:53 »
blacklist on tehtynä ja tosiaan ongelma on toi herja mikä kopioinnista tulee. Miulla ei oo mitään käsitystä mihin toi tiedosto pitäs kopioida. Copypastean ohjetta jolla videoiden perusteella tulee toimiva systeemi muutamassa minuutissa. Vastaanotin tikkukin on täsmälleen sama. Ainoa asia joka ei videoilta selviä on rasbianin versio. Mie siis yritän uusimmalla. Jessietä en oo löytäny enää mistään.

Ohjeet joita oon kokeillu on selkeitä. Copypastean komennot kirjotusvirheiden välttämiseksi. En ymmärrä kovin montaa komentoa, mutta jos homma etenee hyvin, ei sillä ole hirveen suurta merkitystä ja ajan kanssa opin lisää. Se tässä eniten ihmetyttää, että miten nää kaikki miun raspi systeemit menee perseelleen tavalla tai toisella vaikka noudatan ohjeita.
Ohje on tossa kopiointi komennon edellä ja sen jälkeen riveiltään seuraavanlainen. Mihinkään kansioon menemisestä ei siinä ole mitään. Myöskään videoilla ei oo siitä merkkejä. Mie ko en ymmärrä mitä komento tekee, niin lopputulos on se mikä tässä nyt on ollu.
Koodia: [Valitse]
sudo ldconfig
cd /home/pi/rtl-sdr/build
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/

Nyt tein näin
Koodia: [Valitse]
pi@Fldigi:~ $ cd /home/pi/rtl-sdr/build
pi@Fldigi:~/rtl-sdr/build $ sudo cp ../rtl-sdr.rules /etc/udev/rules.d/
pi@Fldigi:~/rtl-sdr/build $

Nyt ei tullu ainakaan herjaa, koitan jatkaa ohjetta eteenpäin.

Ais systeemi meni reisille kahdella tapaa. Navigointiohjelma ei suostunu asentumaan ja kun löysin gnuaissin kaikki asentu niinkun pitää, mutta asetuksia ei saa muutettua. Harmien ohje oli selvä. # merkki pois niistä asetuksista jotka otetaan käyttöön. Toimin näin ja rupes herjaamaan virhettä sillä rivillä josta merkin poistin. Löin hanskat tiskiin. Miltei koomista tässä on se, että alkuun käytin siinä projektissa tätä samaa vastaanotinta kuin tässä Gqrx/fldigi projektissa ja asensin ajurit saman ohjeen mukaan kuin nyt. Silloin se onnistu, nyt ei. Ennen se on auennu vähintään asetus sivulle.

Tää käytössä oleva ohje on mennyt läpikin, mutta Gqrx ei asentunu vaikka ohjeen mukaan niin pitäis käydä. Sen saa kyllä asennettua synapticilla, mutta se ei aukea.
Koodia: [Valitse]
[pi@Fldigi:~ $ gqrx
linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown

libEGL warning: DRI2: failed to authenticate
Controlport disabled
No user supplied config file. Using "default.conf"
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya
FM demod gain: 1.52789
IQ DCR alpha: 1.04166e-05
Using audio backend: auto
BookmarksFile is /home/pi/.config/gqrx/bookmarks.csv
*** Error in `gqrx': corrupted double-linked list: 0x00a74070 ***
Keskeytetty
pi@Fldigi:~ $ /code]

Kokeilin myös ubuntu matea joka oli jumalattoman hidas. Tikun toimivuutta en kerenny kokeilla kun gqrx ei kestänyt pystyssä 15sek. pidempään. Pari päivää sitten kokeilin uudestaan ja en saanu asennettua mitään kun nettiyhteys katkes minuutin jälkeen ja sitä ei saanu takas kun kirjautumalla ulos. Ei houkuttele taistelu sen kanssa yhtään.

Toissailtana löysin vahingossa sdrplay vastaanottimen sivuilta käyttiksen raspille. Kyseinen vastaanotin on aina ollu niin winonly kun olla voi ja siks oli yllätys törmätä raspiversioon. No se oli räätälöity niin tarkkaan heidän omalle vastaanottimelle että muiden ohjelmien asennuskin oli hankalaa.

Lisään tähän hetken päästä pätkän koodia.
« Viimeksi muokattu: 02.01.2018 - klo:14:46 kirjoittanut Rantarosvo »
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa raimo

  • Jäsen
  • Viestejä: 218
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #86 : 02.01.2018 - klo:14:07 »
Lainaus
Jessietä en oo löytäny enää mistään.

Tuossa on viimeisin Raspbian Jessie: http://downloads.raspberrypi.org/raspbian/images/raspbian-2017-07-05/
Loput: http://downloads.raspberrypi.org/raspbian/images/

Voi hyvinkin olla että jokin ohjelma ei ole yhteensopiva Raspbian Stretchin kanssa koska se kuitenkin on aika uusi ilmestys.

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #87 : 02.01.2018 - klo:16:14 »
Mitä tää tarkalleen tarkottaa? rtl-sdr.rules tiedosto kopioidaan mutta mistä minne?
Koodia: [Valitse]
sudo cp udev/rtl-sdr.rules /etc/udev/rules.d/
/etc/udev/rules.d kansio löytyy ja se sisältää tuon  rtl-sdr.rules tiedoston.
/udev/ kansiota ei juuressa ole. Luonko sen ja kopsaan sinne ton  rtl-sdr.rules tiedoston?
Ohjeessa seuraava kohta on
Koodia: [Valitse]
volk_profile toolJa sitten pitäiskin toi Gqrx olla asennettu jota mie hiukan epäilen jostain syystä. Ehkä siks, että sitä ei mainita noissa komennoissa ollenkaan.

Kiitos tosta jessie linkistä. Itellä tää ymmärrys jo pikkasen tiukilla kipukohtauksen takia. Jos/kun saan noi pari riviä vielä menemään läpi ilman herjoja, otan levykuvan ennenkuin edes yritän käynnistää gqrx:ää. Onpahan sitten ainakin yks taso läpästy  :P
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #88 : 03.01.2018 - klo:07:54 »
Mitä tää tarkalleen tarkottaa? rtl-sdr.rules tiedosto kopioidaan mutta mistä minne?
Koodia: [Valitse]
sudo cp udev/rtl-sdr.rules /etc/udev/rules.d/
/etc/udev/rules.d kansio löytyy ja se sisältää tuon  rtl-sdr.rules tiedoston.
/udev/ kansiota ei juuressa ole. Luonko sen ja kopsaan sinne ton  rtl-sdr.rules tiedoston?

tuo komento yrittää kopioida rtl-sdr.rules tiedoston nykyisestä hakemiston alta olevasta udev hakemistosta ei juuresta koska polun alussa ei ole / (kautta) merkkiä joka tarkoittaa absoluuttista polkua juuresta.

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #89 : 03.01.2018 - klo:15:08 »
Komento sillon toinen tällön ja nyt on ton jessien kanssa kokeilu vastatuulessa. Ohje on sama kun uudemmallakin ja meno päätty paria komentoa aikasemmin kun uudemmalla rasbianilla.
Koodia: [Valitse]
-- Configuring incomplete, errors occurred!
See also "/home/pi/rtl-sdr/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/rtl-sdr/build/CMakeFiles/CMakeError.log".
pi@Fldigi:~/rtl-sdr/build $ make
make: *** Kohteita ei ole annettu, eikä makefileä löytynyt. Seis.
pi@Fldigi:~/rtl-sdr/build $
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #90 : 03.01.2018 - klo:16:27 »
Komento sillon toinen tällön ja nyt on ton jessien kanssa kokeilu vastatuulessa. Ohje on sama kun uudemmallakin ja meno päätty paria komentoa aikasemmin kun uudemmalla rasbianilla.
Koodia: [Valitse]
-- Configuring incomplete, errors occurred!
See also "/home/pi/rtl-sdr/build/CMakeFiles/CMakeOutput.log".
See also "/home/pi/rtl-sdr/build/CMakeFiles/CMakeError.log".
pi@Fldigi:~/rtl-sdr/build $ make
make: *** Kohteita ei ole annettu, eikä makefileä löytynyt. Seis.
pi@Fldigi:~/rtl-sdr/build $
Laitatko tulosteen komentohistoriasta. Jotain tossa nyt menee pieleen.
Koodia: [Valitse]
history

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #91 : 03.01.2018 - klo:19:56 »
2 ekaa tehty jo eilen, joka selittänee kolmoskohdan :)
Koodia: [Valitse]
pi@Fldigi:~/rtl-sdr/build $ history
    1  sudo apt-get update
    2  sudo apt-get upgrade
    3  sudo apt-get update
    4  sudo apt-get install git
    5  sudo apt-get install cmake
    6  sudo apt-get install build-essential
    7  git clone git://git.osmocom.org/rtl-sdr.git
    8  cd rtl-sdr/
    9  mkdir build
   10  cd build
   11  cmake ../ -DINSTALL_UDEV_RULES=ON
   12  make
   13  history
pi@Fldigi:~/rtl-sdr/build $

Ohje mitä oon käyttäny(gqrx osuus puuttuu tästä)
Koodia: [Valitse]
1. Open a terminal and confirm you're in your home directory. This is the
preferred convention and will be assumed throughout this text. Text highlighted in
gray is exactly what you want to type at the command line. Yes it's case sensitive.
2. Update your distribution.
sudo apt-get update
3. Install the tools needed to retrieve (git), compile (cmake) and build (build-
essential).
sudo apt-get install git
sudo apt-get install cmake
sudo apt-get install build-essential
4. Install libusb-1.0-0-dev which is a C library that provides generic access to USB
devices.
sudo apt-get install libusb-1.0-0-dev
5. Retrieve, build and compile the RTL2832U Osmocom drivers from the source.
git clone git://git.osmocom.org/rtl-sdr.git
cd rtl-sdr/
mkdir build
cd build
cmake ../ -DINSTALL_UDEV_RULES=ON
make
sudo make install
sudo ldconfig
sudo cp ../rtl-sdr.rules /etc/udev/rules.d/
6. Blacklist the default driver that is automatically loaded for using the dongle as
a TV device as it doesn't work for SDR purposes and clashes with the new
Osmocom drivers we just installed.
A. Open your /etc/modprobe.d folder as an administrator.
B. Create a new file 'blacklist-rtl.conf' and add this one line:
blacklist dvb_usb_rtl28xxu
C. Save the file, close the editor and restart the machine.
7. Test that the dongle is working by opening a terminal and typing:
rtl_test -t

Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #92 : 04.01.2018 - klo:08:20 »
mites tätä kohtaa ei näy historiassa?

Koodia: [Valitse]
4. Install libusb-1.0-0-dev which is a C library that provides generic access to USB
devices.
sudo apt-get install libusb-1.0-0-dev

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #93 : 04.01.2018 - klo:12:19 »
Tohon on vain yks selitys. Joku P******een tunari on jättäny sen välistä pois  :P

Saatto muuten löytyä syy koko sylttytehtaalle. Mie oon copypastennu ton ohjeen itelleni txt tiedostoks, jossa siis vaan noi komennot ja joitakin itteäni helpottavia kommentteja vastasuuden varalle. Tästä kyseisestä komentokokoelmasta puuttuu tuo neljäs kohta  >:(
Alkuperänen ohje on 18 sivunen pdf josta miuta koskee vaan 2 ekaa sivua.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #94 : 04.01.2018 - klo:17:11 »
Nyt meni asennus jessiessä läpi ilman herjoja. Tuolta ubuntufoorumilta Raimon vinkistä löysin lyhyen ja ytimekkään loitsun Gqrx asentamiseksi. No ei se käynnisty vieläkään ja vastaanotin tikun testikin hiukan hämmentää. Lähinnä siks, että se on huomattavasti pidempi kun ennen.

rtl_test _t lopputulos. Toimiiko vai ei? Pari vikaa riviä on ollu joka kerta.
Koodia: [Valitse]
pi@Fldigi:~ $ rtl_test -t
Found 1 device(s):
  0:  , , SN:

Using device 0: Generic RTL2832U OEM
rtlsdr_write_reg failed with -1
Resetting device...
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
No supported tuner found
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Enabled direct sampling mode, input 1
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Supported gain values (1): 0.0
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
WARNING: Failed to set sample rate.
No E4000 tuner found, aborting.
rtlsdr_write_reg failed with -4
pi@Fldigi:~ $

Gqrx Käynnistys
Koodia: [Valitse]
pi@Fldigi:~ $ gqrx
linux; GNU C++ version 4.9.1; Boost_105500; UHD_003.007.003-0-unknown

gr-osmosdr 0.1.3 (0.1.3) gnuradio 3.7.5
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy
Using Volk machine: neon_hardfp_orc
pulseaudio/pa_sink.cc: pa_simple_new() failed: Yhteys hylätty
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2716
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #95 : 04.01.2018 - klo:20:14 »
olethan tämän tehnyt?

Koodia: [Valitse]
6. Blacklist the default driver that is automatically loaded for using the dongle as
a TV device as it doesn't work for SDR purposes and clashes with the new
Osmocom drivers we just installed.
A. Open your /etc/modprobe.d folder as an administrator.
B. Create a new file 'blacklist-rtl.conf' and add this one line:
blacklist dvb_usb_rtl28xxu
C. Save the file, close the editor and restart the machine.

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #96 : 04.01.2018 - klo:21:09 »
Juu olen ja nyt vielä tarkistin. Jostain syystä noita tiedostoja oli 3kpl, hiukan eri nimellä ja sisällöllä. Ennen ei tossa kansiossa ole ollu kun 2 tiedostoa. Ainoo mikä unohtu Gqrx:än asennuksen lopuksi oli volk_profile.
No nyt sekin on tehty, mutta ei vaikutusta. Gqrx aukeaa ruutuun jossa ilmotetaan, että asetuksia pitää muuttaa. Tuttu ruutu ennestäänkin ja ei niitä oikeesti tarvii muuttaa. No nyt on ihan sama vastaako kyllä vai ei, ne asetukset ei aukea ja toi konsolin tekstikin jumahtaa tohon samaan kohtaan mailman tappiin asti.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #97 : 05.01.2018 - klo:13:51 »
Pulseaudio tohon miun järjen mukaan on jonkunsortin syypää. Kun yrittää tehdä sille jotain, niin aina tulee herja. Fatal jotain ja yhteyttä ei saada. Vaihdoin oletus äänisysteemiks alsan ja Gqrx aukes asetuksiin asti, mitä se ei oo ennen tehny. Toki herjoja riitti.
Asensin toiselle muistikortille uusimman rasbianin ja siinäkin asennus meni loppuun asti ilman herjoja. Kun Gqrx:än käynnistää, tulee sama vanha herja kun ennenkin.

Kummalla rasbian versiolla kannattas jatkaa touhuumista? Jessiellä pääsee Gqrx:än kanssa pidemmälle, tai saa ainakin pidemmän herjalistan. Jessiessä asentu pari outoa radioihin liittyvää ohjelmaa, kun asensin Gqrx:än. Kumpikaan niistä ei toimi. Aukee kyllä, mutta eivät löydä vastaanotinta. Rtl_test -t tulos on myös melkosen pitkä. Ekat 2 koodin pätkää tässä alla on jessiestä ja lisään hiukan myöhemmin vastaavat tosta uusimmasta jahka oon vaihtanu muistikortin koneeseen.

Koodia: [Valitse]
pi@Fldigi:~ $ gqrx
linux; GNU C++ version 4.9.1; Boost_105500; UHD_003.007.003-0-unknown

gr-osmosdr 0.1.3 (0.1.3) gnuradio 3.7.5
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy
Using Volk machine: neon_hardfp_orc
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
gr-osmosdr 0.1.3 (0.1.3) gnuradio 3.7.5
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy
Using device #0 Realtek RTL2838UHIDIR SN: 00000001
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
No supported tuner found
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
Enabled direct sampling mode, input 1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1

FATAL: Failed to set default samplerate.

Trying to fill up 1 missing channel(s) with null source(s).
This is being done to prevent the application from crashing
due to gnuradio bug #528.

terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<boost::math::rounding_error> >'
  what():  Error in function boost::math::round<f>(f): Value -inf can not be represented in the target integer type.
Keskeytetty
pi@Fldigi:~ $

Koodia: [Valitse]
pi@Fldigi:~ $ rtl_test -t
Found 1 device(s):
  0:  , , SN:

Using device 0: Generic RTL2832U OEM
rtlsdr_write_reg failed with -1
Resetting device...
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
rtlsdr_read_reg failed with -4
rtlsdr_write_reg failed with -4
No supported tuner found
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Enabled direct sampling mode, input 1
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
Supported gain values (1): 0.0
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
rtlsdr_demod_write_reg failed with -4
rtlsdr_demod_read_reg failed with -4
WARNING: Failed to set sample rate.
No E4000 tuner found, aborting.
rtlsdr_write_reg failed with -4
pi@Fldigi:~ $

Ja uusin rasbian
Lainaus
Koodia: [Valitse]
pi@Gqrx:~ $ gqrx
linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown

libEGL warning: DRI2: failed to authenticate
Controlport disabled
No user supplied config file. Using "default.conf"
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya
FM demod gain: 1.52789
IQ DCR alpha: 1.04166e-05
Using audio backend: auto
BookmarksFile is /home/pi/.config/gqrx/bookmarks.csv
*** Error in `gqrx': corrupted double-linked list: 0x00e60f68 ***
Keskeytetty
pi@Gqrx:~ $
Koodia: [Valitse]
pi@Gqrx:~ $ rtl_test -t
Found 1 device(s):
  0:  Realtek, RTL2838UHIDIR, SN: 00000001

Using device 0: Generic RTL2832U OEM
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_read_reg failed with -1
rtlsdr_write_reg failed with -1
No supported tuner found
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -9
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
Enabled direct sampling mode, input 1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
Supported gain values (1): 0.0
rtlsdr_demod_write_reg failed with -1
WARNING: Failed to set sample rate.
No E4000 tuner found, aborting.
pi@Gqrx:~ $

Pitää perehtyä tohon virran saantiin. On toi salama tossa ylänurkassa käytännössä kokoajan. Pitänee testata pysyykö herjat samana, siis lähinnä ton Gqrx kohdalla. Vastaanotinta turha testailla ilman vastaanotinta.
« Viimeksi muokattu: 05.01.2018 - klo:14:48 kirjoittanut Rantarosvo »
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa raimo

  • Jäsen
  • Viestejä: 218
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #98 : 05.01.2018 - klo:13:59 »
Tuolla vihjaillaan noista virheistä että virta loppuu ts. ei riitä, ratkaisuna erillisellä virtalähteellä varustettu USB-hubi.
https://aaron-brown.net/blog/?p=40

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Rosmo ja raspberry pi (tiedän, huono yhdistelmä)
« Vastaus #99 : 05.01.2018 - klo:14:23 »
Ainakin salama katos ruudun kulmasta lähes heti kun vastaanottimen irrotti. Toisella vastaanottimella sitä ei ollu. Saman piirin sisältää, mutta ei oo samanlainen. Vie ilmeisesti vähemmän virtaa. Se on kuuntelultaan täys paska, mutta ollu tossa raspissa kiinni noita asennuksia tehdessä aikasemmin. Nyt on toi kunnolla kuunteleva vastaanotin ollu kiinni asennuksienkin aikana jo useamman päivän. Se on aikasemmin ollu tässä susessa kiinni.
Molemmissa siis sama piiri ja toimivat samoilla ajureilla ja susessa toimiivat kumpikin. Toinen vaan ei kuuntele käytännössä mitään. On vielä se kalliimpi  ::)

muoks:

Jessien lisävirralla ja herjat lyheni. Vastaanotinta ei löydy enään tässäkään. Hubi ilmeisesti vaatis jotain?
Koodia: [Valitse]
pi@Fldigi:~ $ rtl_test -t
No supported devices found.
pi@Fldigi:~ $ gqrx
linux; GNU C++ version 4.9.1; Boost_105500; UHD_003.007.003-0-unknown

gr-osmosdr 0.1.3 (0.1.3) gnuradio 3.7.5
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy
Using Volk machine: neon_hardfp_orc
pulseaudio/pa_sink.cc: pa_simple_new() failed: Yhteys hylätty
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600
Could not resolve property : pattern10600

Uudempi rasbian pysy virrallisen hubin lisäämisen jälkeen melkein ennallaan. Ei vaan löydä vastaanotinta
Lainaus
Koodia: [Valitse]
pi@Gqrx:~ $ gqrx
linux; GNU C++ version 6.2.0 20161010; Boost_106100; UHD_003.009.005-0-unknown

libEGL warning: DRI2: failed to authenticate
Controlport disabled
No user supplied config file. Using "default.conf"
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.10
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy soapy redpitaya
FM demod gain: 1.52789
IQ DCR alpha: 1.04166e-05
Using audio backend: auto
BookmarksFile is /home/pi/.config/gqrx/bookmarks.csv
Väylävirhe
pi@Gqrx:~ $ rtl_test -t
No supported devices found.
pi@Gqrx:~ $
« Viimeksi muokattu: 05.01.2018 - klo:14:34 kirjoittanut Rantarosvo »
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."