Kirjoittaja Aihe: Gnuradio ja sussu 13.2 vivaldista myös hiukan. RATKAISTU  (Luettu 16769 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Ois tarvetta saada SDR-vastaanotin kytketyksi tietokoneeseen. Kytkentä ei oo ongelma, mutta ohjelmisto on. Gnuradio pitäis toimia vastaanottimen kanssa, mutta en saa sitä asennettua. Susen omista pakettilähteistä se löytyy, mutta ei ilmeisesti asennu kokonaan. Tulee ohjelma nimeltä Grc ja sitä kun klikkaa tulee herja:

Koodia: [Valitse]
Cannot import gnuradio.
Is the python path environment variable set correctly?
    All OS: PYTHONPATH
Is the library path environment variable set correctly?
    Linux: LD_LIBRARY_PATH
    Windows: PATH
    MacOSX: DYLD_LIBRARY_PATH

Oisko täällä ketään joka kyseisen asian kanssa ois paininu? Käsittääkseni toi gnuradio on melkonen ohjelmistopaketti. Tarvehan ei oo saada kuuluviin FM radiokanavia vaan lento ja laivaliikenteen radioliikenne. Se ei Kden radio-ohjelmalla onnistu. Hajos toinen skanneri ja tuntuu hiukka oudolta ko ei oo riittävästi radioliikennettä kämpässä :) Sdr-vastaanotin olis näin tukiasemakäytössä käyttöliittymältään passeli peli kun ei tarvii toiseltapuolen maailmaa saada mitään kuuluviin. Siihen hommaan on vastaanotin erikseen. Nyt kattellu linkistä löytyvää vastaanotinta. Ostanu en sitä vielä oo, kun haluisin tutustua ensin ohjelmistoon. Ylipäätään radioharrasteisiin löytyy yllättävän paljon ohjelmia, mutta susen lähteissä niitä ei oo :( Jos joku on kiinnostunu näistä ohjelmista, on niitä toisessa linkissä. Löytyy ohjelmaa esimerkiks antennisuunnitteluun joita voi hyödyntää vaikkapa mokkulayhteyden parantelussa. Tabletille(android) pitäs kans olla ohjelmia, mut en oo vielä järkevää löytäny. Se olis kans varteenotettava vaihtoehto vastaanottimen käyttöön.

Radio
http://www.rxtx-tuote.fi/index.php?valikko=skannerit&sivu=sdr.dxpatrol&tuote=Y

Ohjelmia radioharrasteisiin
http://radio.linux.org.au
« Viimeksi muokattu: 20.09.2015 - klo:21:48 kirjoittanut Rantarosvo »
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2
« Vastaus #1 : 04.09.2015 - klo:08:47 »
Kyllä tuo itselleni asentui ja aukesi. Asensitko 1 click asennuksena? Minkä version koitit asentaa?
https://software.opensuse.org/package/gnuradio

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2
« Vastaus #2 : 04.09.2015 - klo:12:20 »
Nyt en osaa versioo sanoa sen tarkemmin. Susen lähteistä löytyvä. Kokeilin tota 1-click asennusta ja klikkauksen jälkeen avautuu selaimeen sivu jossa alla oleva teksti.

Koodia: [Valitse]
<metapackage xmlns:os="http://opensuse.org/Standards/One_Click_Install" xmlns="http://opensuse.org/Standards/One_Click_Install">
  <group>
    <repositories>
      <repository recommended="true">
        <name>openSUSE:13.2</name>
        <summary>Test setup for 13.2</summary>
        <description>This is really just a snapshot of Factory, but we need it to adapt the tools to later test and accept requests to it.</description>
        <url>http://download.opensuse.org/distribution/13.2/repo/oss/</url>
      </repository>
    </repositories>
    <software>
      <item>
        <name>gnuradio</name>
        <summary>GNU software radio</summary>
        <description>GNU Radio is a collection of software that when combined with minimal
hardware, allows the construction of radios where the actual waveforms
transmitted and received are defined by software. What this means is
that it turns the digital modulation schemes used in today's high
performance wireless devices into software problems.</description>
      </item>
    </software>
  </group>
</metapackage>

Miulla hajos juurilevy pariviikkoa sitten ja sussun uudelleen asennuksen jälkeen on ollu joitakin vaikeuksia asennusten kanssa. Esim vivaldi ei suostu asenntumaan. No siitä pitäs tehä oma kysymys ja kattoo ne herjat. Joku muukin ohjelma oli, mutta en nyt muista mikä. Ne ei kuitenkaan ollu 1-click asennuksia vaan koneelle ladattuja .rpm paketteja.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2
« Vastaus #3 : 04.09.2015 - klo:13:29 »
Kokeile asentaa tuo tumbleweed versio.

Suosittelen kyllä että et asentele yksittäisiä rpm-paketteja ellei ole ihan pakko ja jos asennat niin asenna käyttäen zypperiä.

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2
« Vastaus #4 : 04.09.2015 - klo:14:27 »
.rpm paketeista oon asentanu operan uusimman version ja tota vivaldia kaipaisin, eli ei toi kauheen laajamittasta oo :) Niin se vivaldin paketti on sen omalta sivulta ja herja joka tulee on
Koodia: [Valitse]
Installation aborted by user ja en mie sitä keskeyttäny. Operalla samaa herjaa ei tullu.

Jännä et operalla toi gnuradio 1-click anto ton herjan mikä aikasemmassa viestissä on, mut firefoxilla lähti asentamaan. Kaikki meni niinko pitikin, mutta lopputulos on sama herja ko ennenkin tota gnuradiota aukastessa. Eli lähtöpisteessä ollaan. Vanhan repoista asennetun gnuradion toki poistin ensin.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #5 : 05.09.2015 - klo:18:06 »
Laitoin asennuslähteeks --> http://download.opensuse.org/repositories/hamradio/openSUSE_13.2/
Asensin tämän jälkeen gnuradion ja pari tarpeellista hamiohjelmaa. Niitä mitä eniten oisin kaivannu, eli antennisuunnittelu ja analysointi ei löytyny. Tottakai niitä löytyy vaan jollekkin ubuntulle jota inhoon.

No mikään ei kuitenkaan muuttunu tän gnuradion suhteen. Asentuu kyllä, mutta kun käynnistää tulee vaan pien ruutu jossa allaoleva herja. Siitä mie en oo oppinu mitään lisää  :P

Herjaikkunan otsikko siltäosin ko se näkyy, eli on vissiin pidempikin.
Koodia: [Valitse]
liblapack.so.3: jaettua objektiedostoa ei voi avata
Koodia: [Valitse]
Cannot import gnuradio.

Is the python path environment variable set correctly?
    All OS: PYTHONPATH

Is the library path environment variable set correctly?
    Linux: LD_LIBRARY_PATH
    Windows: PATH
    MacOSX: DYLD_LIBRARY_PATH
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #6 : 06.09.2015 - klo:08:27 »
Mitäs tulostaa
Koodia: [Valitse]
rpm -qa | grep -i python

Varmista, että liblapack on asennettuna
Koodia: [Valitse]
sudo zypper in liblapack

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #7 : 06.09.2015 - klo:11:39 »
Noita ettsikelin yastissa aikasemmin kumpaakaan löytämättä, mutta se oli yastissa se.

Koodia: [Valitse]
linux-bkrn:~ # rpm -qa | grep -i python
python3-gobject-3.14.0-1.2.x86_64
python-gobject-3.14.0-1.2.x86_64
python3-apparmor-2.9.1-4.1.x86_64
python-ply-3.4-30.1.4.noarch
python-smbc-1.0.13-12.1.3.x86_64
python-kde4-knewstuff-4.14.3-8.2.x86_64
libpython3_4m1_0-3.4.1-4.2.1.x86_64
python-2.7.8-1.1.x86_64
python-CherryPy-3.3.0-2.1.4.noarch
python-kdebase4-4.11.20-29.5.x86_64
python-Jinja2-2.7.3-3.1.4.noarch
python-gobject2-2.28.6-25.1.5.x86_64
dbus-1-python-1.2.0-5.1.8.x86_64
python-cairo-1.10.0-14.1.3.x86_64
python-decorator-3.4.0-5.1.4.noarch
python-keyring-4.0-2.5.1.noarch
python-docopt-0.6.2-10.1.noarch
rpm-python-4.11.3-12.1.x86_64
libpython2_7-1_0-2.7.8-1.2.x86_64
python-wxWidgets-3_0-lang-3.0.1.1-1.2.x86_64
python-notify-0.1.1-30.1.3.x86_64
python-qt4-4.11.1-2.2.4.x86_64
python-configobj-5.0.6-1.3.noarch
python-pysmell-0.7.3-8.1.noarch
python-cups-1.9.66-2.1.3.x86_64
libboost_python1_54_0-1.54.0-10.1.3.x86_64
python-setuptools-5.4.1-2.1.4.noarch
python-cupshelpers-1.4.5-2.5.1.noarch
python-Cheetah-2.4.4-9.1.4.x86_64
python-kde4-akonadi-4.14.3-8.2.x86_64
python-sip-4.16.2-2.1.4.x86_64
python-six-1.8.0-1.2.noarch
python-cssselect-0.9.1-19.2.noarch
python3-3.4.1-4.2.1.x86_64
kate-python-plugins-4.14.3-4.12.x86_64
python-solv-0.6.11-13.1.x86_64
python-kde4-phonon-4.14.3-8.2.x86_64
python3-pip-1.5.6-2.1.3.noarch
python-jedi-0.9.0-7.2.noarch
gimp-plugins-python-2.8.14-1.5.x86_64
python-wxWidgets-3_0-3.0.1.1-1.2.x86_64
python3-setuptools-3.6-2.1.5.noarch
python-bottle-0.12.7-2.1.3.noarch
python-numpy-1.9.0-1.6.x86_64
python-gobject-cairo-3.14.0-1.2.x86_64
python-tk-2.7.8-1.1.x86_64
python-devel-2.7.8-1.2.x86_64
zypp-plugin-python-0.4-2.1.3.x86_64
python-gnomekeyring-2.32.0-22.1.3.x86_64
python-xml-2.7.8-1.2.x86_64
libpython2_7-1_0-32bit-2.7.8-1.2.x86_64
python-pyplete-0.0.5-7.1.noarch
python-lxml-3.3.5-2.1.4.x86_64
python-base-2.7.8-1.2.x86_64
python3-gobject-cairo-3.14.0-1.2.x86_64
python-simplejson-3.5.2-2.1.4.x86_64
python-gtk-2.24.0-14.1.4.x86_64
python-kde4-4.14.3-8.2.x86_64
python-pyudev-0.16.1-9.1.5.noarch
python-pycurl-7.19.3.1-2.1.6.x86_64
python-MarkupSafe-0.23-2.1.4.x86_64
python-kde4-khtml-4.14.3-8.2.x86_64
python-kde4-plasma-4.14.3-8.2.x86

Asennus män persiilleen
Koodia: [Valitse]
linux-bkrn:~ # zypper in liblapack
Loading repository data...
Reading installed packages...
'liblapack' not found in package names. Trying capabilities.
No provider of 'liblapack' found.
Resolving package dependencies...

Nothing to do.
linux-bkrn:~ # s

Senverran mie tota herjaa ymmärsin et joko noita ei oo tai ne on väärässä paikassa. En sitte löytäny niitä koneelta, asennuslähteistä enkä sitäkään missä ne pitäs olla  :P
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #8 : 06.09.2015 - klo:13:29 »
Sorry sen paketin nimi on liblapack3

Koodia: [Valitse]
sudo zypper in liblapack3


Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #9 : 06.09.2015 - klo:13:37 »
No sattuuhan näitä :)

Näyttäs olevan asennettu, mut lopputulosta ei kyl muuttanu mikskään :p

Koodia: [Valitse]
linux-bkrn:~ # zypper in liblapack3
Retrieving repository 'Packman Repository' metadata ......................[done]
Building repository 'Packman Repository' cache ...........................[done]
Loading repository data...
Reading installed packages...
'liblapack3' is already installed.
No update candidate for 'liblapack3-3.5.0-4.1.3.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
linux-bkrn:~ #
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #10 : 06.09.2015 - klo:13:57 »
en tiedä onko vaikutusta, mutta jostain syystä sinulla on alla oleva paketti 32 bit kun muut on 64bit
python-kde4-plasma-4.14.3-8.2.x86

kokeile poistaa tuo 32bit ja asenna  python-kde4-plasma-4.14.3-8.2.x86_64

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #11 : 06.09.2015 - klo:14:11 »
Ja kokeile avata komentoriviltä jos tulisi lisää infoa mikä mättää

Koodia: [Valitse]
/usr/bin/gnuradio-companion

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #12 : 06.09.2015 - klo:14:52 »
Yastin kautta näyttäs että kaikki python-kde4-plasma alkuset on 64:sia. Poistin ja sensin uudelleen ja tuloste on tää:

Koodia: [Valitse]
linux-bkrn:~ # rpm -qa | grep -i python
python3-gobject-3.14.0-1.2.x86_64
python-gobject-3.14.0-1.2.x86_64
python3-apparmor-2.9.1-4.1.x86_64
python-ply-3.4-30.1.4.noarch
python-smbc-1.0.13-12.1.3.x86_64
python-kde4-knewstuff-4.14.3-8.2.x86_64
libpython3_4m1_0-3.4.1-4.2.1.x86_64
python-2.7.8-1.1.x86_64
python-CherryPy-3.3.0-2.1.4.noarch
python-kdebase4-4.11.20-29.5.x86_64
python-Jinja2-2.7.3-3.1.4.noarch
python-gobject2-2.28.6-25.1.5.x86_64
dbus-1-python-1.2.0-5.1.8.x86_64
python-cairo-1.10.0-14.1.3.x86_64
python-decorator-3.4.0-5.1.4.noarch
python-keyring-4.0-2.5.1.noarch
python-docopt-0.6.2-10.1.noarch
rpm-python-4.11.3-12.1.x86_64
libpython2_7-1_0-2.7.8-1.2.x86_64
python-wxWidgets-3_0-lang-3.0.1.1-1.2.x86_64
python-notify-0.1.1-30.1.3.x86_64
python-qt4-4.11.1-2.2.4.x86_64
python-configobj-5.0.6-1.3.noarch
python-pysmell-0.7.3-8.1.noarch
python-kde4-plasma-4.14.3-8.2.x86_64
python-cups-1.9.66-2.1.3.x86_64
libboost_python1_54_0-1.54.0-10.1.3.x86_64
python-setuptools-5.4.1-2.1.4.noarch
python-cupshelpers-1.4.5-2.5.1.noarch
python-Cheetah-2.4.4-9.1.4.x86_64
python-kde4-akonadi-4.14.3-8.2.x86_64
python-sip-4.16.2-2.1.4.x86_64
python-six-1.8.0-1.2.noarch
python-cssselect-0.9.1-19.2.noarch
python3-3.4.1-4.2.1.x86_64
kate-python-plugins-4.14.3-4.12.x86_64
python-solv-0.6.11-13.1.x86_64
python-kde4-phonon-4.14.3-8.2.x86_64
python3-pip-1.5.6-2.1.3.noarch
python-jedi-0.9.0-7.2.noarch
gimp-plugins-python-2.8.14-1.5.x86_64
python-wxWidgets-3_0-3.0.1.1-1.2.x86_64
python3-setuptools-3.6-2.1.5.noarch
python-bottle-0.12.7-2.1.3.noarch
python-numpy-1.9.0-1.6.x86_64
python-gobject-cairo-3.14.0-1.2.x86_64
python-tk-2.7.8-1.1.x86_64
python-devel-2.7.8-1.2.x86_64
zypp-plugin-python-0.4-2.1.3.x86_64
python-gnomekeyring-2.32.0-22.1.3.x86_64
python-xml-2.7.8-1.2.x86_64
libpython2_7-1_0-32bit-2.7.8-1.2.x86_64
python-pyplete-0.0.5-7.1.noarch
python-lxml-3.3.5-2.1.4.x86_64
python-base-2.7.8-1.2.x86_64
python3-gobject-cairo-3.14.0-1.2.x86_64
python-simplejson-3.5.2-2.1.4.x86_64
python-gtk-2.24.0-14.1.4.x86_64
python-kde4-4.14.3-8.2.x86_64
python-pyudev-0.16.1-9.1.5.noarch
python-pycurl-7.19.3.1-2.1.6.x86_64
python-MarkupSafe-0.23-2.1.4.x86_64
python-kde4-khtml-4.14.3-8.2.x86_64
python3-base-3.4.1-4.2.1.x86_64
linux-bkrn:~ #

/usr/bin/gnuradio-companion ei anna mitään herjaa konsolissa, mutta silmille hyppää herjaruutu, joka taitaa olla aikalailla vanha tuttu.
Koodia: [Valitse]
Cannot import gnuradio.

Is the python path environment variable set correctly?
    All OS: PYTHONPATH

Is the library path environment variable set correctly?
    Linux: LD_LIBRARY_PATH
    Windows: PATH
    MacOSX: DYLD_LIBRARY_PATH
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #13 : 08.09.2015 - klo:17:24 »
Sain ongittua sen herjaikkunan otsikon kokonaan englanninkielisenä. Eli toi otsikko:


Herjaikkunan otsikko siltäosin ko se näkyy, eli on vissiin pidempikin.
Koodia: [Valitse]
liblapack.so.3: jaettua objektiedostoa ei voi avata

On kokonaan
Koodia: [Valitse]
liblapack.so.3: cannot open shared: file no such file or directory
ja herja sen alla oli tuolla ylempänä jo, mut pannaan se tähän vielä.

Koodia: [Valitse]
Cannot import gnuradio.

Is the python path environment variable set correctly?
    All OS: PYTHONPATH

Is the library path environment variable set correctly?
    Linux: LD_LIBRARY_PATH
    Windows: PATH
    MacOSX: DYLD_LIBRARY_PATH

Jännä, et normikäyttäjänä ei saa herjaikkunan otsikkoa näkyviin mut roottina saa, tosin englanniks. Tiedä sitte auttaako toi mitään.

muoks.
Mie ymmärrän ton niin, että tota --> liblapack.so.3 tiedostoa ei löydy sieltä mis se pitäs olla. Missä sit lieneekin. Jos ootte samaa mieltä, voisko joku jolla gnuradio on tai voi asentaa ettiä haulla et mis se pitäs olla ja mitä se tiedosto ylipäätään sisältää.
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #14 : 09.09.2015 - klo:01:35 »
Koodia: [Valitse]
/var/lib/rpm/alternatives/liblapack.so.3
/etc/alternatives/liblapack.so.3
/usr/lib64/liblapack.so.3
/usr/lib64/lapack/liblapack.so.3

Koodia: [Valitse]
linux-cs2a:/home/suser # ll /var/lib/rpm/alternatives/liblapack.so.3
-rw-r--r-- 1 root root 69 Sep 23  2014 /var/lib/rpm/alternatives/liblapack.so.3

linux-cs2a:/home/suser # ll /etc/alternatives/liblapack.so.3
lrwxrwxrwx 1 root root 32 Sep 23  2014 /etc/alternatives/liblapack.so.3 -> /usr/lib64/lapack/liblapack.so.3

linux-cs2a:/home/suser # ll /usr/lib64/liblapack.so.3
lrwxrwxrwx 1 root root 32 Sep 23  2014 /usr/lib64/liblapack.so.3 -> /etc/alternatives/liblapack.so.3

linux-cs2a:/home/suser # ll /usr/lib64/lapack/liblapack.so.3
lrwxrwxrwx 1 root root 18 Sep 23  2014 /usr/lib64/lapack/liblapack.so.3 -> liblapack.so.3.4.2


Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #15 : 10.09.2015 - klo:13:47 »
Kiitos! :)

/var/lib/rpm/alternatives/liblapack.so.3 Puuttuu alternatives kansiokin
/etc/alternatives/liblapack.so.3 Löytyy
/usr/lib64/liblapack.so.3 puuttuu
/usr/lib64/lapack/liblapack.so.3 Löytyy

Nippu herjoja.

Koodia: [Valitse]
Salasana:
linux-bkrn:~ # linux-cs2a:/home/suser # ll /var/lib/rpm/alternatives/liblapack.so.3
-bash: linux-cs2a:/home/suser: No such file or directory
linux-bkrn:~ # -rw-r--r-- 1 root root 69 Sep 23  2014 /var/lib/rpm/alternatives/liblapack.so.3If '-rw-r--r--' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf -rw-r--r--
linux-bkrn:~ # linux-cs2a:/home/suser # ll /etc/alternatives/liblapack.so.3
-bash: linux-cs2a:/home/suser: No such file or directory
linux-bkrn:~ # lrwxrwxrwx 1 root root 32 Sep 23  2014 /etc/alternatives/liblapack.so.3 -> /usr/lib64/lapack/liblapack.so.3
lrwxrwxrwx: command not found
linux-bkrn:~ # linux-cs2a:/home/suser # ll /usr/lib64/liblapack.so.3
-bash: linux-cs2a:/home/suser: No such file or directory
linux-bkrn:~ # lrwxrwxrwx 1 root root 32 Sep 23  2014 /usr/lib64/liblapack.so.3 -> /etc/alternatives/liblapack.so.3
lrwxrwxrwx: command not found
linux-bkrn:~ # linux-cs2a:/home/suser # ll /usr/lib64/lapack/liblapack.so.3
-bash: linux-cs2a:/home/suser: No such file or directory
linux-bkrn:~ # lrwxrwxrwx 1 root root 18 Sep 23  2014 /usr/lib64/lapack/liblapack.so.3 -> liblapack.so.3.4.2
lrwxrwxrwx: command not found
linux-bkrn:~ # ^C
linux-bkrn:~ #
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #16 : 11.09.2015 - klo:10:36 »
Sinulla on vähän turhaa kamaa tuossa komennon edessä siksi herjat. Kolme noista on vain linkkejä.

mitä sinulla tulostaa
Koodia: [Valitse]
zypper se --provides --detail liblapack.so.3
« Viimeksi muokattu: 11.09.2015 - klo:10:41 kirjoittanut harmie »

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #17 : 11.09.2015 - klo:11:42 »
Sinulla on vähän turhaa kamaa tuossa komennon edessä siksi herjat. Kolme noista on vain linkkejä.

Sitä se teettää kun keskittymiskyky puuttuu(kipujen takia)  :P
Jotenkin sitä ajattelee että koodiks merkattu copypastetaan konsoliin  :o

Koodia: [Valitse]
linux-bkrn:~ # zypper se --provides --detail liblapack.so.3
Retrieving repository 'openSUSEn paketointipalvelu - Mono:Yhteisö' metadata ............[done]
Building repository 'openSUSEn paketointipalvelu - Mono:Yhteisö' cache .................[done]
Retrieving repository 'Packman Repository' metadata ....................................[done]
Building repository 'Packman Repository' cache .........................................[done]
Retrieving repository 'openSUSE-13.2-Update' metadata ..................................[done]
Building repository 'openSUSE-13.2-Update' cache .......................................[done]
Loading repository data...
Reading installed packages...

S | Name             | Type    | Version     | Arch   | Repository       
--+------------------+---------+-------------+--------+------------------
i | liblapack3       | package | 3.5.0-4.1.3 | x86_64 | openSUSE-13.2-Oss
i | liblapack3       | package | 3.5.0-4.1.3 | x86_64 | openSUSE-13.2-0 
v | liblapack3       | package | 3.5.0-4.1.3 | i586   | openSUSE-13.2-Oss
  | liblapack3-32bit | package | 3.5.0-4.1.3 | x86_64 | openSUSE-13.2-Oss
linux-bkrn:~ #
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa Rantarosvo

  • Jäsen
  • Viestejä: 1111
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #18 : 17.09.2015 - klo:13:06 »
Alkaa usko tähän gnuradioon loppumaan  >:( Nyt noi liblapac3 tiedostot on samoissa paikoissa kun Harmiella. Ainoo mikä on muuttunu, niin herjaruudun otsikko. Se on nyt:
Koodia: [Valitse]
/usr/lib64/liblapack.so.3: tiedosto on liian lyhyt
Rosmo

"windows ajeluttaa sinua ympäriinsä; Linux antaa sinulle avaimet ja laittaa sinut kuskin istuimelle. On oma ongelmasi, jos et osaa ajaa."

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2780
  • Sukupuoli: Mies
Vs: Gnuradio ja sussu 13.2 vivaldista myös hiukan.
« Vastaus #19 : 17.09.2015 - klo:14:08 »
Alkaa usko tähän gnuradioon loppumaan  >:( Nyt noi liblapac3 tiedostot on samoissa paikoissa kun Harmiella. Ainoo mikä on muuttunu, niin herjaruudun otsikko. Se on nyt:
Koodia: [Valitse]
/usr/lib64/liblapack.so.3: tiedosto on liian lyhyt
Kopioitko tiedoston vai teitkö linkit? Jos et tehnyt linkkeinä niin kannattaa kokeilla sitä.