Kirjoittaja Aihe: Äänet lakkasivat toimimasta sovellusohjelmilla  (Luettu 5179 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

guest1593

  • Vieras
Äänet lakkasivat toimimasta sovellusohjelmilla
« : 18.04.2013 - klo:10:23 »
-ei selaimilla esim. youtubessa
-ei Amorokilla eikä muillakaan playereillä
-sen sijaan Yastin kautta äänimäärityksillä "toista testiääni" antaa äänet.

Asensin pavucontrollin ja paprefs:n...eikä niistä ollut yhtään apua.

Yastin kautta äänimäärityksissä on korttimalli ALS 4000 Audio Chipset kuten kuuluukin. Jostain syystä kytkentä sovelluksien ja äänikortin välillä hävinnyt. Tänä ennen toimineet hyvin...

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 833
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #1 : 18.04.2013 - klo:11:00 »
Onko koneessa useampia äänikortteja (esim. integroitu ja jokin muu)? Onko kotikansiossa .asoundrc-nimistä piilotiedostoa? Jos käynnistät päätteessä alsamixerin, (a) mikä tulee oletuslaitteeksi, (b) mitä muita laitteita on valittavissasi, kun painat F6?
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed; kannettava 1: openSUSE Tumbleweed; kannettava 2: CentOS Stream 9; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

guest1593

  • Vieras
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #2 : 18.04.2013 - klo:11:20 »
Tässä koneessa on alunperin ollut integroitu äänikortti joka lakkasi toimimasta jo vuosia sitten. Sen tilalle asennettu erillinen äänikortti joka toimiin Linux Mintin puolella (Alsa 4000)...

päätteeltä: alsamixer antaa tulokseksi...

card: pulse audio
chip: pulse audio

F6 antaa: default
               enter device name....

päätteeltä: ls -al ei näyttänyt piilotiedostoa...

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 833
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #3 : 18.04.2013 - klo:11:40 »
Tässä koneessa on alunperin ollut integroitu äänikortti joka lakkasi toimimasta jo vuosia sitten. Sen tilalle asennettu erillinen äänikortti joka toimiin Linux Mintin puolella (Alsa 4000)...

Tuo voi olla arvoituksen ratkaisu. On hyvin mahdollista, että oletuslaitteena on nyt se toimimaton integroitu piiri.

Lainaus
F6 antaa: default
               enter device name....

Tätä vähän ihmettelen. Minä olen saanut tuohon listaan yleensä defaultin lisäksi (vähintään) yhden numeroidun laitteen, joka on se todellinen äänikortti Pulseaudion takana.

Lainaus
päätteeltä: ls -al ei näyttänyt piilotiedostoa...

Kokeiles tällaista: luo jollakin tekstieditorilla (nano, KWrite, Kate, samantekevää) tuo ~/.asoundrc-tiedosto, jonka sisällöksi tulee:

Koodia: [Valitse]
pcm.!default {
type hw
card 1
}

ctl.!default {
type hw
card 1
}

Nämä rivit tekevät sen, että ALSAn oletuslaitteeksi tulee laite numero 1 oletusarvoisen 0:n sijaan. Tämä siis perustuu oletukseen, että jossakin siellä takana ne kumpikin laite vielä oleilisivat, vaikkei niitä jostakin syystä alsamixerissä näy. Tiedoston tallentamisen jälkeen kokeiltava ohjelma pitää käynnistää uudelleen (esim. selain, jos kokeilet Flashiä).

On kuitenkin mahdollista, että koska laitteita ei näy, niitä ei ole syystä tai toisesta määritettykään.
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed; kannettava 1: openSUSE Tumbleweed; kannettava 2: CentOS Stream 9; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

guest1593

  • Vieras
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #4 : 18.04.2013 - klo:12:08 »
Kiitos. Se tepsi. Kiinnostavaa olisi kyllä nyt sitten tietää mitä eilen ja tämän aamuisen välillä tapahtui sellaista että heitti asetukset niin, että alkoi lukea tuota integroitua äänikorttia.


Poissa Samuel

  • Jäsen
  • Viestejä: 357
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #5 : 18.04.2013 - klo:12:58 »
Niinpä lakkasivat täälläkin tomimasta. Eilen vielä pelitti illalla. Toi yllä oleva loitsu ei kelvannut. 12.3 toimi muuten muutaman päivä äänien kanssa? Mikäs nyt sitten eteen?

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 833
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #6 : 18.04.2013 - klo:13:09 »
Joskus laitteiston tunnistus vain yhtäkkisesti löytää jo kertaalleen hylätyn laitteen. Itsekin olen pöytäkoneessa ottanut BIOSissa integroidun äänikortin pois käytöstä, mutta aina satunnaisin ajoin jokin distro sen kumminkin löytää.

Saattaa auttaa: Yast > Laitteisto > Ääni > valitse kortti, jota et halua käyttää ja paina ”Poista”.

Ja joskus auttaa tuo ~/.asoundrc, joskus se, että sen poistaa. Kyse on vain siitä, mille numeroille kukin laite sattuu numeroitumaan, koska ALSA ottaa 0:ksi merkityn oletuslaitteekseen, ellei ~/.asoundrc toisin määrää.
pöytäkone 1: Debian GNU/Linux 11, Fedora 37; pöytäkone 2: openSUSE Tumbleweed; kannettava 1: openSUSE Tumbleweed; kannettava 2: CentOS Stream 9; RPi 1: Ubuntu 22.04 LTS; RPi 2: LibreELEC 10

guest1593

  • Vieras
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #7 : 18.04.2013 - klo:13:12 »
Taisi sen tempun tehdä Creative USB Headset eli jälkikasvun hankkimat kuulokkeet... sitä ei ilmeisesti tarvinne millään tavalla määritellä tuossa Yastin ääniasetuksessa...

Se näyttää muutenkin temppuilevan vähän miten sattuu Linuxilla, mm jumittavan näyttöä ym...

EDIT: Niin - tuo Creative USB Headset ei sitten näytäkään toimivan koneellani - muuta kuin testeissä (Kmix--->Ääniasetukset"Ääni- videoasetuksen ja kokeile") itse sovellukset eivät sitä tee...

guest1593

  • Vieras
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #8 : 18.04.2013 - klo:21:57 »
No niin. Sain kuin sainkin nyt nuo äänet kuulumaan sekä kovaäänisten että Creative USB Headsetin kautta.

Tuo integroidun äänikortin ottaminen pois BIOS:sta olisi tietysti paras keino vastasen varalta. Tosin missään muissa jakeluissa se ei ole hypännyt vastaan mutta kerta se on ensimmäinenkin. Pitäisi vain olla varmuus siitä miten se tapahtuu etten ota tuota vuonna 2007 ostettua äänikorttia vahingossa pois.

Päätteltä:
Koodia: [Valitse]
arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: ALS4000 [Avance Logic ALS4000], device 0: ALS4000 DSP []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


guest1593

  • Vieras
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #9 : 18.04.2013 - klo:22:00 »
Niinpä lakkasivat täälläkin tomimasta. Eilen vielä pelitti illalla. Toi yllä oleva loitsu ei kelvannut. 12.3 toimi muuten muutaman päivä äänien kanssa? Mikäs nyt sitten eteen?

Kiinnostava tapaus. Tuli heti mieleen että olisiko mahdollisesti joku päivitys sittenkin aiheuttanut tämän?

Poissa Samuel

  • Jäsen
  • Viestejä: 357
Vs: Äänet lakkasivat toimimasta sovellusohjelmilla
« Vastaus #10 : 19.04.2013 - klo:16:05 »
Meikä kun tohistaa, niin en oikeen tiedä mikä minulla johti tilanteeseen, että nyt toimi läppärillä ja pöytäkoneella .Ainakin Ystissa tein, että pyysin näyttämään ja päivittämään kaikki laitteet. Kun kaffeine ei toiminut dvd-asentamisen jälkeen poistin sen (ja riippuvuudet). Latasin vanhat versiot. Sitten poistin nekin. Sen jälkeen latasin kaffeinen uudelleen netistä ja ihme, nyt se toistaa musiikkia. Kaikille tuosta tietysti sanomattakin selviää, että minulla ei ole harmainta aavistusta , mikä vaikutti asiaan, mutta toistaiseksi kuuluu :)