Kirjoittaja Aihe: Kuinka saan AntiVir:n toimimaan?  (Luettu 5892 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

KimmoK

  • Vieras
Kuinka saan AntiVir:n toimimaan?
« : 21.03.2009 - klo:20:30 »
Uutena OpenSuse käyttäjänä ja lopullisesti M$ maailman jättäneenä nyt hiukan noviisina kysellen AntiVir:n asentamisesta ja toimintaan saamisesta.

Tähän mennessä tapahtunutta: imuttelin Funetin sivuilta mirrorista OpenSuse.DVD.iso filen, jolta asensin tämän distron lappariini. Ei mitään ongelmia, kaikki meni hyvin ja sen jälkeen kotiverkon tulostin ja wlan toimii upeasti.

Koska meillä on iso USB-kovo enemmän tai vähemmän backup-paikkana mm. valokuville ja muille enemmän tai vähemmän tärkeille jutuille, niin sen takia tarvetta myös tarvetta tähän OpenSuseen AntiVir:lle tai muulle virustorjunnalle. Vaimo kun backuppaa väikkärinsä tiedoston WinXp koneelta siihen, enkä halua saada/jakaa mitään pöpöjä tähän/tästä.

Siispä, Yastilla muistaakseni asensin AntiVir:n, joka löytyi kivasti tuolta DVD:lta. Se siis asentui helposti, mutta mutta. Sitä ei näy missään tai sitten en vaan yksinkertaisesti osaa a) aktivoida sitä tai b) löytää minne se on asentunut. Luulisi, että tuossa sysTrayssa oikeassa alakulmassa näkyisi jotakin, mutta eipä näy mitään.

Siispä te kokeneemmat ja viisaammat. Saisinko joltakin yksinkertaisen neuvon kuinka edetä tässä varmastikin aika yksinkertaisessa asiassa?

Kiitoksia teille vastaamiseen vaivautuville   ;D

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #1 : 21.03.2009 - klo:21:09 »
Uutena OpenSuse käyttäjänä ja lopullisesti M$ maailman jättäneenä nyt hiukan noviisina kysellen AntiVir:n asentamisesta ja toimintaan saamisesta.

Tähän mennessä tapahtunutta: imuttelin Funetin sivuilta mirrorista OpenSuse.DVD.iso filen, jolta asensin tämän distron lappariini. Ei mitään ongelmia, kaikki meni hyvin ja sen jälkeen kotiverkon tulostin ja wlan toimii upeasti.

Koska meillä on iso USB-kovo enemmän tai vähemmän backup-paikkana mm. valokuville ja muille enemmän tai vähemmän tärkeille jutuille, niin sen takia tarvetta myös tarvetta tähän OpenSuseen AntiVir:lle tai muulle virustorjunnalle. Vaimo kun backuppaa väikkärinsä tiedoston WinXp koneelta siihen, enkä halua saada/jakaa mitään pöpöjä tähän/tästä.

Siispä, Yastilla muistaakseni asensin AntiVir:n, joka löytyi kivasti tuolta DVD:lta. Se siis asentui helposti, mutta mutta. Sitä ei näy missään tai sitten en vaan yksinkertaisesti osaa a) aktivoida sitä tai b) löytää minne se on asentunut. Luulisi, että tuossa sysTrayssa oikeassa alakulmassa näkyisi jotakin, mutta eipä näy mitään.

Siispä te kokeneemmat ja viisaammat. Saisinko joltakin yksinkertaisen neuvon kuinka edetä tässä varmastikin aika yksinkertaisessa asiassa?

Kiitoksia teille vastaamiseen vaivautuville   ;D

Korjataanpa sen verran samantien, että Yast2:lla asensin ja Clamav kyseessä siis, mutta miksei voisi vaihtaa AntiVir softaan tarvittaessa. Puuttuuko siis minun lapparista joku käyttämistä vaativa moduuli?

guest141

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #2 : 21.03.2009 - klo:21:55 »
Oletko ajanut konsolissa komennon: antivir ? ( tietenkin itse antivir pitää olla asennettuna, vaikkapa Yast kautta ).

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #3 : 21.03.2009 - klo:22:12 »
Oletko ajanut konsolissa komennon: antivir ? ( tietenkin itse antivir pitää olla asennettuna, vaikkapa Yast kautta ).

ClamAv:sta puuttui Frontend palikka. Nyt toiminnassa .. ;D

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #4 : 21.03.2009 - klo:22:56 »
Oletko ajanut konsolissa komennon: antivir ? ( tietenkin itse antivir pitää olla asennettuna, vaikkapa Yast kautta ).

ClamAv:sta puuttui Frontend palikka. Nyt toiminnassa .. ;D

ClamAv sitten sai lähteä samantien, kun ei tunnistanut edes Eicaria. Antivir asennettu takaisin. terminaalista käynnistin joo nytten - kiitos vinkistä - mutta jäin kaipaamaan tietoa, onko se nyt millään tavalla tuolla taustalla aktiivisena? Mitään visuaalista merkkiä kun siitä ei näy missään ..

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4539
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #5 : 22.03.2009 - klo:00:51 »
ClamAv sitten sai lähteä samantien, kun ei tunnistanut edes Eicaria. Antivir asennettu takaisin. terminaalista käynnistin joo nytten - kiitos vinkistä - mutta jäin kaipaamaan tietoa, onko se nyt millään tavalla tuolla taustalla aktiivisena? Mitään visuaalista merkkiä kun siitä ei näy missään ..

Antiviriin löytyy graafinen käyttöliittymä

Koodia: [Valitse]
zypper in antivir-gui antivir-avguard
Tuo ohjelma tuskin toimii taustalla, ilmeisesti kyse on lähinnä on-demand tyyppisestä ratkaisusta.
En toki sano tätä 100% varmuudella koska en kyseistä ohjelmaa ole koskaan käyttänyt.



Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #6 : 22.03.2009 - klo:20:22 »
ClamAv sitten sai lähteä samantien, kun ei tunnistanut edes Eicaria. Antivir asennettu takaisin. terminaalista käynnistin joo nytten - kiitos vinkistä - mutta jäin kaipaamaan tietoa, onko se nyt millään tavalla tuolla taustalla aktiivisena? Mitään visuaalista merkkiä kun siitä ei näy missään ..

Antiviriin löytyy graafinen käyttöliittymä

Koodia: [Valitse]
zypper in antivir-gui antivir-avguard
Tuo ohjelma tuskin toimii taustalla, ilmeisesti kyse on lähinnä on-demand tyyppisestä ratkaisusta.
En toki sano tätä 100% varmuudella koska en kyseistä ohjelmaa ole koskaan käyttänyt.


Niin, miten sen vain saisin näkyviin? Utilites - Security - Antivit GUI kohtaa klikatessa kysytään root:n salasanaa ja sen jälkeen ei tapahdu mitään. Myönnetään, noviisi mikä noviisi, allekirjoittanut siis ..

Ei kellään sattuisi olemaan tuohon hyvää neuvoa? 

Terminalissa kun annan käskyn antivir --gui
Tulee ilmoitus STATUS(antivir): OK
Sitten tuo --avguard optio ja skannaa...
Jotenkin olisi minulle graafinen ulosanti jotenkin helpompaa .. tiedä häntä ..

Ei mitään muuta .. nada ..
« Viimeksi muokattu: 22.03.2009 - klo:20:30 kirjoittanut KimmoK »

Poissa jkaija

  • Jäsen
  • Viestejä: 551
  • Sukupuoli: Mies
    • OtaNetti
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #7 : 22.03.2009 - klo:20:35 »
ClamAv sitten sai lähteä samantien, kun ei tunnistanut edes Eicaria. Antivir asennettu takaisin. terminaalista käynnistin joo nytten - kiitos vinkistä - mutta jäin kaipaamaan tietoa, onko se nyt millään tavalla tuolla taustalla aktiivisena? Mitään visuaalista merkkiä kun siitä ei näy missään ..

Antiviriin löytyy graafinen käyttöliittymä

Koodia: [Valitse]
zypper in antivir-gui antivir-avguard
Tuo ohjelma tuskin toimii taustalla, ilmeisesti kyse on lähinnä on-demand tyyppisestä ratkaisusta.
En toki sano tätä 100% varmuudella koska en kyseistä ohjelmaa ole koskaan käyttänyt.


Niin, miten sen vain saisin näkyviin? Utilites - Security - Antivit GUI kohtaa klikatessa kysytään root:n salasanaa ja sen jälkeen ei tapahdu mitään. Myönnetään, noviisi mikä noviisi, allekirjoittanut siis ..

Ei kellään sattuisi olemaan tuohon hyvää neuvoa? 

Terminalissa kun annan käskyn antivir --gui
Tulee ilmoitus STATUS(antivir): OK
Sitten tuo --avguard optio ja skannaa...
Jotenkin olisi minulle graafinen ulosanti jotenkin helpompaa .. tiedä häntä ..

Ei mitään muuta .. nada ..
Itse aikoinaan Yast:lla asensin seuraavat paketit
antivir
antivir-gui
antivir-avguard

ja sen jälkeen antivir:n sivujen ohjeiden mukaan -> http://www.free-av.com/en/pages/22/faq.html
katso myös -> http://opensuse.fi/keskustelu/index.php?topic=2595.msg16728#msg16728
HP Pavilion15-p076no, Tumbleweed 64bit Plasma
Asus Prime X570P, AMD Ryzen 5 3600, 32GT, GeForce RTX2080, Tumbleweed 64bit Plasma

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #8 : 22.03.2009 - klo:21:03 »
Moi!

Luin tuon aikaisemman viestiketjusi aikaisemmin ja tein saman lisenssijutun. Antivir ilmoittaa nyt, että lisenssi mennyt umpeen eikä anna päivittää itseään.

Ei kai tässä mitään muuta vaikeaa ole kuin se, ett yht'äkkiä hyppään Win puolelta Linuxiin ja tarkoitus olla pysyvä tämä muutos. Pitää siis itse avoimesti sopeutua moniin eri asioihin. Terminal ikkunan tekstimuodossa annettuja käskyjä jne. tässä alettava opiskelemaan hiljalleen  :)

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4539
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #9 : 22.03.2009 - klo:21:03 »
Tiedostossa /usr/share/doc/packages/antivir-gui/README.SuSE sanotaan näin

Lainaus
The Avira AntiVir GUI by default installs a SUID-root binary

  /usr/lib/AntiVir/gui/bin/antivir_start.real

It enables the members of the antivir group to operate the
antivir virus scanner.

This RPM does not enable the SUID-root bit, so you have to
authenticate as root to be able to use the GUI. The desktop
icon we ship authenticates you and starts the GUI as root.

Before you're able to use it, it is required to enable the
GUI support in the
        /etc/avguard.conf
configuration file by setting the following options:

        # Enable and configure GUI support
        GuiSupport  yes
        GuiCAFile   /usr/lib/AntiVir/gui/cert/cacert.pem
        GuiCertFile /usr/lib/AntiVir/gui/cert/server.pem
        GuiCertPass antivir_default

Have fun,
 your openSUSE Team.

Luin tuon aikaisemman viestiketjusi aikaisemmin ja tein saman lisenssijutun. Antivir ilmoittaa nyt, että lisenssi mennyt umpeen eikä anna päivittää itseään.

Ei kai tässä mitään muuta vaikeaa ole kuin se, ett yht'äkkiä hyppään Win puolelta Linuxiin ja tarkoitus olla pysyvä tämä muutos. Pitää siis itse avoimesti sopeutua moniin eri asioihin. Terminal ikkunan tekstimuodossa annettuja käskyjä jne. tässä alettava opiskelemaan hiljalleen  :)

Lataa uusi lisenssi ja kopioi se /usr/lib/AntiVir-hakemistoon.

Koodia: [Valitse]
su -c "cp hbedv.key /usr/lib/AntiVir"
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #10 : 10.04.2009 - klo:23:39 »
No niin .. täällä taas neuvoja kyselemässä ..

Sain kuin sainkin tuon graafisenkin puolen pelaamaan, mutta ihan eritavalla kuin luulin. Päivityksiä en saa sitten mitenkään toimimaan vaikka tuosta JKaijan viestistä liitteen tallensin tai Antivirin sivuilta samaa .key tiedostoa tarjosin /usr/lib/Antivir kansioon. Joka kerta vaan sitkeästi tulee ilmoitus päivitys yrittäessä terminaalissa tai gui tilassa ettei onnaa. Graafinen puoli sanoo ettei ole oikeuksia kirjoittaa /usr/lib/Antivir kansioon.

No. Terminalissa su -> salasana -> cd /usr/lib kansioon ja sitten chmod a+w+x Antivir ja tarkistin ls - Antivir ja näyttäisi sille, että paukkuja olisi user oikeuksillakin kirjoittaa sinne. Ei vaan onnaa ei.

Antakaa yksinkertaiselle yksinkertaiset seikkaperäiset ohjeen  ;D

Poissa jkaija

  • Jäsen
  • Viestejä: 551
  • Sukupuoli: Mies
    • OtaNetti
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #11 : 11.04.2009 - klo:11:14 »
Moro,

Tein taas uuden koe asennuksen tuosta Antivir ohjelmasta.
Eli Yastissa hakusanaksi 'virus' klikkasin asennettavaksi tuon
'antivir-gui':n ja yast lisäsi kaikki nuo muut mitä on kuvassa 'virus1.png'

Käynnistin ohjelman...  ...
tuli 'virus2.png' mukainen virhe
ratkaisu siihen alla

Lainaus
Please edit your /etc/avguard.conf file so it will end like this:

# Enable and configure GUI support
GuiSupport yes
GuiCAFile /usr/lib/AntiVir/gui/cert/cacert.pem
GuiCertFile /usr/lib/AntiVir/gui/cert/server.pem
GuiCertPass antivir_default

Then try starting AntiVir GUI again.
Eli muokkaa tuo /etc/avguard.conf tiedoston loppu tollaiseksi kun tuossa ohjeessa.

Uusi käynnistys ...  OK
yritin päivitystä...
tuli 'virus3.png' mukainen virhe

ratkaisu siihen kopioida uusi hbdev.key

kansioon /usr/lib/AntiVir
...uusi päivitys yritys... ...OK
Sitten vielä 'guard':n käynnistysyritys...
tuli 'virus4.png' mukainen virhe
käynnistys yritys commandlineltä
Koodia: [Valitse]
:/usr/lib/AntiVir # ./avguard restart
Shutting down AntiVir on-access scanning facility: avguard
                                                         done
Starting AntiVir on-access scanning facility: avguard
- Verifying dazuko device                                failed
Selvittelyä netistä mikä maksaa....
...dazuko:a ei ollut ladattuna...
Koodia: [Valitse]
:/usr/lib/AntiVir # modprobe dazuko

:/usr/lib/AntiVir # ./avguard restart
Shutting down AntiVir on-access scanning facility: avguard     done
Starting AntiVir on-access scanning facility: avguard
- Verifying dazuko device                                      done
- Starting avguard daemon                                      failed
...PETKELE mikä nyt TAAS... googlegooglegoogle...

tarkista etc/sysconfig/antivir tiedosto että siellä on tuo AVGUARD_TYPE="workstation"

uusi yritys...
Koodia: [Valitse]
:/usr/lib/AntiVir # ./avguard restart
Shutting down AntiVir on-access scanning facility: avguard     done
Starting AntiVir on-access scanning facility: avguard
- Verifying dazuko device                                      done
- Starting avguard daemon                                      done

...hmmmm... Toimiiko nyt ???
HP Pavilion15-p076no, Tumbleweed 64bit Plasma
Asus Prime X570P, AMD Ryzen 5 3600, 32GT, GeForce RTX2080, Tumbleweed 64bit Plasma

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #12 : 11.04.2009 - klo:15:54 »
Testataanpa jälleen kerran ..   ;)

Kiitoksia taasen!

KimmoK

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #13 : 11.04.2009 - klo:21:28 »
Testataanpa jälleen kerran ..   ;)

Kiitoksia taasen!

KimmoK

Jotenkin sitä tuntee itsensä aika kädettömäksi. Olen tahkonnut vaikka kuinka tän kanssa tässä illalla ja just hokasin, ett olen hakannut päätäni seinään lukihäiriöisenä   ;D  Olen antanut itselleni oikeutta uutta Antivir kansioon, kun piti konffata AntiVir kansiota .. Case sensitive kun on Unix maailmassa olennainen asia ..  ;)  Enkös oo rohkea, kun uskallan myöntää omat kämmit  ;)

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #14 : 11.04.2009 - klo:21:31 »
Testataanpa jälleen kerran ..   ;)

Kiitoksia taasen!

KimmoK

Jotenkin sitä tuntee itsensä aika kädettömäksi. Olen tahkonnut vaikka kuinka tän kanssa tässä illalla ja just hokasin, ett olen hakannut päätäni seinään lukihäiriöisenä   ;D  Olen antanut itselleni oikeutta uutta Antivir kansioon, kun piti konffata AntiVir kansiota .. Case sensitive kun on Unix maailmassa olennainen asia ..  ;)  Enkös oo rohkea, kun uskallan myöntää omat kämmit  ;)

Kiitos Juha pitkämielisestä avustasi !! :)

KimmoK

  • Vieras
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #15 : 13.04.2009 - klo:19:44 »
Sinänsä ihan ok softa tuo AntiVir, mutta pari kysymystä teille, jotka mahdollisesti olette enemmän sitä käyttäneet:

- Terminalista käskytettynä onko mahdollista saada -ren tai -del optioden lisäksi toimintoa, että putsaisi automaattisesti ilman uudelleennimeämistä tai hävittämistä?

- Graafisessa skannauksessa ohjelma jämähtää joka kerta, kun tarkistaa JAVA tiedosto (.jar). Samoin graafisessa moodissa ei ole mahdollista valita muuta skannatavaa aluetta kuin Local. Valintaan olennaisesti vaikuttava rasti, mistä voisi valita mitä kansiorakenteen aluetta tarkistaisi, vain vilahtaa ja häviää siis pois. Bugi vai ominaisuus?

Poissa jkaija

  • Jäsen
  • Viestejä: 551
  • Sukupuoli: Mies
    • OtaNetti
Vs: Kuinka saan AntiVir:n toimimaan?
« Vastaus #16 : 14.04.2009 - klo:11:42 »
Moro,
Kannattaa varmaan kokeilla jotain muuta virus skanneria.
Itse testasin tänä aamuna seuraavat;
'clamav' saa asennettua yastin kautta. Puuttuu sähköpostiskannaus ja daemoni.
'Avast!' latasin rpm paketin muuten ok mutta puuttuu myös tuo sähköpostiskannaus ja daemoni.
'Panda' komentoikkuna ohjelma.
'f-secure' 30pv trial hallinta selaimen kautta.

Seuraavaa en enään jaksanut kokeilla
'F-prot' komentoikkuna ohjelma, GUI on erikseen saatavilla.

Vaikka olen nyt linuxia käyttänyt useamman vuoden niin jotenkin on tuo hiirikäyttöliittymä jäännyt vaatimukseksi noissa ohjelmissa wintoosa ajoilta, jotenka en noita komentoriviohjelmia sen kummoisemmin testannut.
Ja voihan noita lisääkin löytyä, mutta en enään tänään jaksanut muita kokeilla.

Ja onhan noita virus-ja vakoiluohjelmia linuxillekin ilmestynyt :o joten jätin nyt koneeseen tuon Avast!:n jos sitä joskus tulisi vaikka käytettyä. :-\
HP Pavilion15-p076no, Tumbleweed 64bit Plasma
Asus Prime X570P, AMD Ryzen 5 3600, 32GT, GeForce RTX2080, Tumbleweed 64bit Plasma