Kirjoittaja Aihe: Vmware ei toimi  (Luettu 4816 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vmware ei toimi
« : 31.10.2007 - klo:18:49 »
10.3 64 bit. Heittää erroria. Pitäis kai tuon toimia myös 64 bittisessä. Tuossa viimeiset rivit jos joku sais jotain tolkkua.

make[1]: Siirrytään hakemistoon "/usr/src/linux-2.6.22.9-0.4-obj/x86_64/default"
make -C ../../../linux-2.6.22.9-0.4 O=../linux-2.6.22.9-0.4-obj/x86_64/default modules
  CC [M]  /tmp/vmware-config4/vmmon-only/linux/driver.o
In file included from /tmp/vmware-config4/vmmon-only/linux/driver.c:80:
/tmp/vmware-config4/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘compat_exit’
/tmp/vmware-config4/vmmon-only/./include/compat_kernel.h:21: error: expected declaration specifiers or ‘...’ before ‘exit_code’
/tmp/vmware-config4/vmmon-only/./include/compat_kernel.h:21: warning: type defaults to ‘int’ in declaration of ‘_syscall1’
make[4]: *** [/tmp/vmware-config4/vmmon-only/linux/driver.o] Virhe 1
make[3]: *** [_module_/tmp/vmware-config4/vmmon-only] Virhe 2
make[2]: *** [modules] Virhe 2
make[1]: *** [modules] Virhe 2
make[1]: Poistutaan hakemistosta "/usr/src/linux-2.6.22.9-0.4-obj/x86_64/default"
make: *** [vmmon.ko] Virhe 2
make: Poistutaan hakemistosta "/tmp/vmware-config4/vmmon-only"
Unable to build the vmmon module.

Execution aborted.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4538
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Vmware ei toimi
« Vastaus #1 : 31.10.2007 - klo:19:17 »
Lataa vmware-any-any-updateXXX.tar.gz osoitteesta http://ftp.cvut.cz/vmware/  XXX on numerosarja, valitse uusin.

Pura paketti ja suorita sen sisällä oleva runme.pl-tiedosto.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Vmware ei toimi
« Vastaus #2 : 01.11.2007 - klo:08:38 »
Tänk juu ;)
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

tomppa

  • Vieras
Vs: Vmware ei toimi
« Vastaus #3 : 06.11.2007 - klo:18:24 »
Hei!

Joo mulla oli kans sama ongelma tuon vmwaren kanssa ja latasin tuon vmware-any-any-update109.tar.gz-tiedoston ja kun yritän purkamisen jälkeen ajaa ./runme.pl -scriptiä niin tulee ilmoitus:

Unable to open the installer database /etc/vmware/locations in read-mode

mikähän mahtaa olla vikana?

Poissa jari88

  • Käännösryhmä
  • *
  • Viestejä: 785
Vs: Vmware ei toimi
« Vastaus #4 : 06.11.2007 - klo:18:26 »
Ellen ihan väärässä ole niin suoritus oikeudet puuttuvat: root-tilassa konsolissa, kyseisessä kansioissa chmod a+x ja tiedoston nimi.
If i give you a penny you would be one penny richer and i would be a penny poorer,
but if i give you an idea then you would be a one idea more richer and i`d still got mine

~Albert Einstein

tomppa

  • Vieras
Vs: Vmware ei toimi
« Vastaus #5 : 06.11.2007 - klo:21:47 »
Joo nuo oikeudet pitäs olla kunnossa, mutta ei auta, sama ilmoitus tulee, ja tuon runme.pl- scriptin ilmoitus

Unable to open the installer database /etc/vmware/locations in read-mode  on sikäli outo, ettei tuollaista paikkaa ole edes olemassa.  /etc/vmware/ kansio löytyy muttei muuta (ja sekin taitaa olla jäämistöä siitä ku kokeilin vmplayeria), scriptissä on viittaus myös /installer.sh-scriptiin muttei tommostakaan kyllä löydy, tuo paketin purin ihan kotikansioon, mutta joo pitää pähkäillä myöhemmin lisää

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4538
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Vmware ei toimi
« Vastaus #6 : 06.11.2007 - klo:22:42 »
Joo nuo oikeudet pitäs olla kunnossa, mutta ei auta, sama ilmoitus tulee, ja tuon runme.pl- scriptin ilmoitus

Unable to open the installer database /etc/vmware/locations in read-mode  on sikäli outo, ettei tuollaista paikkaa ole edes olemassa.  /etc/vmware/ kansio löytyy muttei muuta (ja sekin taitaa olla jäämistöä siitä ku kokeilin vmplayeria), scriptissä on viittaus myös /installer.sh-scriptiin muttei tommostakaan kyllä löydy, tuo paketin purin ihan kotikansioon, mutta joo pitää pähkäillä myöhemmin lisää


Onhan tuo VMware asennettuna koneella?

Normaalisti tarvitset tuota vmware-any-any-update:a kun vmware-config.pl skriptin suorittaminen kaatuu virheeseen.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

tomppa

  • Vieras
Vs: Vmware ei toimi
« Vastaus #7 : 07.11.2007 - klo:08:35 »
Heh, no eipä tietänkää oo, stupid me;), luulin että tuossa ois ollu koko höskä, enkä kattonu asiaa sitten tarkemmin, piti jo ihmetellä, että hieman oudolta näyttää

thx