Kirjoittaja Aihe: Päivitysilmoituksen ongelma  (Luettu 953 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa Ktpen

  • Jäsen
  • Viestejä: 23
Päivitysilmoituksen ongelma
« : 21.06.2024 - klo:10:36 »
Minun Tumbleweed KDE järjestelmän Päivitykset täppä ja Discover ilmoittavat liitteenä olevan kuvan mukaisesista 4 ohjelman päivityksestä. Kun hyväksyn niiiden kaikkien päivittämisen, päivityksen lataus alkaa mutta katkeaa yht'äkkiä. Tätä on jatkunut jo pari viikkoa. Käsittääkseni olen tehnyt kaikki päivitykset. Päivitysilmoituksen alareunan Poista kaikki - täpän käsky ei toimi, vaan tämä ilmoitus toistuu heti uudestaan.

Kun ajan sudo zypper update ja sen jälkeen sudo zypper dup, saan molemmista vastaukseksi, että ei ole mitään tehtävää. Silti järjestelmän Päivtykset täppä ja Discover jatkavat tuota samaa päivitysilmotusta.

Ko. ilmoitus myös pysäyttää oikeiden päivitysten lataamisen Discoverin kautta ja nyt ne voi ladata/asentaa vain ajamalla sudo zypper update. Viimeksi tämä tapahtui tänään, kun mm. kernel 6.9.3 päivittyi uusimpaan  6.9.5-1.1:een.

Miten saisin tämän kuvassa olevan ehkä väärän (tai vanhentuneen) ilmoituksen joko poistumaan tai - jos se on vielä tarpeen - päivittamään ilmoittamansa ohjelmat ?

 




Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Vs: Päivitysilmoituksen ongelma
« Vastaus #1 : 22.06.2024 - klo:15:34 »
Minä olen ratkaissut tämän ongelman niin, että olen kieltänyt Discoveria (tai kuka se nyt onkaan) asettamasta tuota ilmoitusta. En koskaan asenna mitään Discoverilla, jos ei ole ihan äärimmäinen pakko, koska olen ymmärtänyt ettei kannata "sotkea" zypperillä ja Discoverilla asennettuja ohjelmia  samaan koneeseen.

Saat Discoverin ilmoitukset pois näin:
1. alhaalla/oikealla  klikkaa "näytä piiloitetut kuvakkeet"
2. tila ja ilmoitukset -palkista "ilmoitusalueen asetukset"
3. kuvakkeet
4. päivitykset alavetovalikko (minulla näyttää olevan valittuna "aina piilossa")

ps. jos käytät Tumbleweediä, niin älä käytä zypper update -komentoa. Käytä ainoastaan zypper dup -komentoa.
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa Ktpen

  • Jäsen
  • Viestejä: 23
Vs: Päivitysilmoituksen ongelma
« Vastaus #2 : 22.06.2024 - klo:17:03 »
@RaijaR Kiitos vinkeistä ! Kun ajoin Tumbleweed KDE:llä ensin sudo zypper dup (eli 'päiviä tuote TB'), niin sen jälkeen sudo zypper update ajo ei näytä enää mitäään päivitettävää.  Tämä lienee OK.

Em. ajojen jälkeen muutin 'Näytä piilotetut kuvakkeet' täpän asetuksia ohjeesi mukaisesti ja Päivitysilmoitus täppä häipyi ruudun alareunasta, mutta Discovery näytti edelleen samat 4 päivitettävää ohjelmaa sekä yhden uuden, eli Breeze GTK, joka ei ollutkaan päivittynet em. komennoilla. Valitsin Discoveryn listalta vain sen (Breeze GTK) ja se päivittyi, mutta ko. 4 ohjelmaa jäiviät edeleen Discovery:n listalle. eli ne eivät ne suostu päivittymään eikä poistumaan. Eli jotain Discovery kautta päivittyi, mikä ei ollut päivittynyt em. ajojen kautta.   

Discory:n päivittymättömien ohjelmien listalla ei ole sinänsä väliä, kunhan tämä tilanne (eli se, että jotkut ohjelmat eivät päivity eivätkä poistu päivitettävien listalta) ei muodostustu krittiseksi järjestelmän toimivuuden kannalta ja joutuisin sen vuoksi tekemämään tämän koko järjetelmän asennuksen uudestaan.

Katsotaan miten tämä tilanne kehittyy.






 

Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Vs: Päivitysilmoituksen ongelma
« Vastaus #3 : 23.06.2024 - klo:21:02 »
Heps,
En olisi kovin huolissani ohjelmistosi eheydestä, kunhan käytät zypper dup -komenota. Siihen on hyvä syy, ja se on selitetty ao. sivulla.
Koodia: [Valitse]
https://en.opensuse.org/SDB:Upgrade_TumbleweedPitää vielä yrittää löytää varma tieto siitä, että mikä on periaatteellinen ero Discoverin ja zypperin välillä. Täällä palstalla varmaan joku sen toki tietääkin.  ;)
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa png

  • Jäsen
  • Viestejä: 388
  • Sukupuoli: Mies
Vs: Päivitysilmoituksen ongelma
« Vastaus #4 : 24.06.2024 - klo:03:15 »
Heps,
En olisi kovin huolissani ohjelmistosi eheydestä, kunhan käytät zypper dup -komenota. Siihen on hyvä syy, ja se on selitetty ao. sivulla.
Koodia: [Valitse]
https://en.opensuse.org/SDB:Upgrade_TumbleweedPitää vielä yrittää löytää varma tieto siitä, että mikä on periaatteellinen ero Discoverin ja zypperin välillä. Täällä palstalla varmaan joku sen toki tietääkin.  ;)
Discover taitaa olla KDE Plasman alainen ohjelma. Taasen zypper on Opensusen koko järjestelmän alainen ohjelma.
Ja liittyykö Flatpack jotenkin tähän hommaan?
Kukaan ei voi tehdä kaikkea, mutta jokainen
voi tehdä jotakin; ja jos jokainen tekee jotakin,
tulee kaikki tehdyksi.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Vs: Päivitysilmoituksen ongelma
« Vastaus #5 : 24.06.2024 - klo:15:25 »
Koodia: [Valitse]
Discover taitaa olla KDE Plasman alainen ohjelma. Taasen zypper on Opensusen koko järjestelmän alainen ohjelma.
Ja liittyykö Flatpack jotenkin tähän hommaan?

Sen verran tiedän, että TW:ssä Discoverin voi poistaa, eikä haittaa tahtia  :)
Onkohan tuo Discover mukana jo Leapissa (15.5/15.6) vai uusi ominaisuus TW:ssä?
Ja kyllä, epäilen että liittyy jotenkin Flatpackiin?

Alla esimerkki. Zypperillä en voi asentaa Avidemuxia, mutta Discorilla voin ja se toimiikin, mutta zypper if avidemux -komento ilmoittaa, ettei sitä ole asennettu.


Koodia: [Valitse]
raija@kone1:~> sudo zypper in avidemux
[sudo] root-käyttäjän salasana:
Luetaan asennuslähteiden tietoja...
Luetaan asennettuja paketteja...
Ratkaistaan pakettien riippuvuuksia...

Ongelma: 1: asennettavan paketin avidemux-2.5.6-1699.9017.pm.75.x86_64 vaatimaa pakettia ”libvpx.so.8()(64bit)” ei tarjoa mikään lähde
 Ratkaisu 1: älä asenna pakettia avidemux-2.5.6-1699.9017.pm.75.x86_64
 Ratkaisu 2: jätä avidemux-2.5.6-1699.9017.pm.75.x86_64 riippuvuuksia huomioimatta

Valitse yllä olevista ratkaisuista numeron perusteella tai peruuta [1/2/p/t/?] (p): ^C
Yritetään lopettaa siististi…
raija@kone1:~>
raija@kone1:~> zypper if avidemux
Luetaan asennuslähteiden tietoja...
Luetaan asennettuja paketteja...


Tiedot kohteesta paketti avidemux:
----------------------------------
Asennuslähde            : Packman
Nimi                    : avidemux
Versio                  : 2.5.6-1699.9017.pm.75
Arkkitehtuuri           : x86_64
Toimittaja              : http://packman.links2linux.de
Koko asennettuna        : 11,4 MiB
Asennettu               : Ei
Tila                    : ei asennettu    <============= !!!!
lähdekoodipaketti       : avidemux-2.5.6-1699.9017.pm.75.src
Ylävirran verkko-osoite : http://fixounet.free.fr/avidemux/
Yhteenveto              : Video processing tool
Kuvaus                  :
    Avidemux is a free video editor designed for simple cutting, filtering and
    encoding tasks. It supports many file types, including AVI, DVD compatible
    MPEG files, MP4 and ASF, using a variety of codecs.
    Tasks can be automated using projects, job queue and powerful scripting
    capabilities.

raija@kone1:~>


Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa maksim

  • Jäsen
  • Viestejä: 29
  • Sukupuoli: Mies
Vs: Päivitysilmoituksen ongelma
« Vastaus #6 : 24.06.2024 - klo:19:44 »
Lainaus
Miten saisin tämän kuvassa olevan ehkä väärän (tai vanhentuneen) ilmoituksen joko poistumaan tai - jos se on vielä tarpeen - päivittamään ilmoittamansa ohjelmat ?
Nuo ohjelmat ovat käsittääkseni Flatpak-asennukseen liittyviä ohjelmia ja ne voisi päivittää komennolla
Koodia: [Valitse]
flatpak update
Heps,
En olisi kovin huolissani ohjelmistosi eheydestä, kunhan käytät zypper dup -komenota. Siihen on hyvä syy, ja se on selitetty ao. sivulla.
Koodia: [Valitse]
https://en.opensuse.org/SDB:Upgrade_TumbleweedPitää vielä yrittää löytää varma tieto siitä, että mikä on periaatteellinen ero Discoverin ja zypperin välillä. Täällä palstalla varmaan joku sen toki tietääkin.  ;)
Discover taitaa olla KDE Plasman alainen ohjelma. Taasen zypper on Opensusen koko järjestelmän alainen ohjelma.
Ja liittyykö Flatpack jotenkin tähän hommaan?

Discover on nimenomaan Plasman mukana tuleva päivitys-palikka.
Siihen on saatavissa Flatpak -lisäosa, jolla voi päivittää/asentaa flatpakin tarjoamia ohjelmia. (Flathub-repo pitää tietenkin olla asennettuna järjestelmään.)
Muistaakseni se on nimeltään
Koodia: [Valitse]
discover-flatpakZypper ei päivitä Flatpak-asennuksia.

Komennolla
Koodia: [Valitse]
flatpak listvoi tarkistaa on järjestelmässä flatpak -asennuksia.

Poissa Ktpen

  • Jäsen
  • Viestejä: 23
Vs: Päivitysilmoituksen ongelma
« Vastaus #7 : 07.07.2024 - klo:15:57 »
@maxim Kiitos paljon neuvoista ! Ajoin ensin flatpak-update, sitten flatpak-list, joka ilmoitti asennetut flatpak sovellukset/paketit. Sitten avasin Discovery:n ja päivitin kaikki sen ilmoittamat päivitykset, loppuksi Discovery:n pyytämä uudelleenkäynnistys. Nyt näyttää toimivan OK. Nyt Discory:ssä ei enää näy tätä ennen siellä näkyneet  pakettia. Merkitsen tämän asian ratkaistuksi.

Minulle uutta oli tuo flatpak-update komento. Se on kai ajettava aina ensin?