Kirjoittaja Aihe: Takaovi  (Luettu 3981 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa Ruutiukko

  • Jäsen
  • Viestejä: 15
Takaovi
« : 30.03.2024 - klo:01:31 »
Tumbleweed käyttäjien kannattaa päivittää pikaisesti. Ja jos SSH on käytössä niin ilmeisesti vain uudelleen asennus on turvallinen. OpenSUSE uutinen aiheesta https://news.opensuse.org/2024/03/29/xz-backdoor/

Takaovi ei koske Leap jakelua koska siinä vanhempi versio käytössä

Poissa tapio50

  • Jäsen
  • Viestejä: 69
Vs: Takaovi
« Vastaus #1 : 30.03.2024 - klo:06:21 »

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 926
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Takaovi
« Vastaus #2 : 30.03.2024 - klo:12:24 »
Ja kuten Debian-bugipostilistan keskusteluista käy ilmi, harkinnassa on monella taholla paitsi iso taaksepäinpäivitys myös mahdollisesti XZ:sta luopuminen esimerkiksi Zstd:n hyväksi. Aika pahasti on nyt käynyt.
« Viimeksi muokattu: 30.03.2024 - klo:17:40 kirjoittanut SuperOscar »
pöytäkone 1, kannettavat 1–3: Debian GNU/Linux 12; pöytäkone 2: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 14-RELEASE; RPi 2: LibreELEC 11

Poissa RaijaR

  • Jäsen
  • Viestejä: 1435
  • Sukupuoli: Nainen
Vs: Takaovi
« Vastaus #3 : 30.03.2024 - klo:19:14 »
Minä en tästä ymmärtänyt yhtään mitään. Miten tarkistan onko minulle tupsahtanut tämä ohjelma?
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa Ruutiukko

  • Jäsen
  • Viestejä: 15
Vs: Takaovi
« Vastaus #4 : 30.03.2024 - klo:23:20 »
Minä en tästä ymmärtänyt yhtään mitään. Miten tarkistan onko minulle tupsahtanut tämä ohjelma?

Jos olet viimeisen kuukauden aikana päivittänyt Tumbleweed jakelua niin sinullakin on/oli kyseinen takaovi. Sen voi tarkistaa ihan normikäyttäjänä komennolla rpm -q liblzma5

Vastauksen pitäisi olla (Tumbleweed) liblzma5-5.6.1.revertto5.4-3.2.x86_64 Jos ei ole niin kannattaa ajaa päivitys heti.

Poissa Ktpen

  • Jäsen
  • Viestejä: 20
Vs: Takaovi
« Vastaus #5 : 19.04.2024 - klo:16:57 »
@Ruutiukko

Kiitos ohjeesta ! 

Ajoin testin ja sain tulokseksi liblzma5-5.6.1.revertto5.4-3.1.x86_64, eli muuten lähes sama,  mutta revetro ei ole ohjeessasi mainittu versio revertto5.4-3.2 vaan ilmeisesti vanhempi revertto5.4-3.1.   Olen ladannut tarjotut Tumbleweedin päivitykset sitä mukaa, kun niitä on tullut käynnissä olevaan järjestelmääni. Minulla ei ole ymmärtääkseni käytössä SSH:ta, en ole sitä ainakaan tietoisesti asentanut.

Tämä takaportti on toiminut aika kauan aikaa tämän vuoden alussa. Siksi kysyisin, onko tämä testini tulos OK, eli onko ko. takaportin uhka väistynyt vai tulisiko minun tehdä tälle järjestelmälle vielä jotain ? Täysin uusi asennus ? Kaikkien mahdollisten salasanojen vaihto,, jota openSUSE:n tiedote kehottaa ?
 
« Viimeksi muokattu: 19.04.2024 - klo:17:21 kirjoittanut Ktpen »

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2773
  • Sukupuoli: Mies
Vs: Takaovi
« Vastaus #6 : 20.04.2024 - klo:10:45 »
Kyllä tuo ihan turvallinen versio on. Olisikohan tuo uudelleen asennus ollut vaan sellainen ainut tiedossa oleva varma keino päästä mahdollisista vaikutuksista eroon. Itse en ainakaan asentanut käyttöjärjestelmää uusiksi enkä myöskään vaihtanut jokapaikkaan salasanoja, mutta jokainen tekee sen mukaan mikä tuntuu turvalliselta omasta mielestä :)

Poissa Ktpen

  • Jäsen
  • Viestejä: 20
Vs: Takaovi
« Vastaus #7 : 23.04.2024 - klo:10:07 »
@harmie   Kiitos tiedoista !