Kirjoittaja Aihe: Ohjelmien graafinen asentaminen ei onnistu Linux Mint Edgessä 20.3  (Luettu 4453 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Graafisesti minkä tahansa ohjelman asennus ei onnistu. Asennus jää pyörittämään ympyrää ilmeisesti maailman tappiin. PPA repo lienee kunossa:

/etc/apt/sources.list.d/official-package-repositories.list:deb https://mirrors.c0urier.net/linux/linuxmint/packages una main upstream import backport
Koodia: [Valitse]
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]: Traceback (most recent call last):
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/sbin/aptd", line 39, in <module>
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     aptdaemon.core.main()
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/lib/python3/dist-packages/aptdaemon/core.py", line 2194, in main
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     daemon = AptDaemon(options, bus=bus)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/lib/python3/dist-packages/aptdaemon/core.py", line 1467, in __init__
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     self.worker = AptWorker(options.chroot, load_plugins)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/lib/python3/dist-packages/aptdaemon/worker/aptworker.py", line 205, in __init__
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     self._load_plugins(["modify_cache_after", "modify_cache_before",
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/lib/python3/dist-packages/aptdaemon/worker/__init__.py", line 191, in _load_plugins
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     dists, errors = pkg_resources.working_set.find_plugins(env)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 907, in find_plugins
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     env = Environment(self.entries)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 1044, in __init__
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     self.scan(search_path)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 1077, in scan
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     self.add(dist)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 1096, in add
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     dists.sort(key=operator.attrgetter('hashcmp'), reverse=True)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 2640, in hashcmp
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     self.parsed_version,
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:   File "/usr/local/lib/python3.8/dist-packages/pkg_resources/__init__.py", line 2694, in parsed_version
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]:     raise packaging.version.InvalidVersion(f"{str(ex)} {info}") from None
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]: pkg_resources.extern.packaging.version.InvalidVersion: Invalid version: '0.1.36ubuntu1' (package: python-debian)
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]: Error in sys.excepthook:
helmi 21 17:18:03 LinuxMint org.debian.apt[10075]: Traceback (most recent call last):

En tiedä liittyykö mitenkään asiaan, mutta tuollaistakin ilmoittelee (kuva). Ei kuitenkaan viitsi kertoa, miten tuo "välimuisti ladataan uudelleen".
Olisiko hyviä ideoita?

jk. taitaa olla ihan oikea vika, eikä vain minun osaamattomuutt - ainakin osittain  ;D

« Viimeksi muokattu: 21.02.2023 - klo:19:07 kirjoittanut RaijaR »
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa tapio50

  • Jäsen
  • Viestejä: 69
Koita vaihtaa ohjelmostolähteistä Pääpalvelin ja/tai pohjapalvelin.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Vaihdoin kyllä nuo palvelimet juurikin suomalaiseen ja ruotsalaiseen jo aiemmin, mutta ei auttanut ongelmaan.

Löysin netistä pitkän kirjoituksen samasta ongelmasta, joka oli kirjoitettu tänä vuonna, mutta en enää löytänyt sitä mistään. Tosin ei siinä ketjussa ollut mitään korjaus/pätsiehdotustakaan. Ilmeisesti selaimen hakuhistoria oli Linux Mintin puolella.

Jotta asia olisi tarpeeksi monimutkainen ymmärtää, ongelmat on velipojan Linux Mint Edgessä ja minulla oli sama paketti omalla koneella  qemu/kvm:ssä, mutta päivitin oman koneen eilen Linux Mint 21.1:een. Tarkoitus on testata upgrade tässä minun koneessa ennen kuin sohlaan velipojan koneen epäkuntoon.
Linux Mint Edge asennettiin aikoinaan velipojan koneeseen, koska Linux Mintiltä ei löytynyt vielä tarpeeksi uutta kerneliä (?).
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa tapio50

  • Jäsen
  • Viestejä: 69
Kokeilin Mint Edgeä ja ainakin minulla graafinen asennus toimii,
Suosittelen kuitenkin päivittämistä 21.0 versioon.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1446
  • Sukupuoli: Nainen
Jep. Tarkoitus on tosiaan päivittää kone 20.3 -> 21.0. Testailin omalla koneella ao. ohjetta ja hyvin pelitti minun koneella, mutta sitähän ei ikinä mitä tulee vastaan  ;)
Jos ei onnistu, niin sitten vaan päivitetään perinteissä systeemillä eli kaikki uusiksi ja kotihakemisto kopioidaan takaisin backupilta.

https://itsfoss.com/upgrade-linux-mint-version/
Pöytäkone ASUS ExpertCenter PN52, Tumbleweed, jossa nippu distroja QEMU/KVM:ssä.
Ja Väinö-minibulli :D
Huom! Kirjoitusvihreet tulee jostain aravuudesta...

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 931
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Suosittelen kuitenkin päivittämistä 21.0 versioon.

Mintissä on itse asiassa hyvin terve asenne päivittämiseen: älä suotta, ellei ole pakko :)
pöytäkone 1, kannettavat 1–3: Debian GNU/Linux 12; pöytäkone 2: openSUSE Tumbleweed; NUC: openSUSE Leap 15.5; RPi 1: FreeBSD 14-RELEASE; RPi 2: LibreELEC 11