Kirjoittaja Aihe: Päivitysongelma: Ohjelmistopäivitykset ja zypper ristiriidassa [Ratkaistu]  (Luettu 271 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 759
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Leap 15.2 -koneitani on jo jonkin aikaa piinannut se, ettei päivityksiä voi tehdä Plasman Ohjelmistopäivitykset-ilmoitusaluekuvakkeesta, koska päivitys pysähtyy saman tien virheilmoitukseen ”patch:openSUSE-2020-2261-1.noarch conflicts with virtualbox-kmp-default.x86_64”. sudo zypper ref; sudo zypper up toimii, oletettavasti koska ymmärtää olla asentamatta ristiriidan aiheuttavaa pakettia:

Koodia: [Valitse]
Seuraavia 3  päivityspakettia EI asenneta:
  gstreamer-plugins-bad-lang gstreamer-plugins-ugly-lang virtualbox-kmp-default

Mitenkähän nämä kaksi järjestelmää saisi taas jotenkin synkkaan?
« Viimeksi muokattu: 29.12.2020 - klo:13:10 kirjoittanut SuperOscar »
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 759
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Jaahas, ratkaisu löytyi kansainväliseltä openSUSE-foorumilta. Ensin pitää tehdä päivitys YaSTissa ja antaa sen ratkaista ydinmoduulin ongelma korvaamalla yksi paketti toisella. Tämän jälkeen ilmoitusaluekuvake löytää taas uuden joukon päivitettävää ja valittaa muista asioista (”There is no update candidate for flac-1.3.2-lp152.5.3.1.x86_64”) mutta siitä voi olla piittaamati ja puskea eteenpäin, jolloin parin kierroksen jälkeen kaikki lopulta rauhoittuu.
openSUSE Leap 15.2 (pöytäkone 1, kannettavat 1, 2 & 3), openSUSE Tumbleweed (pöytäkone 2), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2)