Kirjoittaja Aihe: Ohjelmistopäivitykset  (Luettu 1251 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa rekufaari

  • Jäsen
  • Viestejä: 226
  • Sukupuoli: Mies
Ohjelmistopäivitykset
« : 13.04.2020 - klo:08:45 »
Meni jotenkin sekaisin tuo päivitys systeemin tietokanta.
Nyt tulee tuollainen herja kun yritän päivitykset asentaa ?

Subprocess failed. Error: RPM failed: error: package bluez-5.48-lp151.8.9.1.x86_64 is not installed

Virhe tuli sen jälkkeen kun olin päivittämässä uudet päivitykset ja koneeni päätti sammua aivan yllättäen
kesken päivityksen.


Poissa raimo

  • Jäsen
  • Viestejä: 197
  • Sukupuoli: Mies
Vs: Ohjelmistopäivitykset
« Vastaus #1 : 13.04.2020 - klo:11:15 »
Oletko kokeillut ihan vaan näin?
Koodia: [Valitse]
sudo zypper in bluez

Poissa rekufaari

  • Jäsen
  • Viestejä: 226
  • Sukupuoli: Mies
Vs: Ohjelmistopäivitykset
« Vastaus #2 : 14.04.2020 - klo:19:33 »
Oletko kokeillut ihan vaan näin?

Kyllä olen ja väittää asennetun.
Kohde "bluez" on jo asennettu.
Ei päivitysehdotuksia "bluez-5.48-lp151.8.12.1.x86_64". Uusin saatavilla oleva versio on jo asennettu.

Jotenkin se tietokanta on sekaisin eikä asenna siitä alapalkin ohjelmistopäivitykset painikkeesta vaan herjaa tuota bluez juttua.
« Viimeksi muokattu: 14.04.2020 - klo:19:44 kirjoittanut rekufaari »

Poissa RaijaR

  • Jäsen
  • Viestejä: 1053
  • Sukupuoli: Nainen
Vs: Ohjelmistopäivitykset
« Vastaus #3 : 15.04.2020 - klo:00:02 »
Tulipahan vain mieleen, että voisiko sen bluez:n vain poistaa ja asentaa uudestaan?
zypper rm bluez
zypper in bluez

Tai voisiko yrittää puhdistaa välimuistin?
zypper cc

Oheisessa tekstitiedostossa lisää zypper komentoja.
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa rekufaari

  • Jäsen
  • Viestejä: 226
  • Sukupuoli: Mies
Vs: Ohjelmistopäivitykset
« Vastaus #4 : 15.04.2020 - klo:22:17 »
Tulipahan vain mieleen, että voisiko sen bluez:n vain poistaa ja asentaa uudestaan?
zypper rm bluez

Eipä tunnu auttavan..
(5/5) Poistetaan bluez-5.48-lp151.8.12.1.x86_64 ..............................................................[virhe]
(126)bluez-5.48-lp151.8.12.1.x86_64(@System) poisto epäonnistui:
Virhe: Subprocess failed. Error: RPM-virhe: error: package bluez-5.48-lp151.8.12.1.x86_64 is not installed

Tapahtui virhe paketin asennuksen tai poiston yhteydessä:
Failed to cache rpm database (1).
Historia:
 - 'rpmdb2solv' '-r' '/' '-X' '-p' '/etc/products.d' '/var/cache/zypp/solv/@System/solv' '-o' '/var/cache/zypp/solv/@System/solvybc5wN'
rpmdb2solv: inconsistent rpm database, key 3015 not found. run 'rpm --rebuilddb' to fix.

Poissa RaijaR

  • Jäsen
  • Viestejä: 1053
  • Sukupuoli: Nainen
Vs: Ohjelmistopäivitykset
« Vastaus #5 : 16.04.2020 - klo:14:59 »
Sittenhän voisi vielä kokeilla tuota rpm --rebuilddb, jos vika on vielä päällä?
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa rekufaari

  • Jäsen
  • Viestejä: 226
  • Sukupuoli: Mies
Vs: Ohjelmistopäivitykset
« Vastaus #6 : 17.04.2020 - klo:22:36 »
Sittenhän voisi vielä kokeilla tuota rpm --rebuilddb, jos vika on vielä päällä?
Kiitos vinkistä, nyt taitaa taas systeemini olla ihan kunnossa..

Poissa Samuel

  • Jäsen
  • Viestejä: 317
Vs: Ohjelmistopäivitykset
« Vastaus #7 : 02.05.2020 - klo:10:28 »
Muuten on "arokieriä" aika mielenkiintoinen ja mennyt suht' hyvin sen käyttö, mutta nyt tökkii päivitys.

Pysähtyy tuohon:  ( Päivitysvirhe There is no update candidate for libbrlapi0_7-6.0-109.23.x86_64 )

( Tarjolla on 665 uutta päivitystä  ) ;)

Mietin millä lääkkeillä ja loitsuilla yrittäisi ongelmaa hoitaa ?


 

Poissa RaijaR

  • Jäsen
  • Viestejä: 1053
  • Sukupuoli: Nainen
Vs: Ohjelmistopäivitykset
« Vastaus #8 : 02.05.2020 - klo:11:56 »
Minulta tuo libbrlapi0_7 löytyy arokierijästä. Ja olethan päivittänyt arokierijän komennolla zypper dup?
========================================
kone3:~ # zypper info libbrlapi0_7
Retrieving repository 'paikallinen hakemisto' metadata ..................................................................[done]
Building repository 'paikallinen hakemisto' cache .......................................................................[done]
Loading repository data...
Reading installed packages...

Information for package libbrlapi0_7:
-------------------------------------
Repository     : repo-oss
Name           : libbrlapi0_7
Version        : 6.0-4.5
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 128.5 KiB
Installed      : Yes (automatically)
Status         : up-to-date
Source package : brltty-6.0-4.5.src
Summary        : Library to use BRLTTY from applications
... jne ...
========================================
Tuolla on listattuna repot: https://en.opensuse.org/Package_repositories

Minulla on käytössä nämä repot ja niillä olen pärjännyt  :D
# | Alias                                                        | Name                  | Enabled  | GPG Check | Refresh
--+-------------------------------------+-----------------------+---------+-----------+--------
1 | http-download.opensuse.org-c089887c| KDE:Extra                   | Yes     | (r ) Yes  | Yes
2 | packman                                                | packman                     | Yes     | (r ) Yes  | Yes
3 | packman-essentials                              | packman-essentials    | Yes     | (r ) Yes  | Yes
4 | raija                                                        | paikallinen hakemisto  | Yes     | ( p) Yes  | Yes
5 | repo-non-oss                                         | repo-non-oss               | Yes     | (r ) Yes  | Yes
6 | repo-oss                                                | repo-oss                       | Yes     | (r ) Yes  | Yes
7 | repo-update                                           | repo-update                  | Yes     | (r ) Yes  | Yes
8 | teamviewer                                            | TeamViewer - x86_64 | Yes     | (r ) Yes  | No
9 | x86_64                                                   | brave-browser             | No      | ----      | ----
Pöytäkone NUC Intel NUC8i7BEH, openSUSE Tumbleweed
Läppäri Acer Aspire V7,  en itsekään tiedä, vaihtuu niin sukkelaan
Läppäri Acer Aspire V5, Windows 10 ja Linux Mint 19.3?
Ja Väinö-minibulli :D

Poissa Samuel

  • Jäsen
  • Viestejä: 317
Vs: Ohjelmistopäivitykset
« Vastaus #9 : 04.05.2020 - klo:11:07 »
Kiitoksia Raija R muistutuksesta.

Tuolla loitsulla taas selvittiin, umpiperästä. Eli toi on varmempi tapa päivittää koko hössäkkä :)

Poissa mrl586

  • Jäsen
  • Viestejä: 152
Vs: Ohjelmistopäivitykset
« Vastaus #10 : 07.07.2020 - klo:08:07 »
Pakettivarastot kannattaa virkistää aina välillä, jos paketit ovat kadoksissa.
Koodia: [Valitse]
sudo zypper ref