Kirjoittaja Aihe: Mistä reposta asennus?  (Luettu 13478 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

harzu

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #20 : 09.04.2007 - klo:22:25 »
No ongelmaksi jäi edelleen se, että Amarok ei suostu noin vain päivittymään uusimpaan versioon Gurusta. Riippuvuudet ei ole kunnossa. Kannattaako/uskaltaako sille tehdä mitään?

Ulkoasu ei myöskään suostu vaihtumaan. Asensin dust_blue tyylin mutta mitään muutosta ei  tapahdu. Missähän vika?

guest158

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #21 : 09.04.2007 - klo:22:33 »
Jos riittää Susen viralliset päivitykset, niin mitään lähteitä ei tarvi lisätä mikäli on asennuksen yhteydessä muistanut ruksittaa kohdan rekisteröidy nyt... se kun laittaa sen virallisen päivityslähteen kyllä toimintaan.

Sen rekisteröitymisen voi toki tehdä asennuksen jälkeenkin Yastisata valitsemalla järjestelmänvalvojan asetukset ja sieltä internetpäivityksen määritys ja eikun ruksi ruutuun rekisteröidy nyt...
Asennuslähteiden saamiseksi ei tarvitse rekisteröityä mihinkään.

juu ei oo pakko, mutt sillon pitää tietää päivityslähde - se virallinenkin - ja asettaa se ihan itse.
Rekisteröitymällä se tulee automatis - sitä vaan tarkoitin esittää


guest158

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #22 : 09.04.2007 - klo:22:42 »
No ongelmaksi jäi edelleen se, että Amarok ei suostu noin vain päivittymään uusimpaan versioon Gurusta. Riippuvuudet ei ole kunnossa. Kannattaako/uskaltaako sille tehdä mitään?

Ulkoasu ei myöskään suostu vaihtumaan. Asensin dust_blue tyylin mutta mitään muutosta ei  tapahdu. Missähän vika?

Amarokin päivittymiseen ei tarvita Gurua. Mulla ei se oo päivityslähteenä, mutt kyll Amarok päivittyy.
nyt näytti olevan versio 1.4.5-14.2 ja se löytyy KDE:n päivityksiä haettaessa ekana vaihtoehtona

Mulla lähteinä ns virallinen päivityspaikka (ne rekisteröitymisen yhteydessä tulleet yliopistot, ym)
KDE, Packmann, xorg, non-oss, nvidia ...eikä kait muita.

guest158

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #23 : 09.04.2007 - klo:22:48 »
No ongelmaksi jäi edelleen se, että Amarok ei suostu noin vain päivittymään uusimpaan versioon Gurusta. Riippuvuudet ei ole kunnossa. Kannattaako/uskaltaako sille tehdä mitään?

Ulkoasu ei myöskään suostu vaihtumaan. Asensin dust_blue tyylin mutta mitään muutosta ei  tapahdu. Missähän vika?

joidenkin ohjelmien kohdalla tulee ilmoitus ristiriidasta/ristiriidoista. Niihin suhtautuminen on ihan tapauskohtaista.
Ennen repo-aikaa tuli ristiriitailmo aina esim openofficen päivityksen kohdalla kun se valitti suomennoksen ja kde-tuen ristiriitaisuuksista ja antoi ratkoisuvaihtoehtoja. joku oli, ett älä välitä ja joku ett poista ne ristiriitoja aiheuttavat ja minähän valitsin aina openofficen päivityksen kohdalla sen ja asensin sitt uudemmat paketit tilalle, kun ne oli samassa lähdehakemistossa. Silloin siis vielä imutettiin paketit ensin himaan ja asennettiin ne paketit yks kerrallaan OO:n tapauksessa minä aina kolme pakettia.

harzu

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #24 : 10.04.2007 - klo:19:33 »
Semmoinen juttu vielä, että mitä näiden i586 ja i686 ero on?

juippis

  • Vieras
Vs: Mistä reposta asennus?
« Vastaus #25 : 14.04.2007 - klo:09:56 »
NNoh, ne on prosessoriarkkitehtuureita gcc-kääntäjille (tai jotain yhtä teknistä). Intel kai nuo merkit laittoi liikkeelle, mutta esimerkiksi AMD:n Athlonilla toimii nuo i-paketit ihan yhtä hyvin.

Mitä suurempi luku on, sitä uudempaa prosessorimallia ne tukevat. Tai no, i386:lle optimoidut binäärit toimii aivan jokaisella koneella, mutta i686 ei välttämättä toimi vanhemmilla prosessoreilla, jotka olisivat i586 tai i386 mallia, tai jos ne toimivat niin meno on hitaampaa. Muun muassa 32-bittinen Ubuntu käyttää i386-paketteja. Se 'nopeusero' i386:n ja i586:n o niin pieni ja hyödytön, että sitä ei kannata käyttää. Nopeusero voi näkyä joissain isoissa paketeissa, kuten gcc ja glibc.

Voit kuitenkin huoletta ajaa i586 ja i686 -paketteja ristiin openSUSEssa.

Jos haluat tietää asiasta lisää, sano 'info gcc' terminaalissa ja navigoi tiesi -> Invoking GCC -> Submodel options -> i* tai x86_64

http://www.linux-me.org/index.php?option=articles&task=viewarticle&artid=19&Itemid=3