Kirjoittaja Aihe: web-kamera ongelma  (Luettu 6905 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

guest857

  • Vieras
web-kamera ongelma
« : 31.08.2011 - klo:10:59 »
Eli tuli hommattua tollanen halpis kamera ebaysta ja sanomistahan siitä tulee  ;D Mut sen verran sentään olen edistynyt, että komento
Koodia: [Valitse]
luvcview avaa ohjelman joka näyttää kuvaa ihan hienosti ja sillä voi kuvata jopa videota. Kamera on siis toimiva. Mikään muu ohjelma sitten ei tunnukkaan tietävän kameran olemassa olosta.
Koodia: [Valitse]
lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 1c4f:3001 SiGma Micro
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c051 Logitech, Inc. G3 (MX518) Optical Mouse
Bus 003 Device 003: ID 0ace:1215 ZyDAS WLA-54L 802.11bg (zd1211rw)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Eli kamera näyttää olevan SiGma Micro ja guuglella näytti löytyvän sellaista että tuki pitäois olla ytimessä jo kai   ::)
Halu olisi saada kamera toimimaan lähinnä skypen ja ehkä myös juuston kanssa, toki tuo luvcview välttää juuston korvikkeena... Tuleeko sopivaa temppua kellään mieleen mitä tehdä?

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: web-kamera ongelma
« Vastaus #1 : 31.08.2011 - klo:12:22 »
Ekana koittasin konsolissa mitä sanoo komento cheese.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2782
  • Sukupuoli: Mies
Vs: web-kamera ongelma
« Vastaus #2 : 31.08.2011 - klo:12:43 »
Kokeile asentaa  libv4l
Koodia: [Valitse]
su
zypper in libv4l

Kokeili sitten käynnistää skype komentoriviltä
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype

guest857

  • Vieras
Vs: web-kamera ongelma
« Vastaus #3 : 31.08.2011 - klo:15:20 »
Ekana koittasin konsolissa mitä sanoo komento cheese.
Ei kerro mitään, juusto vaan aukee ja ilmoittaa,ettei löydä laitetta.

Koodia: [Valitse]
zypper in libv4l
...
Luetaan asennuslähteiden tietoja...
Luetaan asennettuja paketteja...
Kohde 'libv4l' on jo asennettu.
Kohteelle 'libv4l' ei löydy päivitysehdotuksia.
Ratkaistaan pakettien riippuvuuksia...

Ei tehtävää.

Kokeili sitten käynnistää skype komentoriviltä
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Vissiin tällä ratkesi ton skypen ongelma.  Testissä ainaski sain naamani näkyviin  ;D  oisko tolle juustolle vielä loitsua?

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2782
  • Sukupuoli: Mies
Vs: web-kamera ongelma
« Vastaus #4 : 31.08.2011 - klo:15:32 »
Vissiin tällä ratkesi ton skypen ongelma.  Testissä ainaski sain naamani näkyviin  ;D  oisko tolle juustolle vielä loitsua?
Kokeilitko tätä?
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese

guest857

  • Vieras
Vs: web-kamera ongelma
« Vastaus #5 : 31.08.2011 - klo:15:36 »

Kokeili sitten käynnistää skype komentoriviltä
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
Vissiin tällä ratkesi ton skypen ongelma.  Testissä ainaski sain naamani näkyviin  ;D
hmm skypekin pitänee käynnistää aina tolla komentopätkällä... ei nimittäin tuolta valikosta käynnistettynä toiminu... Mutta pikakuvakkeen teko nyt ei oo ongelma.

Kokeilitko tätä?
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so cheese
Juu sama tulos kuin
Koodia: [Valitse]
cheese eli ei löydä laitetta.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2782
  • Sukupuoli: Mies
Vs: web-kamera ongelma
« Vastaus #6 : 31.08.2011 - klo:15:42 »

hmm skypekin pitänee käynnistää aina tolla komentopätkällä... ei nimittäin tuolta valikosta käynnistettynä toiminu... Mutta pikakuvakkeen teko nyt ei oo ongelma.

Kyllä sen voi lisätä myös sinne käynnistysvalikkoon.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2782
  • Sukupuoli: Mies
Vs: web-kamera ongelma
« Vastaus #7 : 31.08.2011 - klo:15:45 »
kokeile vielä jos tämä toimisi.
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so cheese

guest658

  • Vieras
Vs: web-kamera ongelma
« Vastaus #8 : 31.08.2011 - klo:16:44 »
Itsekkin olen paininut tuon cheese-ohjelman kanssa tässä KDE puolella ja sain sen toimimaan seuraavin konstein: http://opensuse.fi/keskustelu/index.php?topic=3990.msg27064#msg27064

Lisäys: Asensin nyt tähän tämän cheesen ja lähti toimimaan ilman tuota minun ohjettakin, että ilmeisesti ovat päivittäneet joitakin paketteja, kun ei tarvitse tuota gstreameriakaan (gstreamer-0_10-plugins-good-extra) asentaa. Niin vielä sen verran, että olen asentanut tuon xawtv ohjelman, jos se on asentanut joitakin puuttuvia ohjelmia mitä tuo cheese tarvitsee?

Lisäys 2: Testasin vielä tuon juuston asennusta, kun tässä asentelin uudestaan susen. Ei tarvinnut mitään lisäkikkareita ja gstreamerin vaihtoja tehdä vaan nyt tuo juusto asentui ihan nätisti. Ovat korjannet sen tähän KDE:hen toimivaksi. Ei ole muuta muutosta tuon live-cd:n oletusasennukseen kuin se, että jätin tuon pulse-audion asentamatta ja sillä tuskin on tähän vaikutusta.

guest857

  • Vieras
Vs: web-kamera ongelma
« Vastaus #9 : 03.09.2011 - klo:22:55 »
kokeile vielä jos tämä toimisi.
Koodia: [Valitse]
LD_PRELOAD=/usr/lib/libv4l/v4l2convert.so cheese
Ei pelitä, ei löydy edelleenkään...  :-\