Kirjoittaja Aihe: opensuse 11.3 ja wlan ongelma  (Luettu 6557 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

guest1136

  • Vieras
opensuse 11.3 ja wlan ongelma
« : 26.08.2010 - klo:09:36 »
Joo elikkäs wlania en saa toimimaan, voisko joku viisaampi neuvoa?
Ja tähän pari tulostetta alle, toivottavasti valaisevat asiaa.

iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

lspci -knn
00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (int gfx) [1022:9602]
00:04.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 0) [1022:9604]
        Kernel driver in use: pcieport
00:07.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 3) [1022:9607]
        Kernel driver in use: pcieport
00:09.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 4) [1022:9608]
        Kernel driver in use: pcieport
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [AHCI mode] [1002:4391]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ahci
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ohci_hcd
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ohci_hcd
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ehci_hcd
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ohci_hcd
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ohci_hcd
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ehci_hcd
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3a)
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: piix4_smbus
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: HDA Intel
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
        Subsystem: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:14.5 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller [1002:4399]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: ohci_hcd
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Processor HyperTransport Configuration [1022:1300] (rev 40)
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Processor Address Map [1022:1301]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Processor DRAM Controller [1022:1302]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Processor Miscellaneous Control [1022:1303]
        Kernel driver in use: k10temp
00:18.4 Host bridge [0600]: Advanced Micro Devices [AMD] Family 11h Processor Link Control [1022:1304]
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc RS780M/RS780MN [Radeon HD 3200 Graphics] [1002:9612]
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: radeon
02:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8042 PCI-E Fast Ethernet Controller [11ab:4357] (rev 10)
        Subsystem: Hewlett-Packard Company Device [103c:308c]
        Kernel driver in use: sky2
06:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
        Subsystem: Hewlett-Packard Company Device [103c:1508]
        Kernel driver in use: b43-pci-bridge


guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #1 : 26.08.2010 - klo:10:12 »
hmmm  koitan päätteessä tätä "sudo /usr/sbin/install_bcm43xx_firmware"

kerron jos toimii

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2724
  • Sukupuoli: Mies
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #2 : 26.08.2010 - klo:10:16 »
Kyllä toi pitäisi toimia ongelmitta.

Onhan sulla käyttäjän hallinnoima verkkotyökalu käytössä?
Yast --> verkkolaitteet --> verkkoasetukset ja sieltä yleiset valinnat välilehti

Lisäksi sinun tulee asentaa ajuri tolle. Lisää packman asennuslähde ja asenna paketti b43-firmware.

Toinen vaihtoehto on asentaa packamanin asennuslähteistä paketti b43-fwcutter ja antaa alla oleva komento
Koodia: [Valitse]
su
/usr/sbin/install_bcm43xx_firmware


Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2724
  • Sukupuoli: Mies
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #3 : 26.08.2010 - klo:10:16 »
hmmm  koitan päätteessä tätä "sudo /usr/sbin/install_bcm43xx_firmware"

kerron jos toimii
Kone pitää käynnistää uusiksi tuo jälkeen niin sitten pitäisi toimia.

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #4 : 26.08.2010 - klo:10:22 »
hmmm  koitan päätteessä tätä "sudo /usr/sbin/install_bcm43xx_firmware"

kerron jos toimii
Kone pitää käynnistää uusiksi tuo jälkeen niin sitten pitäisi toimia.

Jep :-)

Salausavaimen syöttämisessä oli pikku ongelma mutta tolla komennolla wlan lähti toimimaan mutta....   Nopeus vain 1 Mbit/s,  miksi näin???

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2724
  • Sukupuoli: Mies
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #5 : 26.08.2010 - klo:10:27 »
onko sulla sen ifup vai käyttäjän hallinnoima verkkotyökalu käytössä?

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #6 : 26.08.2010 - klo:10:28 »
Käyttäjän hallinnoima muistaakseni


ja eipä tuo langaton taas toimi ollenkaan :-(

Pitäiskö laittaa ifup?  ja jos niin mistä?

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2724
  • Sukupuoli: Mies
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #7 : 26.08.2010 - klo:10:40 »
Käyttäjän hallinnoima muistaakseni


ja eipä tuo langaton taas toimi ollenkaan :-(

Pitäiskö laittaa ifup?  ja jos niin mistä?

Ei kun tarkoitus on käyttää tuota käyttäjän hallinnoimaa. Tossa aikasemmas viestissähän laitoin sen mistä löytyy :)

Kun yrität kytkeytyä langattomaan verkkoon monitoroi samalla komentoriviltä alla olevalla komennolla ja laita tänne

Koodia: [Valitse]
sudo tail -f /var/log/messages

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #8 : 26.08.2010 - klo:10:47 »
Aug 26 10:45:54 linux-r2aq kernel: [ 1960.020153] b43-phy0: Radio hardware status changed to DISABLED
Aug 26 10:45:59 linux-r2aq kernel: [ 1965.020152] b43-phy0: Radio hardware status changed to ENABLED
Aug 26 10:45:59 linux-r2aq kernel: [ 1965.272135] b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)           
Aug 26 10:46:04 linux-r2aq kernel: [ 1970.804803] ADDRCONF(NETDEV_UP): wlan0: link is not ready                               


guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #9 : 26.08.2010 - klo:10:48 »
Noin se ilmoittaa. ja kun annan wep salasanan niin ei tapahdu mitään :-(    Ihan kuin mulla ei olisi oikeuksia käyttää tuota.

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #10 : 26.08.2010 - klo:11:43 »
Mulla on tämä suse dualboottina tässä koneessa ubuntun kanssa.  Miten saan ubuntun käyntiin?

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #11 : 26.08.2010 - klo:11:52 »
Kirjauduin nyt roottina sisään ja langaton toimii erittäin hyvin!

Bit rate on 54 mbit/s ja signaalivahvuus 100%

eli miten saadaan toimimaan käyttäjä puolella kanssa??????

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #12 : 26.08.2010 - klo:11:53 »
Vai voinko käyttää roottina aina?  tietoturvariskejä?

guest1136

  • Vieras
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #13 : 26.08.2010 - klo:12:27 »
No niin nyt ei tämäkään toimi enää :-(

Joo muuta en olisi toivonut kun että tuo langaton toimeisi kunnolla ja asentamalla joku suljettu ajuri niin olisi käytössä. mutta kun ei niin ei.  pari kertaa aiemminkin kokeillut susea ja homma kaatui silloinkin tähän samaiseen ongelmaan.

Kippaan tän mäkeen ja laitan ubuntun takaisin, siinä ainakin toimii.

tää menee perus käyttäjälle liian hankalaksi tämmönen säätäminen.

jaksa pelleillä näillä jutuilla.

Anteeksi karkea käytös ja "pienehkö" kiihtyminen tässä asiassa.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2724
  • Sukupuoli: Mies
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #14 : 26.08.2010 - klo:12:35 »
Melko kärsivällistä. Ilmoitit ongelmasta ~3h sitten ja nyt asennat jo käyttistä uusiksi.
 ;D  ;D  ;D

Kuinkakohan moni kerkesi edes lukea tätä ennen kuin luovutit...

Poissa letkume

  • Jäsen
  • Viestejä: 521
Vs: opensuse 11.3 ja wlan ongelma
« Vastaus #15 : 30.08.2010 - klo:16:11 »
Melko kärsivällistä. Ilmoitit ongelmasta ~3h sitten ja nyt asennat jo käyttistä uusiksi.
 ;D  ;D  ;D

Kuinkakohan moni kerkesi edes lukea tätä ennen kuin luovutit...

ks. nimimerkki "fastest"  ;D