Kirjoittaja Aihe: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?  (Luettu 5855 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

MiB

  • Vieras
Kaipa tämä tälle keskustelualueelle parhaiten sopii, sillä tekstissäni tuskin on päätä tai häntää...

Ostaessani Probook 4710s -kannettavan mukana tuli Suse Linux Enterprise Desktop 11. Ja voi tätä ongelmien määrää, kun aikasemmin kokemusta on oikeastaan vain Windows Xp:stä!

Suurin hiusten repimisen syy on ollut etenkin ohjelmien asennus. Avast, VLC, MPlayer, Winamp.... Mikään ei yksinkertaisesti suostu asennettavaksi, sillä aina puuttuu jotain (esim. avastin suhteen libexpat.so.0) ja vaikuttaa että jokainen uusi osa taas vaatii kymmenen muuta osaa toimiakseen. Olen onnistunut ainostaan skypen ja vuzen (jotenkin) asentamaan koneelleni.

Olen sellannut läpi openSusen ja Novellin sivuja. Opensuselle löytyykim paljon ohjeita asennusten suhteen, mutta SLEDistäni en sitten löydäkään usein mainittua "yhteisöasennuslähdettä".

VLC:tä yritin aluksi tallentaa 1-click-installsin kautta -> Yast: Avattu asennuslinkki tai -tiedosto ei sisällä ohjeita tätä openSUSEn versiota varten.

Seuraavaksi seurasin ohjetta: "Add VideoLAN's repository

First, add a new repository (installation source) in YaST (YaST2 -> Software -> Installation Sources)

Add the following Repository:

Type: HTTP / Servername: download.videolan.org /
Directory: /pub/videolan/vlc/SuSE/<SUSE Version>

Replace <SUSE Version> in the Directory above with your installed SuSE Version. Supported at this time are :

10.3
11.0
11.1 "

jonka sain tallennettua ainostaan versiona 10.3, mikä sekään ei loppujen lopuksi toiminut puuttuvan osan takia. Eli harvinainen voitonriemu muuttui jälleen suruksi.

Ainoat asennuslähteeni ovat:
Broadcom, SLE11-Debuginfo-Pool, SLE11-Debuginfo-Updates, SLED11-Extras, SLED11-Pool, SLED11-Updates. Eli tässäkö menee asiat pieleen?

Kuten selväkis on tullut, en todellakaan ole tekniikan ihmelapsi. Mutta ei minulla ole aikaisemmin ollut näin ylitsepääsemäätömiä ongelmia. Jos vinkkejä ohjelmien asentamiseen löytyy, ne kannattaa minulle VÄÄNTÄÄ RAUTALANGASTA.

Kiusaus Windows 7 ostamiseen kasvaa joka päivä, kun en edes pysty .avi-tiedostoja katsomaan... Hjälp.  :'(

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #1 : 04.11.2009 - klo:18:32 »
Olen sellannut läpi openSusen ja Novellin sivuja. Opensuselle löytyykim paljon ohjeita asennusten suhteen, mutta SLEDistäni en sitten löydäkään usein mainittua "yhteisöasennuslähdettä".

SLEDille noita asennuslähteitä ei välttämättä ole.
openSUSE 11.1 pakettien pitäisi upota tuohon SLEDiin, SLED kun pohjautuu siihen.

Lainaus
Ainoat asennuslähteeni ovat:
Broadcom, SLE11-Debuginfo-Pool, SLE11-Debuginfo-Updates, SLED11-Extras, SLED11-Pool, SLED11-Updates. Eli tässäkö menee asiat pieleen?

Kuten selväkis on tullut, en todellakaan ole tekniikan ihmelapsi. Mutta ei minulla ole aikaisemmin ollut näin ylitsepääsemäätömiä ongelmia. Jos vinkkejä ohjelmien asentamiseen löytyy, ne kannattaa minulle VÄÄNTÄÄ RAUTALANGASTA.

Kiusaus Windows 7 ostamiseen kasvaa joka päivä, kun en edes pysty .avi-tiedostoja katsomaan... Hjälp.  :'(

Kokeile ensin niitä openSUSE 11.1 asennuslähteitä. Ja asennuslähteillä tarkoitan sitten seuraavia:

VLC:
http://download.videolan.org/pub/videolan/vlc/SuSE/11.1/

esim. komennolla

Koodia: [Valitse]
su -c 'zypper ar http://download.videolan.org/pub/videolan/vlc/SuSE/11.1/ VLC'
Packman:
http://ftp.skynet.be/pub/packman/suse/11.1/

komennolla

Koodia: [Valitse]
su -c 'zypper ar http://ftp.skynet.be/pub/packman/suse/11.1/ Packman'
Tietysti yksi vaihtoehto olisi asentaa openSUSE tuon SLEDin tilalle.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

MiB

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #2 : 05.11.2009 - klo:16:30 »
Kiitos äärettömän paljon neuvoista! Ne todellakin auttoivat ja sain paljon uusia ohjelmistoja käyttööni Yastin kautta!  :D

Nyt minulle on kuitenkin ilmennyt ikävä kyllä uusia ongelmia...  :-[

Asensin onnistuneesti VLC:n, mutta huomasin että ääni pätkii pahasti katsosessani ainakin itse nauhoittamiani .avi-tiedostoja sekä myös DVD-levyjä. Asensin täten sitten myös Xinen, joka toimiikin DVD-levyn kanssa, mutta myös siinä .avi pätkii ärsyttävästi.

Muita ääniongelmia olen kokenut myös Skypen kanssa, sillä aukaistuani ohjelman en enää pääse PulseAudion Volume Cotrolliin, vaan tämä vain nopeasti välähtää kuvaruudulla aukematta. Pääsen ainoastaan esim. säätämään mikin voimakkuutta käynnistämällä koneen uudelleen. Mutta ilmeisesti PulseAudiolla ja Skypellä on yleisesti joitain ongelmia muutenkin. Itse koen kyseisen ohjelman jotenkin vaikeana Windowsin jälkeen, äänenvoimakkuutta kun pystyy säätelemään PulseAudiossa ties mistäkin sen eri ohjelmasta.

Löysin packmanin kautta myös Vuzen, joten poistin aikaisemmin (Vuzen sivuilta) lataamani ohjelman ja latasin sen uudelleen packmanista kautta. Nyt Vuze ei sitten kuitenkaan enää aukea, vaan välähtää nopeasti kuvaruudulla käynnistymättä. Packamnin paketeista sain ladattua kaikki muut paitsi ”Vuze-console To run Vuze from console command line”, koska minulta ei löydy sen vaatimaa log4j:tä enkä sitä mistään edes löytänyt. En sitten tiedä vaatisiko Vuze uusimman Javan, jota en millään saa konelleni asennettua (esim. jre-6u17-linux-i586-rpm.bin). Löysin tosin myös temp-kansiostani Vuze.log:in, jossa lukee /usr/lib/jvm/jre/bin/java: symbol lookup error: /usr/lib/Azureus/libswt-xulrunner-gtk-3555.so: undefined symbol: XPCOMGlueStartup . Yhtä suurta kysymysmerkkiä minulle koko asia ja taitaa olla muillekin epäselvän selitykseni jälkeen...

Kyse luultavasti hyvin yksinkertaisista asioista, mutta en näihin nettiä selaamalla saanut tälläkään kertaa vastausta. Jos täältä jotain apua toistamiseenkin saisin?  ???

MiB

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #3 : 05.11.2009 - klo:17:12 »
Joo-o, VLC: ongelmat selvis... Jos pikkasen sitä omaa järkeä käyttäis aina välillä  ;D

Mutta muut ongelmat on vielä jäljellä...

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2773
  • Sukupuoli: Mies
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #4 : 05.11.2009 - klo:17:27 »
Kiitos äärettömän paljon neuvoista! Ne todellakin auttoivat ja sain paljon uusia ohjelmistoja käyttööni Yastin kautta!  :D


Löysin packmanin kautta myös Vuzen, joten poistin aikaisemmin (Vuzen sivuilta) lataamani ohjelman ja latasin sen uudelleen packmanista kautta. Nyt Vuze ei sitten kuitenkaan enää aukea, vaan välähtää nopeasti kuvaruudulla käynnistymättä. Packamnin paketeista sain ladattua kaikki muut paitsi ”Vuze-console To run Vuze from console command line”, koska minulta ei löydy sen vaatimaa log4j:tä enkä sitä mistään edes löytänyt. En sitten tiedä vaatisiko Vuze uusimman Javan, jota en millään saa konelleni asennettua (esim. jre-6u17-linux-i586-rpm.bin). Löysin tosin myös temp-kansiostani Vuze.log:in, jossa lukee /usr/lib/jvm/jre/bin/java: symbol lookup error: /usr/lib/Azureus/libswt-xulrunner-gtk-3555.so: undefined symbol: XPCOMGlueStartup . Yhtä suurta kysymysmerkkiä minulle koko asia ja taitaa olla muillekin epäselvän selitykseni jälkeen...



Ei pitäisi tarvita uusinta javaa. Jos kokeilet avata sitä vuzee komentoriviltä niin saatko sinne jotain herjaa?

Noita pakettaja ei kannata ihan hirveesti asennelle paketinhallinnan ohi jos ei ole varma mitä tekee, koska tällöin järjestelmä ei pysty pitämään huolta riippuvuuksista. Muutenkin jonkin ajan kuluttua huomaat koneesi olevan sellainen sillisalaatti, että mikään ei toimi tappelematta.

Vaikuttaa siltä, että sinun käyttötarkoitukseen tuo openSUSE voisi olla parempi ratkaisu. Tuo SLED 11 on enemmän tarkoitettu yrityskäyttöön jossa ei välttämättä tarvita kaikkea multimedia härpäkettä, torrentteja jne...

guest405

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #5 : 05.11.2009 - klo:17:49 »

Vaikuttaa siltä, että sinun käyttötarkoitukseen tuo openSUSE voisi olla parempi ratkaisu. Tuo SLED 11 on enemmän tarkoitettu yrityskäyttöön jossa ei välttämättä tarvita kaikkea multimedia härpäkettä, torrentteja jne...

Olen samaa mieltä. SLED 10 tai 11 todella sopii paremmin yrityskäyttöön. On aika keinotekoinen (vaarallinen) ratkaisu alkaa liittää SLED 11:sta yast:n pakettihallintaan OpenSuse 11.1:n ohjelma- kanavia. Omat kokemukseni ovat että menee aivan varmasti rikki jossain vaiheessa. Viimeistään siinä vaiheessa on ongelmia, kun OpenSuse 11.1 on end off live tilassa. Mistäs sitten asennellaan ja päivitellään ohjelmia.

Yksi mahdollinen ratkaisu on käyttää http://software.opensuse.org/search sivuilta löytyviä ohjelmia. Täältä löytyy paljon OpenSuse ohjelmia, joista on käännetty myös usein SLED versio. Nämä eivät ole mitään virallisia paketteja, mutta toimivat. Siis mieluummin näin. Ei niin että käyttää OpenSuse 11.1 versiota suoraan SLED:ssä.

Toinen ratkaisu on täräyttä SLED 11 päälle tuo OpenSuse 11.2 kun se viikon päästä julkaistaan. Takuuta ei voi antaa, että toimii mutta itselläni aikoinaan toimi OK, kun hetin SLED 10:n päälle OpenSuse 11:sta.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #6 : 05.11.2009 - klo:18:00 »
11:sta yast:n pakettihallintaan OpenSuse 11.1:n ohjelma- kanavia. Omat kokemukseni ovat että menee aivan varmasti rikki jossain vaiheessa. Viimeistään siinä vaiheessa on ongelmia, kun OpenSuse 11.1 on end off live tilassa. Mistäs sitten asennellaan ja päivitellään ohjelmia.

Näin se menee.

Lainaus
Yksi mahdollinen ratkaisu on käyttää http://software.opensuse.org/search sivuilta löytyviä ohjelmia. Täältä löytyy paljon OpenSuse ohjelmia, joista on käännetty myös usein SLED versio. Nämä eivät ole mitään virallisia paketteja, mutta toimivat. Siis mieluummin näin. Ei niin että käyttää OpenSuse 11.1 versiota suoraan SLED:ssä.

Jos paketit on tehty BuildServicessä niin niihin suhteellisen hyvällä todennäköisyydellä löytää SLE-version, mutta esim. packman/videolan eivät SLE-sarjalle paketteja tee.

Lainaus
Toinen ratkaisu on täräyttä SLED 11 päälle tuo OpenSuse 11.2 kun se viikon päästä julkaistaan. Takuuta ei voi antaa, että toimii mutta itselläni aikoinaan toimi OK, kun hetin SLED 10:n päälle OpenSuse 11:sta.

No itselläni tämä 11.2 tai oikeammin Factory on pyörinyt ilman suurempia ongelmia.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

MiB

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #7 : 05.11.2009 - klo:18:59 »
Pitänee vaihtaa siihen openSUSEen sitten tuossa viikon kuluttua, jos vaikka omakin elämä siinä helpottuisi samalla eikä kone tilttaisi. Vähän pelottaa asennuksen onnistuminen...

Siitä Vuzesta vielä kuitenkin sen verran että seuraavaa tekstiä tuli sitten komentoriviltä:

using MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.1.4 and MOZ_PLUGIN_PATH=/usr/lib/browser-plugins
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus4.jar:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus -Dazureus.install.path=/var/lib/Azureus -Dazureus.script.version=2 -Dazureus.script=/usr/bin/vuze
arguments used:
file:/usr/share/java/Azureus/Azureus4.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/home/minna/
UIFunctions/ImageLoad took 25ms
new shell took 177ms
new shell setup took 75ms
skinlisteners init took 25ms
skin init took 276ms
MainMenu init took 200ms
createWindow init took 0ms
skin layout took 28ms
pre skin widgets init took 25ms
hooks init took 0ms
WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@7976c1
skin widgets (1/2) init took 276ms
skin widgets init took 179ms
pre SWTInstance init took 0ms
Init Core Columns took 75ms
SWTInstance init took 0ms
shell.layout took 150ms
---------SHOWN AT 1257440046038;1664ms

Sanooko mitään?

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2773
  • Sukupuoli: Mies
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #8 : 05.11.2009 - klo:19:09 »
Pitänee vaihtaa siihen openSUSEen sitten tuossa viikon kuluttua, jos vaikka omakin elämä siinä helpottuisi samalla eikä kone tilttaisi. Vähän pelottaa asennuksen onnistuminen...
Eiköhän se helpotu. Ei se asennus mitään rakettitiedettä ole. Täältä löytyy ohjeet jotka voi avuttaa eteenpäin.
http://opensuse.fi/Asennusopas_openSUSE_11.2


Siitä Vuzesta vielä kuitenkin sen verran että seuraavaa tekstiä tuli sitten komentoriviltä:

using MOZILLA_FIVE_HOME=/usr/lib/xulrunner-1.9.1.4 and MOZ_PLUGIN_PATH=/usr/lib/browser-plugins
java virtual machine used: /usr/lib/jvm/jre/bin/java
classpath used: /usr/share/java/Azureus/Azureus4.jar:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar:/usr/share/java/Azureus/swt.jar
main class used: org.gudy.azureus2.ui.swt.Main
flags used:
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus -Dazureus.install.path=/var/lib/Azureus -Dazureus.script.version=2 -Dazureus.script=/usr/bin/vuze
arguments used:
file:/usr/share/java/Azureus/Azureus4.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/usr/share/java/Azureus/swt-3.5.1-I20080702-0939.jar ; file:/home/minna/
UIFunctions/ImageLoad took 25ms
new shell took 177ms
new shell setup took 75ms
skinlisteners init took 25ms
skin init took 276ms
MainMenu init took 200ms
createWindow init took 0ms
skin layout took 28ms
pre skin widgets init took 25ms
hooks init took 0ms
WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@7976c1
skin widgets (1/2) init took 276ms
skin widgets init took 179ms
pre SWTInstance init took 0ms
Init Core Columns took 75ms
SWTInstance init took 0ms
shell.layout took 150ms
---------SHOWN AT 1257440046038;1664ms

Sanooko mitään?

Eipä tosta ainakaan minulle irtoa mitään.

guest141

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #9 : 16.11.2009 - klo:22:40 »
Lainaus
Sanooko mitään?
Onko mikä java(versio) asennettuna, ja miten on java pluginien laita?

MiB

  • Vieras
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #10 : 19.11.2009 - klo:00:38 »
Hmmm, nyt Java on pienin ongelmistani... "Yllättäen" openSUSE 11.2 asennus meni täysin metsään enkä saa enää koko Linuxia auki.

Poissa harmie

  • Valvoja
  • *
  • Viestejä: 2773
  • Sukupuoli: Mies
Vs: Linuxin ensikäyttäjä ja SLED 11 = mahdoton yhdistelmä?
« Vastaus #11 : 19.11.2009 - klo:09:57 »
Hmmm, nyt Java on pienin ongelmistani... "Yllättäen" openSUSE 11.2 asennus meni täysin metsään enkä saa enää koko Linuxia auki.
Kerro toki hieman tarkemmin mihin kohtaan homma hyytyy?

Saitko tehtyä kuitenkin asennuksen loppuun ja käynnistyksen jälkeen ei toimi?