Kirjoittaja Aihe: Huawei ongelma  (Luettu 12374 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Huawei ongelma
« : 26.06.2008 - klo:20:11 »
Piti tuo mokkula laittaa tutun koneeseen, mutta eipä anna mitään merkkiä. Eikös tuossa joku piirisarja ole että lsusb komennolla näkis.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmureke

  • Jäsen
  • Viestejä: 66
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #1 : 26.06.2008 - klo:21:32 »
Jaa oliko kyseessä Saunalahden "Nettisuppo" eli Huawei E169?

Minulla se pelaa OpenSuse 11.0:n kanssa siten, että kone bootataan tikku kiinnitettynä, jonka jälkeen nettiin pääsee valitsemalla NetworkManagerista kytkentä GSM-verkkoon. Asetuksista kuitenkin kannattanee valita oikea APN-nimi oman operaattorisi myöntämien ohjeiden mukaisesti. PIN-koodin kysely sujunee myös, ellei ole sitä etukäteen puhelimessa tai Windows-ohjelmalla (pthyi!) poistanut käytöstä.

Tällä konstilla ei tartte Vodafone-ajureita eikä /dev/ttyUSB-laitteen tunkkaamista.

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #2 : 27.06.2008 - klo:08:05 »
Jaa oliko kyseessä Saunalahden "Nettisuppo" eli Huawei E169?

Minulla se pelaa OpenSuse 11.0:n kanssa siten, että kone bootataan tikku kiinnitettynä, jonka jälkeen nettiin pääsee valitsemalla NetworkManagerista kytkentä GSM-verkkoon. Asetuksista kuitenkin kannattanee valita oikea APN-nimi oman operaattorisi myöntämien ohjeiden mukaisesti. PIN-koodin kysely sujunee myös, ellei ole sitä etukäteen puhelimessa tai Windows-ohjelmalla (pthyi!) poistanut käytöstä.

Tällä konstilla ei tartte Vodafone-ajureita eikä /dev/ttyUSB-laitteen tunkkaamista.

DNA mokkula ja Huawei E 220. Boottasin tikku kiinni, mutta NetworkManager ei näytä muuta kuin tuon langallisen yhteyden. Mokkulassa kyllä vihreä valo vilkkuu. Ei ymmärrä.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmureke

  • Jäsen
  • Viestejä: 66
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #3 : 27.06.2008 - klo:08:53 »
Hmm.

Muistaakseni tuon E169:n tunnistus johtaa 'option'-merkkisen kernel-modulin lataukseen. Tuo E220 aiheuttanee hieman enemmän askartelua, mennee Vodafone-ajureiksi.

Tässä linkissä lupaillaan peräti ratkaisua E220:lle:

http://forum.ubuntu-fi.org/index.php?topic=10480.120


Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #4 : 27.06.2008 - klo:10:52 »
Linkkejä on kahlaitu ja jotain selkoa tullut. /dev/ttyUSB0 löytyy. /etc hakamistoon tein conffin:

[Dialer defaults]
Modem = /dev/ttyUSB0
Init = AT+CGDCONT=1,"IP","internet"
Phone = *99***1#
Stupid Mode = 1
Username = "guest"
Password = "guest"

Tuon jälkeen komento, wvdial antaa herjan:

--> WvDial: Internet dialer version 1.56 (abuild@delius)
--> Cannot open /dev/ttyUSB0: Device or resource busy

Mahtaisiko olla kyse olla niinkin yksinkertaisesta asiasta ettei yhteyttä ole vielä kytketty DNA puolelta. Merkkivalon vilkkuminen antais vihjeitä siihen suuntaan.

Mihinkäs tuo sitten laitetaan, APN:internet.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa Owdy

  • Huoltomies
  • Jäsen
  • Viestejä: 3260
Vs: Huawei ongelma
« Vastaus #5 : 27.06.2008 - klo:17:30 »
Mulla on Sauniksen Huawei E220 ja se alko toimimaan Newrkmanagerin kanssa melkein heittämällä. Tätäkin kirjotan mokkulan kautta. Mul on Datapaketti 384. Mitä tohon tiedonsiirtonopeuskohtaan pitäs laittaa?

Poissa jmureke

  • Jäsen
  • Viestejä: 66
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #6 : 27.06.2008 - klo:18:12 »
Eikös tuo ole ns. päätelaitevauhti? Ollen kyse USB-laitteesta, nopeusasetuksella ei välttämättä ole merkitystä. Laita siihen korkein nopeus, jolla se toimii tai sitten tuo 115200.

Mulla Huawei E169 kirjautuu parhaimmillaan HSDPA-verkkoon 7.2 megabitin kantoaaltovauhdilla, mutta sopimukseni rajoittaa varsinaisen internet-yhteyden nopeuden 384 kbit/s:n.

Poissa Owdy

  • Huoltomies
  • Jäsen
  • Viestejä: 3260
Vs: Huawei ongelma
« Vastaus #7 : 27.06.2008 - klo:18:41 »
Arijoutsi, muuta Yastin verkkoasetuksista että käytetään "käyttäjän hallionnoima verkkotyökalun avulla". Sitten ethernet piuha irti, mokkula kiinni ja buuttaus. Pitäs lähtee toimimaan ilman loitsuja tai tiedostojen hakkerointeja. Ainakin mulla toimii :)

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #8 : 27.06.2008 - klo:19:49 »
Arijoutsi, muuta Yastin verkkoasetuksista että käytetään "käyttäjän hallionnoima verkkotyökalun avulla". Sitten ethernet piuha irti, mokkula kiinni ja buuttaus. Pitäs lähtee toimimaan ilman loitsuja tai tiedostojen hakkerointeja. Ainakin mulla toimii :)

Näin mulla oli koko ajan.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmureke

  • Jäsen
  • Viestejä: 66
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #9 : 27.06.2008 - klo:21:22 »
Näissä USB-HSDPA-rasioissa (ja esim. Buffalo/Melco USB-WLAN-tikuissa) on nähtävästi ominaisuus, joka helpottaa erityisesti Windows (pthyi!) -käyttöä. Nimittäin, ne ovat kytkettäessä "lennossa" ikäänkuin "asennustilassa", eli ne näkyvät CD-asemana sisältäen Windows (pthyi!)-client-ohjelman ja ajurit. Näiden automaattiasennuksen jälkeen tikku - kaiketi ajureiden ohjaamana - kippaa "modeemitilaan" ja jo on internetin runsaudensarvi ammennettavissa.

Owdy: tiedätkö kertoa, miten saisi linuxissa "käsin" KDE:stä (tai mustalta ruudulta manaamalla) kipattua tikun "modeemitilaan", ettei tarvitsisi aina bootata tikku kiinni?

Poissa Owdy

  • Huoltomies
  • Jäsen
  • Viestejä: 3260
Vs: Huawei ongelma
« Vastaus #10 : 27.06.2008 - klo:21:30 »
Owdy: tiedätkö kertoa, miten saisi linuxissa "käsin" KDE:stä (tai mustalta ruudulta manaamalla) kipattua tikun "modeemitilaan", ettei tarvitsisi aina bootata tikku kiinni?
Tolla networkmanager apletillä pitäs onnistua, mutta en o saanu sitä pelittämään. Jos vaihtaa sillä lennossa, se voi väittää että yhteys on päällä mutta mihinkään ei me. Buuttamaalla se on aina onnistunut.

fsu

  • Vieras
Vs: Huawei ongelma
« Vastaus #11 : 27.06.2008 - klo:21:47 »
Näissä USB-HSDPA-rasioissa (ja esim. Buffalo/Melco USB-WLAN-tikuissa) on nähtävästi ominaisuus, joka helpottaa erityisesti Windows (pthyi!) -käyttöä. Nimittäin, ne ovat kytkettäessä "lennossa" ikäänkuin "asennustilassa", eli ne näkyvät CD-asemana sisältäen Windows (pthyi!)-client-ohjelman ja ajurit. Näiden automaattiasennuksen jälkeen tikku - kaiketi ajureiden ohjaamana - kippaa "modeemitilaan" ja jo on internetin runsaudensarvi ammennettavissa.

Owdy: tiedätkö kertoa, miten saisi linuxissa "käsin" KDE:stä (tai mustalta ruudulta manaamalla) kipattua tikun "modeemitilaan", ettei tarvitsisi aina bootata tikku kiinni?

Empä oo owdy, enkä oo edes varma oikeasta vastauksesta, mutta kokeile usb_modeswitchiä
(openSUSE 11.0 -repo)

Poissa jmureke

  • Jäsen
  • Viestejä: 66
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #12 : 27.06.2008 - klo:22:12 »
Cappas, tuo usb_modeswitch - jos mikä - hoitanee homman.

Kiitti vinkistä, pitää tyypätä.

vms100

  • Vieras
Vs: Huawei ongelma
« Vastaus #13 : 29.06.2008 - klo:18:29 »
ajakaa winellä  ;D

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Huawei ongelma
« Vastaus #14 : 02.07.2008 - klo:18:25 »
Kinkkinen homma selvisi. Asensin Ubuntun ja siihen Vodafonen ajurit. Mutkien kautta sain mokkulan toimiin. Wvdial antoi erroria. Sitten otin kaiken alusta lähtien uudelleen. Tämän sivun mukaan tein:

http://linux.fi/index.php/Huawei_E220/E270

Ongelma oli siinä kun poistin pin koodi kyselyn toisessa puhelimessa, niin jotain tein väärin ja koodin kysely oli voimassa. Tein uudestaan homman ja nyt ei pin koodin kysely ollut päällä. Sen jälkeen tein tuolta sivulta löytyvän ohjeen mukaan tiedoston että mokkula on valmiina nettiin työpöydälle päästyä. Konsoliin vain komento wvdial ja yhteys toimi. Sitten poistin vodafonen ajurin joka on kyllä susi vaikka jotenkin sillä toimiin sai, mutta kesti kauan ennekuin yhteys oli päällä. Wvdialilla se oli heti. Valitettavasti openSUSE 10.3 en tuota saanut noilla ohjeilla toimimaan. Mokkulan sininen valo kyllä vilkkui heti kun biosista siirryttiin linuxiin, mutta wvdial antoi edelleen ilmoituksen:

--> WvDial: Internet dialer version 1.56 (abuild@delius)
--> Cannot open /dev/ttyUSB0: Device or resource busy
--> Cannot open /dev/ttyUSB0: Device or resource busy
--> Cannot open /dev/ttyUSB0: Device or resource busy

Mokkula on DNA:n yhteydellä. Pääasia ettei tarvinnut suxpeetä asentaa 8)
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

guest17

  • Vieras
Vs: Huawei ongelma
« Vastaus #15 : 08.07.2008 - klo:15:18 »
Moro,

10.3:lla kokeilin tuota huaweitä ja sain tällä toimimaan aikoinaan:
http://oozie.fm.interia.pl/src/huawei.tar.bz2
Eli paketin purku ja komennat hakemistossa make install_suse.
Tämän jälkeen käynnistys, tai udev-sääntöjen "päivitys", jonka jälkeen Soneran asetukset wvdial-tiedostoon.

//Olli