Kirjoittaja Aihe: Ei pysty asentamaan ohjelmia.(Ratkaistu)  (Luettu 9017 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

E.K.Virtanen

  • Vieras
Ei pysty asentamaan ohjelmia.(Ratkaistu)
« : 19.01.2008 - klo:22:15 »
Moiks.

Uusi naama täällä joten tyhmiä kysymyksiä alkaa pukkaamaan  ;D
Koetan asentaa ohjelmia Tietokone --> Asenna Ohjelmistoja ja salasanan syötettyäni ei tapahdukaan mitään. Kokeilin syöttää salasanan väärin ja siitä valitti joten ainakin se lukee vielä salasananmutta sitten homma kaatuu.

Ideoita?

E.K.Virtanen
« Viimeksi muokattu: 20.01.2008 - klo:19:20 kirjoittanut E.K.Virtanen »

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #1 : 19.01.2008 - klo:22:27 »
Koetan asentaa ohjelmia Tietokone --> Asenna Ohjelmistoja ja salasanan syötettyäni ei tapahdukaan mitään. Kokeilin syöttää salasanan väärin ja siitä valitti joten ainakin se lukee vielä salasananmutta sitten homma kaatuu.

Eli kyseessä on siis ilmeisesti openSUSE gnomella?

Varmista että asennuslähteet on kunnossa ja asenna ohjelmat joko YaST2 tai zypperillä.

Komento
yast2 sw_single &
avaa suoraan ohjelmien asennusmoduulin.

Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #2 : 19.01.2008 - klo:22:30 »
Moi jmp ja kiitos nopeasta vastauksesta.
Mainitsemasi komento tuotti seuraavaa yast2: command not found

[edit]
Tosiaan gnome on käytössä.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #3 : 19.01.2008 - klo:22:33 »
Moi jmp ja kiitos nopeasta vastauksesta.
Mainitsemasi komento tuotti seuraavaa yast2: command not found

root-käyttäjänä esim. näin

su -c 'yast2 sw_single &'
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #4 : 19.01.2008 - klo:22:35 »
Moi.

Komennon jälkeen pyytää salasanaa normaalisti mutta siihen se jää  ???

Koodia: [Valitse]
ekvirtanen@dhcppc2:~> su -c 'yast2 sw_single &'
Salasana:
ekvirtanen@dhcppc2:~>

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #5 : 19.01.2008 - klo:22:43 »
Asensitko gnome 1CD versiosta?

Onko asennuslähteet määritetty?
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #6 : 19.01.2008 - klo:22:51 »
Latasin iso imagen 64bit gnomesta standardi metoodilla ja levy läpäisi viheettömyys tarkistuksen (asennus ohjelma tarkisti).
Nyt en pääse asennuslähteitäkään säätämään ellei sitten ole keinoa tehdä se konsolin kautta.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #7 : 19.01.2008 - klo:22:57 »
No lisätään pari. Noi komennot annat konsolissa

su

zypper sa -n http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/oss OSS

zypper sa -n http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/non-oss NON-OSS
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #8 : 19.01.2008 - klo:23:06 »
Moikka. Sain ne lisättyä mutta ei vaan lähde käyntiin  :-\

Koodia: [Valitse]
zypper sa -n http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/oss OSS
* Lisätään asennuslähdettä 'OSS'
Asennuslähde 'OSS' lisättiin onnistuneesti:
Käytössä: Kyllä
Automaattinen päivitys: Ei
URL: http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/oss
dhcppc2:/home/ekvirtanen # zypper sa -n http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/non-oss NON-OSS
* Lisätään asennuslähdettä 'NON-OSS'
Asennuslähde 'NON-OSS' lisättiin onnistuneesti:
Käytössä: Kyllä
Automaattinen päivitys: Ei
URL: http://ftp5.gwdg.de/pub/opensuse/distribution/10.3/repo/non-oss
dhcppc2:/home/ekvirtanen #

Konsolin puolelta yast2 lähti käyntiin kylläkin mutta varoitti
Lainaus
Tapahtui virhe valmisteltaessa asennuslähteitä.
'NON-OSS': /var/cache/zypp/raw/NON-OSS: Tarvittava tiedosto puuttuu: ./content


Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #9 : 19.01.2008 - klo:23:31 »
Niin joo, lisää vielä update asennuslähde

su
zypper sa http://ftp5.gwdg.de/pub/opensuse/update/10.3/ UPDATE

kun tuo otettu käyttöön niin komenna(edelleen root-käyttäjänä)

zypper ref

ja sitten vain odottelet, kun tuo on valmis, niin komenna

zypper up

ja päivität järjestelmäsi.

Nyt meikä lähtee baariin.
Illan jatkoja
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #10 : 19.01.2008 - klo:23:56 »
Baareilehan hyvin  ;)

Tein kuten neuvoit. Nyt kone ilmoittaa yhdestä päivityksestä jonka sitten asennan, sen jälkeen koetan avata yastia jolloin kone ilmoittaa että olisi taas yksi päivitys ja yast kaatuu.
Tämä yksi ja sama päivitys josta kone kertoo on: /usr/sbin/updater-zypper-gui ZOPTIONS_RESTART_FALSE ZOPTIONS_RECOMMENDED_FALSE ZOPTIONS_PACKAGES_FALSE 1 0 0 yast2-online-update


Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #11 : 20.01.2008 - klo:02:01 »
Tuo

zypper up

päivittää järjestelmäsi. Et tarvitse siihen graafista mokkulaa.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #12 : 20.01.2008 - klo:13:22 »
Poista tuo aiemmin  määritetty NON-OSS komentamalla

su

zypper rr NON-OSS

ja lisää uusi komentamalla

zypper sa -n http://download.opensuse.org/distribution/10.3/repo/non-oss/ NON-OSS

päivitä lähteet

zypper ref

Voit aina vaihtaa tuon YaST2 gtk liittymän qt:hen, joka on omasta mielestäni selvempi (tämä on tietysti mielepide juttu)

Avaa /etc/sysconfig/yast2 tiedosto root -käyttäjänä.
Vaihda WANTED_GUI="auto" muotoon WANTED_GUI="qt", tallenna ja poistu tiedostosta.
Jos haluat takaisin tuon gtk-version (riippumatta käyttöympäristöstä) muuta WANTED_GUI muotoon WANTED_GUI="gtk".
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #13 : 20.01.2008 - klo:15:10 »
Terve taas.

Oli tuossa aiemmassa asennuksessa aika paljon muitakin ongelmia ja lisäksi osiointi oli kusenut jotenkin pahasti.
Latasin levykuvan uudelleen koska vaikka tarkistu väitti vanhan olleen ok, niin en oikein uskonut sitä. Tämän jälkeen pistin koko asennuksen uusiksi ja samalla sain osiot kuntoon kerralla.

Nyt ensimmäisen käynnistyksen jälkeen yast2 toimi kuten pitää ja asensinkin muutaman ohjelman koneelle. Sitten sammutin koneen jä kävin töissä. Nyt kun käynnistin koneen uudelleen niin yast2 ei lähde millään käyntiin.

Kokeilen nyt noita antamiasi neuvoja ja raportoin lisää  ;)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #14 : 20.01.2008 - klo:15:26 »
Terve taas.

Antamillasi ohjeilla pystyn käynnistämään yastin terminaalista ja asentamaan ohjelmia.
Näyttää kuitenkin siltä että käytännössä mikään yastiin viittaava ei toimi kuin salasanan kysymiseen saakka. Esim. käyttäjien lisääminen tyssää salasanan kysymiseen kuten myöäs kielen vaihtaminen.

Lainaus
Avaa /etc/sysconfig/yast2 tiedosto root -käyttäjänä.
Vaihda WANTED_GUI="auto" muotoon WANTED_GUI="qt", tallenna ja poistu tiedostosta.
Jos haluat takaisin tuon gtk-version (riippumatta käyttöympäristöstä) muuta WANTED_GUI muotoon WANTED_GUI="gtk".
Mainio vinkki, näyttää tosiaan selkeämmältä ja paremmalta. Kiitoksia.

[edit]
Niin, olen varma että salasanaa en kirjoita väärin  ;D

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #15 : 20.01.2008 - klo:15:33 »
Mutta vieläkään en tiedä onko kyseessä CD-asennus?
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #16 : 20.01.2008 - klo:15:35 »
Hups, juu. CD asennus.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #17 : 20.01.2008 - klo:15:38 »
Poista CD asennuslähteistä.

Listaa asennuslähteet
zypper sl

katso mikä on cd:n numero ja komenna poistaaksesi

zypper rr <numero>
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

E.K.Virtanen

  • Vieras
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #18 : 20.01.2008 - klo:15:45 »
zypper sl tuottaa seuraavaa
Koodia: [Valitse]
# | Enabled | Refresh | Type   | Alias                                                             | Name                       
--+---------+---------+--------+-------------------------------------------------------------------+-----------------------------
1 | Yes     | Yes     | rpm-md | UPDATE                                                            | UPDATE                     
2 | Yes     | Yes     | rpm-md | openSUSE-10.3-Updates                                             | openSUSE-10.3-Updates       
3 | Yes     | No      | yast2  | OSS                                                               | OSS                         
4 | Yes     | Yes     | yast2  | http://download.opensuse.org/distribution/10.3/repo/non-oss/      | Main Repository (NON-OSS)   
5 | Yes     | Yes     | yast2  | http://download.opensuse.org/repositories/openSUSE:10.3/standard/ | Main Repository (OSS)       
6 | Yes     | No      | yast2  | NON-OSS                                                           | NON-OSS                     
7 | Yes     | No      | yast2  | openSUSE-10.3-OSS-Gnome 10.3                                      | openSUSE-10.3-OSS-Gnome 10.3
Jos en nyt ihan päin honkia ajattele niin cd on noista joko numero 7, tai sitä ei siellä ole?
Yrittäessäni poistaa lähdettä, saan tulosteen
Repository not found by given alias or URL.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Ei pysty asentamaan ohjelmia.
« Vastaus #19 : 20.01.2008 - klo:16:09 »
Voit poistaa sen myös /etc/zypp/repos.d/-hakemiston kautta root-käyttäjänä.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)