Kirjoittaja Aihe: Nvidian ajuri ei asennu  (Luettu 23896 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #40 : 20.09.2007 - klo:20:59 »
Sitten se on huonompi juttu, eli näytönohjainta ei tunnisteta (oikein/ollenkaan).

Kokeiles vielä komentaa

su -c lspci
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #41 : 20.09.2007 - klo:21:02 »
Sori kielimuuri (koitin tuota avata tuolta kansioiden kautta, vaatisi vissiin aivopesun tuon XP:n jälkeen)
tuolla on http://pastebin.com/m644c107c

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #42 : 20.09.2007 - klo:21:03 »
Kokeile komentaa

su -c switch2nvidia
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #43 : 20.09.2007 - klo:22:18 »
Lainaus
Kokeile komentaa

su -c switch2nvidia
Komennanko nyt eli vesa ajuri käytössä, vai asennanko tuon nvidia ajurin ensin.Konsolessa vai ihan oikealla komentorivillä,roottina vai omilla tunnuksilla
Ei tämä oikeasti ole niin helppoa ;)

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #44 : 20.09.2007 - klo:22:35 »
Jos ajuri on jo asennettuna, tuo komento vaihtaa sen käyttöön.

Mutta kokeilemalla oppii ;)
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

guest158

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #45 : 20.09.2007 - klo:23:18 »
tota, mä oon kyll switch:llä vaihtanu vaan käliä...

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #46 : 21.09.2007 - klo:00:25 »
Tulipahan tässä keskellä työ"päivää" mieleen tällainen juttu, en kyllä tiedä onko tää teoriassakaan mahdollista.
Eli näytönohjaimessa kun on kolme liitäntää VGA , DVI ja S-video, onko mahdollista että tuo nvidian ajuri käyttäisi tuota DVI:tä jossa ei ole näyttöä kiinni ja vesa ajuri käyttäisi tuota VGA:ta jossa on näyttö.

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Nvidian ajuri ei asennu
« Vastaus #47 : 21.09.2007 - klo:01:03 »
onko mahdollista että tuo nvidian ajuri käyttäisi tuota DVI:tä jossa ei ole näyttöä kiinni ja vesa ajuri käyttäisi tuota VGA:ta jossa on näyttö.

En oikein usko. Ainakin oma fx 5200 toimii käyttää kumpaa tahansa.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #48 : 21.09.2007 - klo:05:35 »
tota, mä oon kyll switch:llä vaihtanu vaan käliä...


Koodia: [Valitse]
jmp@ambrym:~> su -c switch2nvidia
Salasana:
------------------------------------------------------------------------
Switching the use of "nv" driver of X.Org to "nvidia" driver of NVIDIA
------------------------------------------------------------------------

# SaX generated X11 config file
Patching /etc/X11/xorg.conf ... done

Sitten joko kirjaudutaan ulos  tai painetaan [Ctrl]+[Alt]+[<--] ja kirjaudutaan uudelleen.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

guest158

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #49 : 21.09.2007 - klo:08:52 »
No OK - taas oppi jotain 'ennennäkemätöntä' ;-)
mutt ei se mitään - ei tää todennäköisesti jää viimeiseksi...
...niin jos Luoja suo...

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #50 : 21.09.2007 - klo:22:37 »
Koitin tuota asennusta taas
WIKI:sta löytyvä skripti kotikansiossa
sh /home/mikko/haeNVIDIA.sh
hakee ajurit
käynnistää nvidia asennusohjelman
lopuksi sanoo että ajuri asennettu
sax2 ei pysty käynnistymään, käskee katsomaan SaX.log, joka on tuossa alla
http://pastebin.com/m56156e17
WW:tä löytyy, sen verran tuosta ymmärrän jopa minä, ettei se ole hyvä juttu

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #51 : 21.09.2007 - klo:22:50 »
tota, mä oon kyll switch:llä vaihtanu vaan käliä...


Koodia: [Valitse]
jmp@ambrym:~> su -c switch2nvidia
Salasana:
------------------------------------------------------------------------
Switching the use of "nv" driver of X.Org to "nvidia" driver of NVIDIA
------------------------------------------------------------------------

# SaX generated X11 config file
Patching /etc/X11/xorg.conf ... done

Sitten joko kirjaudutaan ulos  tai painetaan [Ctrl]+[Alt]+[<--] ja kirjaudutaan uudelleen.

Koitin totakin...vastassa tuttu musta ruutu

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #52 : 21.09.2007 - klo:23:33 »
Koitin totakin...vastassa tuttu musta ruutu

Tämän virheen jälkeinen Xorg.0.log kiinnostaisi.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #53 : 22.09.2007 - klo:03:11 »
Koitin totakin...vastassa tuttu musta ruutu

Tämän virheen jälkeinen Xorg.0.log kiinnostaisi.

Tuossahan tuo  http://pastebin.com/m1c34adb9
Alkaakohan pingviiniasentajakin oppia, eikös tuossa ole näytön kohdalla ihan väärät tiedot

Näyttöhän oli siis HP 19" Kuvaputkiruutu

nämä arvot löytyi netistä

scanning frequensy. horizontal 30 to 96 kHz
                                 vertical 50 to 200 Hz
max. resolution 1600x1200 (75 Hz)
pixel clock 203 MHz
image size standard 350(H)x262(v)
                  maximum 365(H)x274(v)

Poissa arijoutsi

  • Käännösryhmä
  • *
  • Viestejä: 2062
  • Sukupuoli: Mies
Vs: Nvidian ajuri ei asennu
« Vastaus #54 : 22.09.2007 - klo:08:16 »
Koitin totakin...vastassa tuttu musta ruutu

Tämän virheen jälkeinen Xorg.0.log kiinnostaisi.

Tuossahan tuo  http://pastebin.com/m1c34adb9
Alkaakohan pingviiniasentajakin oppia, eikös tuossa ole näytön kohdalla ihan väärät tiedot

Näyttöhän oli siis HP 19" Kuvaputkiruutu

nämä arvot löytyi netistä

scanning frequensy. horizontal 30 to 96 kHz
                                 vertical 50 to 200 Hz
max. resolution 1600x1200 (75 Hz)
pixel clock 203 MHz
image size standard 350(H)x262(v)
                  maximum 365(H)x274(v)

Näyttää olevan liian korkeat arvot ja putkinäytöllä tapahtuu sitten juuri noin, eli pimenee. Voit vaihtaa xorgiin käsin oikeat arvot. Myös sax2 voit sen tehdä.
HP Elite book, openSUSE Leap 15.2
Mac mini Catalina.
Puhelin, iPhone SE.

Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #55 : 22.09.2007 - klo:08:54 »
Tämän virheen jälkeinen Xorg.0.log kiinnostaisi.

Tuossahan tuo  http://pastebin.com/m1c34adb9
Alkaakohan pingviiniasentajakin oppia, eikös tuossa ole näytön kohdalla ihan väärät tiedot

Toi oli väärä pätkä, oikea löytyy paikasta

/var/log/Xorg.0.log



SaX2 osaa, jos näytön ajuri-CD löytyy, hakea siitä oikeat arvot.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #56 : 22.09.2007 - klo:10:01 »


Toi oli väärä pätkä, oikea löytyy paikasta

/var/log/Xorg.0.log

SaX2 osaa, jos näytön ajuri-CD löytyy, hakea siitä oikeat arvot.

Sori taas, tuolla siis Xorg.0.log   http://pastebin.com/m16a6b52b
näytölle ei kyllä CD:tä löydy




Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4553
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Nvidian ajuri ei asennu
« Vastaus #57 : 22.09.2007 - klo:10:07 »
Kokeile päivittää xorg

lisää asennuslähteeksi

zypper sa http://download.opensuse.org/repositories/xorg73/openSUSE_10.2/ Xorg73

Kun olet tuon lisännyt niin suorita

zypper up -t package
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Pinniivi

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #58 : 23.09.2007 - klo:03:52 »
Kokeile päivittää xorg

lisää asennuslähteeksi

zypper sa http://download.opensuse.org/repositories/xorg73/openSUSE_10.2/ Xorg73

Kun olet tuon lisännyt niin suorita

zypper up -t package

Tuosta xorgin päivityksestä oli ilmeisesti apua.
Vieläkin tuon NVidia asennusohjelman lopussa tuleva sax päätyi mustaan ruutuun,
mutta kun koneen käynnisti uudelleen valinnalla 3, ja kirjoitti tuon
Koodia: [Valitse]
sax2 -r -m 0=nvidianiin johan välähti NVidian logo ;D

Kiitos kaikille !!! toistaiseksi ;)

guest158

  • Vieras
Vs: Nvidian ajuri ei asennu
« Vastaus #59 : 23.09.2007 - klo:10:55 »
...sanoinhan sen kaksikin kertaa... muttku xxx no jaa antaa olla

Mihin sä sitä maagista sax2 -r -m 0=nvidia -komentoa sitt oikein kirjoitit, jos et siinä tekstitilassa ollessasi, kuten ohje kehoitti?
Tämä vaan siksi, ett osaisin minäkin olla vielä tarkempi vinkkejä antaessani

Mutt loppu hyvin - en sano, kaikki hyvin

sanon vaan TAAS, ett kantsii lukee ja vielä noudattaakin niitä ohjeita
...vaikka kuinka loukkaantuisit!
ja yksityisiä(kin) moitekirjeitä saisin