Kirjoittaja Aihe: Murmutusta ohjelmien huononemisesta: Kate, LibreOffice  (Luettu 3501 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 683
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Eipä tälle kukaan taida mitään mahtaa, mutta harmittaa: miksi ihmeessä ohjelma toisensa jälkeen muuttuu jatkuvasti huonompaan suuntaan? Hyviä ominaisuuksia vähennetään, bugeja ei korjata mutta silmäkarkkia lisätään. Gaah :o

Viimeisimpinä huononnuksina openSUSE 12.3:sta bongasin nämä:

  • Katen ”ytimestä” on poistunut vanha hyvä sulkutäydennysjärjestelmä. Periaatteessa se on siirretty AutoBrace-nimiseen ”laajennukseen” mutta huonompana. Avaavan sulkeen (tai lainausmerkin) kirjoittaminen lisää automaattisesti päättävän sulkeen enää, kun kohdistimen oikealla puolen on tyhjää – ei sanan alussa tai keskellä sitä. Vielä ikävämpää on se, että avaavan sulkeen kirjoittaminen, kun tekstiä on valittu, ei enää sijoita valittua tekstiä sulkeisiin.
  • LibreOfficesta näkyy nyt kadonneen (vai onko näin vain openSUSEssa?) mahdollisuus telakoida tyyli-ikkuna asiakirjaikkunaan. Käytännössä tämä johtaa vanhan Gimpin tapaiseen tilanteeseen, jossa pikkuruista apuikkunaa täytyy kaiken aikaa siirrellä pois tieltä työtä tehdessään.

Katen laajennuksen puutteista kirjoittelin jo sähköpostin laajennuksen tekijälle. LibreOfficen kohdalla täytyy vielä tarkistaa, onko ongelma jakelukohtainen (näin nimittäin on joskus ollut jo aiemmissakin LO:n versioissa) vai todella 4.0:n ”ominaisuus”.
Debian GNU/Linux 10 (pöytäkoneet 1 & 2, kannettava 2), openSUSE Leap 15.1 (kannettava 1), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2), Haiku R1 Beta 1 (kannettava 3)

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 683
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Murmutusta ohjelmien huononemisesta: Kate, LibreOffice
« Vastaus #1 : 17.03.2013 - klo:16:46 »
Katen uusi laajennus on pahemminkin puutteellinen kuin aluksi edes tajusin: se ei täydennä aaltosulkeitakaan {} kuin TeX-tiedostoissa. Python-koodauksen kannalta laajennus on siis täysi torso.

En kuitenkaan näytä olevan ainoa murmuttaja, koska torsoudesta on tehty jo KDE:n bugiraportti.

Bugiraportista löytyy myös täydellisempi laajennus BraceSane, joka tuntuu toimivan kunnolla. Asennus vain on vähän mutkikasta:

  • puretaan paketti jonnekin
  • asennetaan tarpeellisia paketteja, mm. cmake, make, kdebase4-workspace-devel
  • ajetaan ”cmake .” ja jos se toimii, ”make”, ”make install” (viimeisin ylläpitäjäoikeuksin)
  • korjataan /usr/local-puuhun menneiden alikansioiden oikeuksia (chmod -R go+rX) sekä symlinkataan tiedostot local-puusta /usr-puuhun (muoks: ei tarpeen, kun muistaa antaa cmakelle parametrin -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix`)

Toivottavasti joku joskus tekee tästä paketin tai mikä vielä parempaa, korjaa Katen oletusarvoisen torson paketin, jottei tätä joudu aina tekemään itse.
« Viimeksi muokattu: 17.03.2013 - klo:22:31 kirjoittanut SuperOscar »
Debian GNU/Linux 10 (pöytäkoneet 1 & 2, kannettava 2), openSUSE Leap 15.1 (kannettava 1), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2), Haiku R1 Beta 1 (kannettava 3)

Poissa SuperOscar

  • Käännösryhmä
  • *
  • Viestejä: 683
  • Sukupuoli: Mies
  • Tänään täällä, huomenna poissa
    • Legisign.org
Vs: Murmutusta ohjelmien huononemisesta: Kate, LibreOffice
« Vastaus #2 : 17.03.2013 - klo:22:11 »
Katen uuden AutoBrace-laajennuksen tekijä Jakob Petsovits tuntuu sähköpostitse olevan yhtä ymmällään tapahtuneesta kuin minäkin. Hän kirjoitti laajennuksen kuulemma lähinnä huvikseen eikä ole vastuussa päätöksestä tehdä siitä pääasiallinen korvaaja itse ohjelmasta kadonneelle toiminnallisuudelle. Hänkin viittasi tuohon mainitsemaani bugiraporttiin ja kehotti siirtämään murmutuksen sinne.

Muoks: Korjasin ylle linkin viimeisimpään BraceSane-laajennuksen versioon KDE Bugtrackingin säikeessä. Myös tämän paremman laajennuksen kirjoittaja Dimitar Pashov tuntuu toivovan toiminnallisuuden palaavan paikalleen Katen ytimeen, koska sen toteuttaminen laajennuksena ei ilmeisesti ole mutkatonta.
« Viimeksi muokattu: 17.03.2013 - klo:22:32 kirjoittanut SuperOscar »
Debian GNU/Linux 10 (pöytäkoneet 1 & 2, kannettava 2), openSUSE Leap 15.1 (kannettava 1), LibreELEC 8.2.5 (RPi 1), Raspbian GNU/Linux 10 (RPi 2), Haiku R1 Beta 1 (kannettava 3)