Kirjoittaja Aihe: Canon MP600 ei asennu  (Luettu 2506 kertaa)

0 jäsentä ja 1 Vieras katselee tätä aihetta.

Poissa nonac

  • Jäsen
  • Viestejä: 13
Canon MP600 ei asennu
« : 29.03.2009 - klo:14:22 »
Tervehdys!

Sain pitkän temuamisen jälkeen asennettua 64-bit openSUSE:n. Aika hyvältä näyttää.
Melkein kaikki on saatu toimimaan. 2. päivän linuxkokemuksella ihan hyvin.

Ainoa suurempi murhe on Canon MP600 tulostin.

Siihen löytyy ajurit cnijfilter-common-2.70-2.src.rpm ja cnijfilter-mp600-2.70-2.i386.rpm vuodelta 2007
mutta noiden pakettien asentaminen pyytää mm. paketteja
libgdk
libxml
Gtk+
libgtk
libpng
libpopt

ja noi ei asennu, kun noista on jo uudemmatkin versiot olemassa, tjsp

Onko mitään tehtävissä?





Poissa jmp

  • openSUSE Member
  • *
  • Viestejä: 4526
  • Sukupuoli: Mies
    • openSUSEa suomeksi
Vs: Canon MP600 ei asennu
« Vastaus #1 : 29.03.2009 - klo:15:04 »
kokeile komentaa hakemistossa jossa tuo cnijfilter-mp600-2.70-2.i386.rpm on seuraavasti

Koodia: [Valitse]
su -c 'zypper install ./cnijfilter-mp600-2.70-2.i386.rpm'

Jos tuo herjaa jotain niin laita tuloste tänne.
Ja muistakaa pitää hauskaa ;)

openSUSE Tumbleweed (x86_64)

Poissa nonac

  • Jäsen
  • Viestejä: 13
Vs: Canon MP600 ei asennu
« Vastaus #2 : 29.03.2009 - klo:16:55 »
Jos tuo herjaa jotain niin laita tuloste tänne.
Kiitos ohjeesta!
Ei tullut mitään herjaa.
Jossain on vielä bitti poikittain, kun tulostukset näkyvät jonossa, mutta tulostin pysyy mykkänä.
(boottauksia on tehty ja tulostinjonoa on tyhjennetty)

Ilmeisesti Cups:n avulla(http://localhost:631) tulostinta on hyvä manageroida?

Poissa nonac

  • Jäsen
  • Viestejä: 13
Vs: Canon MP600 ei asennu
« Vastaus #3 : 29.03.2009 - klo:20:00 »
Skannaaminen ja muistinkortinlukija toimivat jo, mutta tulostaminen ei toimi.
Olisiko jollakin ideoita usb tulostimen virittelyyn?

Poissa nonac

  • Jäsen
  • Viestejä: 13
Vs: Canon MP600 ei asennu (RATKAISTU)
« Vastaus #4 : 30.03.2009 - klo:15:11 »
No nyt lähti tulostaminen pelittämään tässä 64 bittisessäkin...

except for the problem that cups looked for /usr/lib64/cups/filter/pstocanonij, but this file was installed in /usr/lib/cups/filter/pstocanonij. Since I had the necessary 32 bit libs installed, I solved the problem by just setting a link from the /usr/lib64/... file to /usr/lib/...